Cannot login the system after upgraded from 13.10 to 14.04

Bug #1298237 reported by HuangZhiquan on 2014-03-27
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Kylin
Critical
Ma Jun
ubuntukylin-default-settings
Undecided
Unassigned
ubuntukylin-default-settings (Ubuntu)
High
ShuiLu Pi

Bug Description

After upgraded from 13.10 to 14.04 at i386, Unity can't be started.

HuangZhiquan (huangzhiquan) wrote :
Changed in ubuntukylin:
importance: Undecided → Critical
summary: - cannot login the system
+ Cannot login the system after upgrade from 13.10 to 14.04

when I check the error log, I find the file /usr/share/gnome-session/sessions/ubuntu.session doesn't exist. when I study further,
In 13.10, the file is included in the package gnome-session, but in 14.04, this is included in another package ubuntu-session, and ubuntu-session package is a new package in 14.04.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1298237

tags: added: iso-testing
Jack Yu (jackyu) wrote :

Yep, I think so. It's due to the replacement from gnome-session to ubuntu-session.

Changed in ubuntukylin:
milestone: none → trusty-final-freeze
description: updated
summary: - Cannot login the system after upgrade from 13.10 to 14.04
+ Cannot login the system after upgraded from 13.10 to 14.04
Ma Jun (maclin.jun) wrote :

this bug is similar with Bug #1288903, the main problem is: the ubuntu-session package was not installed when update.

I check that the ubuntu-session package is installed on the new installed 14.04.

Ma Jun (maclin.jun) wrote :
Jean-Baptiste Lallement (jibel) wrote :

This is because on Ubuntu Desktop, ubuntu-session is installed as dependency of ubuntu-desktop. But on Ubuntu Kylin, ubuntu-desktop is not installed.

Changed in ubuntukylin:
status: New → Confirmed
Jack Yu (jackyu) wrote :

Hi jibel, if we add ubuntu-desktop into ubuntukylin-default-settings, would this bug be fixed?

Steve Langasek (vorlon) wrote :

I believe the ubuntu-desktop package is not installed because ubuntukylin-default-settings modifies the default Ubuntu install with package removals, not just package installs, so the image build would not work as expected with a dependency on ubuntu-desktop.

Ultimately I believe ubuntukylin should move to using seeds and a metapackage, but that's not a "quick fix" for 14.04.

The quick fix would be to manually add any missing packages as depends/recommends to ubuntukylin-default-settings.

Aron Xu (happyaron) on 2014-04-16
Changed in ubuntukylin-default-settings (Ubuntu):
assignee: nobody → ShuiLu Pi (pishuilu1128)
importance: Undecided → High
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntukylin-default-settings - 1.1.7

---------------
ubuntukylin-default-settings (1.1.7) trusty; urgency=low

  [ Shuilu Pi ]
  * Add ubuntu-session to Recommends (LP: #1298237)
  * Add back Korean font

  [ Anthony Wong ]
  * Improve search engine settings for Chromium
 -- Aron Xu <email address hidden> Wed, 16 Apr 2014 15:37:53 +0800

Changed in ubuntukylin-default-settings (Ubuntu):
status: In Progress → Fix Released
Jack Yu (jackyu) on 2014-04-16
Changed in ubuntukylin:
status: Confirmed → Fix Committed
Changed in ubuntukylin-default-settings:
status: New → Fix Released
Changed in ubuntukylin:
assignee: nobody → Ma Jun (maclin.jun)
Jack Yu (jackyu) on 2014-04-17
Changed in ubuntukylin:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers