grub-install error caused by additional space character

Bug #1258043 reported by jiaowen520li on 2013-12-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Kylin
High
Jack Yu
ubuntukylin-default-settings (Ubuntu)
High
ShuiLu Pi

Bug Description

即将安装完成时,出现GRUB相关报错弹框,点击确定后还是会出现安装完成需要重启的弹框,只是grub有问题,进不了安装好的系统。

相关日志信息:
Dec 5 03:36:05 ubuntukylin grub-installer: info: architecture: amd64/generic
Dec 5 03:36:05 ubuntukylin ubiquity: File descriptor 3 (pipe:[32117]) leaked on lvdisplay invocation. Parent PID 19765: /bin/sh
Dec 5 03:36:06 ubuntukylin ubiquity: Volume group "sda" not found
Dec 5 03:36:06 ubuntukylin ubiquity: Skipping volume group sda
Dec 5 03:36:06 ubuntukylin grub-installer: info: Identified partition label for /dev/sda1: msdos
Dec 5 03:36:07 ubuntukylin grub-installer: dpkg: warning: ignoring request to remove grub which isn't installed
Dec 5 03:36:07 ubuntukylin grub-installer: dpkg: warning: ignoring request to remove grub-legacy which isn't installed
Dec 5 03:36:07 ubuntukylin grub-installer: dpkg: warning: ignoring request to remove grub-efi which isn't installed
Dec 5 03:36:07 ubuntukylin grub-installer: dpkg: warning: ignoring request to remove grub-efi-amd64-bin which isn't installed
Dec 5 03:36:07 ubuntukylin grub-installer: dpkg: warning: ignoring request to remove grub-efi-amd64 which isn't installed
Dec 5 03:36:07 ubuntukylin grub-installer: dpkg: warning: ignoring request to remove grub-efi-amd64-signed which isn't installed
Dec 5 03:36:07 ubuntukylin grub-installer: dpkg: warning: ignoring request to remove grub-efi-ia32-bin which isn't installed
Dec 5 03:36:07 ubuntukylin grub-installer: dpkg: warning: ignoring request to remove grub-efi-ia32 which isn't installed
Dec 5 03:36:07 ubuntukylin grub-installer: info: Installing grub on '/dev/sda'
Dec 5 03:36:08 ubuntukylin grub-installer: info: grub-install does not support --no-floppy
Dec 5 03:36:08 ubuntukylin grub-installer: info: Running chroot /target grub-install --force "/dev/sda"
Dec 5 03:36:08 ubuntukylin grub-installer: /usr/sbin/grub-install: 10: /etc/default/grub: Kylin: not found
Dec 5 03:36:11 ubuntukylin grub-installer: Installation finished. No error reported.
Dec 5 03:36:11 ubuntukylin grub-installer:
Dec 5 03:36:11 ubuntukylin grub-installer: info: grub-install ran successfully
Dec 5 03:36:11 ubuntukylin ubiquity: Setting partition 1 of /dev/sda to active... done.
Dec 5 03:36:13 ubuntukylin in-target: /usr/sbin/grub-mkconfig: 10: /etc/default/grub: Kylin: not found
Dec 5 03:36:13 ubuntukylin grub-installer: error: Running 'update-grub' failed.

jiaowen520li (jiaowen520li) wrote :

错误发现于今日的UK-Daily(2013-12-04)系统安装。

jiaowen520li (jiaowen520li) wrote :
jiaowen520li (jiaowen520li) wrote :
jiaowen520li (jiaowen520li) wrote :
description: updated
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1258043

tags: added: iso-testing
Huan Peng (penghuanmail) wrote :
Aron Xu (happyaron) on 2013-12-05
description: updated
Aron Xu (happyaron) on 2013-12-05
summary: - 安装过程中出现GRUB相关报错,导致系统无法被正常安装。
+ grub-install error caused by additional space character
Changed in ubuntukylin-default-settings (Ubuntu):
assignee: nobody → ShuiLu Pi (pishuilu1128)
importance: Undecided → High
status: New → Triaged
Jack Yu (jackyu) on 2013-12-05
Changed in ubuntukylin:
milestone: none → trusty-alpha1
assignee: nobody → Jack Yu (jackyu)
importance: Undecided → High
Aron Xu (happyaron) on 2013-12-06
Changed in ubuntukylin-default-settings (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntukylin-default-settings - 1.0.12

---------------
ubuntukylin-default-settings (1.0.12) trusty; urgency=low

  [ Shuilu Pi ]
  * Fix escape of space character in shell. (LP: #1258043)
 -- Aron Xu <email address hidden> Fri, 06 Dec 2013 23:42:02 +0800

Changed in ubuntukylin-default-settings (Ubuntu):
status: Fix Committed → Fix Released
Aron Xu (happyaron) on 2013-12-07
Changed in ubuntukylin:
status: New → Fix Committed
Jack Yu (jackyu) on 2013-12-09
Changed in ubuntukylin:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers