Cannot enter password to unlock encryption in 4.10

Bug #1724564 reported by Vadim Peretokin on 2017-10-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Joseph Salisbury
Zesty
High
Joseph Salisbury

Bug Description

I'm unable to enter my password on the screen to unlock the disk during boot using kernels 4.10.0-35 and 4.10.0-37. Using the 4.9.45-040945 mainline kernel seems to work fine.
---
ApportVersion: 2.20.4-0ubuntu4.5
Architecture: amd64
CurrentDesktop: Unity:Unity7
DistroRelease: Ubuntu 17.04
EcryptfsInUse: Yes
InstallationDate: Installed on 2017-02-15 (245 days ago)
InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
Package: linux (not installed)
Tags: zesty
Uname: Linux 4.9.45-040945-generic x86_64
UnreportableReason: The running kernel is not an Ubuntu kernel
UpgradeStatus: Upgraded to zesty on 2017-05-24 (147 days ago)
UserGroups: adm cdrom dip docker lpadmin plugdev sambashare sudo wireshark
_MarkForUpload: True

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1724564

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: kernel-da-key

apport information

tags: added: apport-collected zesty
description: updated

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Vadim Peretokin (vperetokin) wrote :

It's a bit of a problem since this is blocking me from upgrading to Ubuntu 17.10.

Vadim Peretokin (vperetokin) wrote :

This issue is also preventing me from using paid snap applications (Hiri for access to email for work) so it is rather urgent. Any other information I can provide for this?

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.14 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.14-rc6

Changed in linux (Ubuntu):
importance: Medium → High
Vadim Peretokin (vperetokin) wrote :

The mainline kernel is the only one I can actually use.

Joseph Salisbury (jsalisbury) wrote :

I see you posted you are using 4.9.45 in the bug description. Does v4.14-rc6 also work? It would be good to know to narrow down if we can bisect this issue and/or if its Ubuntu specific.

Vadim Peretokin (vperetokin) wrote :

Ah, I see. Yes, v4.14-rc6 allows me to enter the disk password, however wifi does not work: Ubuntu thinks the laptop has no wifi capability.

Joseph Salisbury (jsalisbury) wrote :

Can you test the 4.10.0-38 kernel in Zesty -proposed:
https://launchpad.net/~canonical-kernel-team/+archive/ubuntu/ppa/+build/13563574

If it has the bug, please test Artful:
https://launchpad.net/~canonical-kernel-security-team/+archive/ubuntu/ppa2/+build/13567624

To test these two kernels, install both the linux-image and linux-image-extra .deb packages.

tags: added: performing-bisect
Download full text (6.0 KiB)

The first one couldn't install:

vadi@volga:~/Downloads$ ls
2410125510310.pdf linux-headers-4.10.0-38-generic_4.10.0-38.42_amd64.deb
FML_FTE(1).pdf linux-image-4.10.0-38-generic_4.10.0-38.42_amd64.deb
FML_FTE.pdf
linux-image-extra-4.10.0-38-generic_4.10.0-38.42_amd64.deb
vadi@volga:~/Downloads$ sudo dpkg -i linux-*
[sudo] password for vadi:
Selecting previously unselected package linux-headers-4.10.0-38-generic.
(Reading database ... 397002 files and directories currently installed.)
Preparing to unpack linux-headers-4.10.0-38-generic_4.10.0-38.42_amd64.deb
...
Unpacking linux-headers-4.10.0-38-generic (4.10.0-38.42) ...
Selecting previously unselected package linux-image-4.10.0-38-generic.
Preparing to unpack linux-image-4.10.0-38-generic_4.10.0-38.42_amd64.deb ...
Examining /etc/kernel/preinst.d/
run-parts: executing /etc/kernel/preinst.d/intel-microcode
4.10.0-38-generic /boot/vmlinuz-4.10.0-38-generic
Done.
Unpacking linux-image-4.10.0-38-generic (4.10.0-38.42) ...
Selecting previously unselected package linux-image-extra-4.10.0-38-generic.
Preparing to unpack
linux-image-extra-4.10.0-38-generic_4.10.0-38.42_amd64.deb ...
Unpacking linux-image-extra-4.10.0-38-generic (4.10.0-38.42) ...
dpkg: dependency problems prevent configuration of
linux-headers-4.10.0-38-generic:
 linux-headers-4.10.0-38-generic depends on linux-headers-4.10.0-38;
however:
  Package linux-headers-4.10.0-38 is not installed.

dpkg: error processing package linux-headers-4.10.0-38-generic (--install):
 dependency problems - leaving unconfigured
Setting up linux-image-4.10.0-38-generic (4.10.0-38.42) ...
Running depmod.
update-initramfs: deferring update (hook will be called later)
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal
4.10.0-38-generic /boot/vmlinuz-4.10.0-38-generic
run-parts: executing /etc/kernel/postinst.d/dkms 4.10.0-38-generic
/boot/vmlinuz-4.10.0-38-generic
ERROR (dkms apport): kernel package linux-headers-4.10.0-38-generic is not
supported
Error! Bad return status for module build on kernel: 4.10.0-38-generic
(x86_64)
Consult /var/lib/dkms/i915-4.11.6-4.10.0/1/build/make.log for more
information.
run-parts: executing /etc/kernel/postinst.d/initramfs-tools
4.10.0-38-generic /boot/vmlinuz-4.10.0-38-generic
update-initramfs: Generating /boot/initrd.img-4.10.0-38-generic
run-parts: executing /etc/kernel/postinst.d/pm-utils 4.10.0-38-generic
/boot/vmlinuz-4.10.0-38-generic
run-parts: executing /etc/kernel/postinst.d/unattended-upgrades
4.10.0-38-generic /boot/vmlinuz-4.10.0-38-generic
run-parts: executing /etc/kernel/postinst.d/update-notifier
4.10.0-38-generic /boot/vmlinuz-4.10.0-38-generic
run-parts: executing /etc/kernel/postinst.d/zz-update-grub
4.10.0-38-generic /boot/vmlinuz-4.10.0-38-generic
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.14.0-041400rc6-generic
Found initrd image: /boot/initrd.img-4.14.0-041400rc6-generic
Found linux image: /boot/vmlinuz-4.10.0-38-generic
Found initrd image: /boot/initrd.img-4.10.0-38-generic
Found linux image: /boot/vmlinuz-4.10.0-37-generic
Found initrd image: /boot/initrd.img-4.10.0-37-generic
Found linux image: /boot/vmlinuz-4.10.0-35...

Read more...

Joseph Salisbury (jsalisbury) wrote :

You shouldn't need the headers .deb files. Can you try just installing linux-image and linux-image-extra?

Vadim Peretokin (vperetokin) wrote :

I did - the 4.10.0-38 kernel did the trick. Looks like it has been fixed in the upcoming release?

Joseph Salisbury (jsalisbury) wrote :

That is correct, -proposed is the next kernel to be released to -updates.

Changed in linux (Ubuntu Zesty):
status: New → Fix Committed
assignee: nobody → Joseph Salisbury (jsalisbury)
importance: Undecided → High
Changed in linux (Ubuntu):
assignee: nobody → Joseph Salisbury (jsalisbury)
status: Confirmed → Fix Committed
Vadim Peretokin (vperetokin) wrote :

It either worked then or I booted the wrong kernel. 4.10.0-38 and today's 4.10.0-39 are not working, so I am back to using in 4.9.45-040945 order to be able to access the machine.

Changed in linux (Ubuntu):
status: Fix Committed → New
Changed in linux (Ubuntu Zesty):
status: Fix Committed → New

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1724564

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu Zesty):
status: New → Incomplete
Joseph Salisbury (jsalisbury) wrote :

Can you see if this bug also happens with the Artful kernel:
https://launchpad.net/~canonical-kernel-security-team/+archive/ubuntu/ppa2/+build/13567624

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers