gnome-shell crashed with SIGSEGV in __GI___libc_free() from g_free() from gweather_location_unref() from g_boxed_free() from boxed_finalize()

Bug #1688209 reported by errors.ubuntu.com bug bridge on 2017-05-04
30
This bug affects 3 people
Affects Status Importance Assigned to Milestone
GNOME Shell
Confirmed
High
gnome-shell (Ubuntu)
High
Unassigned
Zesty
Undecided
Unassigned
libgweather (Ubuntu)
Undecided
Unassigned
Zesty
Undecided
Unassigned

Bug Description

The Ubuntu Error Tracker has been receiving reports about a problem regarding gnome-shell. This problem was most recently seen with package version 3.24.1-0ubuntu3, the problem page at https://errors.ubuntu.com/problem/36de667464128521f03dbe854aea86811961f4f0 contains more details, including versions of packages affected, stacktrace or traceback, and individual crash reports.
If you do not have access to the Ubuntu Error Tracker you can request it at http://forms.canonical.com/reports/.

tags: added: regression-update
Jeremy Bicha (jbicha) on 2017-05-10
Changed in gnome-shell (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in gnome-shell:
importance: Unknown → High
status: Unknown → Confirmed
Daniel van Vugt (vanvugt) wrote :

Bump. Seems to be crashing the shell in zesty and artful fairly frequently.

summary: - /usr/bin/gnome-
- shell:11:__GI___libc_free:g_free:gweather_location_unref:g_boxed_free:boxed_finalize
+ gnome-shell crashed with SIGSEGV in __GI___libc_free() from g_free()
+ from gweather_location_unref() from g_boxed_free() from boxed_finalize()
Changed in gnome-shell (Ubuntu):
importance: Medium → High
Tim Lunn (darkxst) wrote :

This looks like a duplicate of bug 1693964 based on the stacktrace

Daniel van Vugt (vanvugt) wrote :

The stack trace does not match bug 1616651, and bug 1693964 is also unrelated.

Tim Lunn (darkxst) wrote :

1693964 was a cut and paste fail.
bug 1616651 was the correct one.

The stacktrace is different but it is hitting the same codepath that was suffering memory corruption.

#2 0x00007f4c502ef06b in gweather_location_unref (loc=0x55e7b5c95700) at gweather-location.c:396
        i = <optimized out>
        loc = 0x55e7b5c95700

   g_free (loc->local_name);

I am pretty confident that its the same bug. I saw numerous variatons of stacktraces while debugging the crash.

Daniel van Vugt (vanvugt) wrote :

Have another look at bug 1616651. It does not mention "gweather_location_unref".

Daniel van Vugt (vanvugt) wrote :

However I know you are the original reporter so I won't stand in your way any more. Just suggest being cautious with marking duplicate bugs that have different stack traces. A common outcome from that is people continue to complain their problems actually aren't fixed even after you think you've released a fix. So you need to be very sure it's the same issue or else bugs linger open indefinitely.

Tim Lunn (darkxst) wrote :

right, I apparently mixed up invalid pointer: 0x00 bug at some point, and now my SRU is on the wrong bug! thanks for pointing it out. I'll sort it out

Jeremy Bicha (jbicha) wrote :

Tim, you can ask in #ubuntu-release if you want an unapproved SRU rejected so you can upload a fixed version.

Tim Lunn (darkxst) on 2017-06-03
Changed in gnome-shell (Ubuntu):
status: Triaged → Invalid
Changed in libgweather (Ubuntu):
status: New → Triaged
status: Triaged → Fix Released
Changed in libgweather (Ubuntu Zesty):
status: New → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.