gnome-shell assert failure: *** Error in `/usr/bin/gnome-shell': free(): invalid pointer: 0x00000000082dcf30 *** in g_strfreev() from g_themed_icon_finalize() from g_object_unref() from desktop_entry_unref()

Bug #1616651 reported by chris pollock on 2016-08-24
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
High
Unassigned
libgweather
Fix Released
Medium
gnome-shell (Ubuntu)
Medium
Unassigned
libgweather (Ubuntu)
High
Unassigned
Zesty
High
Unassigned

Bug Description

[Impact]
Backport git patch that fixes memory corruption in libgweather that is causing gnome-shell to crash. This is particularly bad on wayland as it causes the user to lose their sessions

I believe this should also fix bug 1688208 and potentially a couple of other high ranking crashes on errors.ubuntu.com. I have not however found reliable reproducers for those other bugs.

[Test Case]
After update of libgweather
1. Ensure org.gnome.Weather.Application locations is not set (as per default setting)
2. Disable Location Services
3. gnome-shell should not crash

[Regression Potential]
Low, the patch merely fixes a refcounting bug. Given the high impact of this bug, this is an important fix.

======= original bug report ============
This happened while installing Xfce with Synaptic.

chris@localhost:~$ lsb_release -rd
Description: Ubuntu 16.04.1 LTS
Release: 16.04

chris@localhost:~$ apt-cache policy gnome-shell
gnome-shell:
  Installed: 3.18.5-0ubuntu0.1
  Candidate: 3.18.5-0ubuntu0.1
  Version table:
 *** 3.18.5-0ubuntu0.1 500
        500 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages
        100 /var/lib/dpkg/status
     3.18.4-0ubuntu3 500
        500 http://us.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages

ProblemType: CrashDistroRelease: Ubuntu 16.04
Package: gnome-shell 3.18.5-0ubuntu0.1
ProcVersionSignature: Ubuntu 4.4.0-34.53-generic 4.4.15
Uname: Linux 4.4.0-34-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
AssertionMessage: *** Error in `/usr/bin/gnome-shell': free(): invalid pointer: 0x00000000082dcf30 ***
CrashCounter: 1
CurrentDesktop: GNOME
Date: Wed Aug 24 16:21:37 2016
DisplayManager: gdm3
ExecutablePath: /usr/bin/gnome-shell
InstallationDate: Installed on 2014-10-24 (670 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
ProcCmdline: /usr/bin/gnome-shell
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 6SourcePackage: gnome-shell
StacktraceTop:
 __libc_message (do_abort=do_abort@entry=2, fmt=fmt@entry=0x7fabad1e06b0 "*** Error in `%s': %s: 0x%s ***\n") at ../sysdeps/posix/libc_fatal.c:175
 malloc_printerr (ar_ptr=<optimized out>, ptr=<optimized out>, str=0x7fabad1dd48f "free(): invalid pointer", action=3) at malloc.c:5007
 _int_free (av=<optimized out>, p=<optimized out>, have_lock=0) at malloc.c:3868
 __GI___libc_free (mem=<optimized out>) at malloc.c:2969
 g_strfreev () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
Title: gnome-shell assert failure: *** Error in `/usr/bin/gnome-shell': free(): invalid pointer: 0x00000000082dcf30 ***
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
XsessionErrors:
 x-session-manager[7610]: CRITICAL: We failed, but the fail whale is dead. Sorry....
 x-session-manager[14832]: CRITICAL: We failed, but the fail whale is dead. Sorry....
 x-session-manager[5188]: CRITICAL: We failed, but the fail whale is dead. Sorry....

chris pollock (cpollock) wrote :

StacktraceTop:
 __libc_message (do_abort=do_abort@entry=2, fmt=fmt@entry=0x7fabad1e06b0 "*** Error in `%s': %s: 0x%s ***\n") at ../sysdeps/posix/libc_fatal.c:175
 malloc_printerr (ar_ptr=<optimized out>, ptr=<optimized out>, str=0x7fabad1dd48f "free(): invalid pointer", action=3) at malloc.c:5007
 _int_free (av=<optimized out>, p=<optimized out>, have_lock=0) at malloc.c:3868
 __GI___libc_free (mem=<optimized out>) at malloc.c:2969
 g_strfreev () from /tmp/apport_sandbox_Ypcjlo/lib/x86_64-linux-gnu/libglib-2.0.so.0

Changed in gnome-shell (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
information type: Private → Public

Happend on a new install of Artful after installation of gnome-shell and ubuntu-gnome-desktop, logout and login. Crashed during "Welcome to Gnome"

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Tim Lunn (darkxst) on 2017-05-21
Changed in ubuntu-gnome:
milestone: none → artful
Tim Lunn (darkxst) wrote :

This can be reproduced by the following steps:
1. Ensure org.gnome.Weather.Application locations is not set (as per default setting)
2. Disable Location Services
3. gnome-shell will crash

Changed in gnome-shell:
importance: Unknown → Medium
status: Unknown → Confirmed
affects: gnome-shell → libgweather
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libgweather - 3.24.0-0ubuntu3

---------------
libgweather (3.24.0-0ubuntu3) artful; urgency=medium

  * debian/patches/git_guard-against-segfault.patch
    - Backport git patch to fix (LP: #1616651) and hopefully (LP: #1688208)

 -- Tim Lunn <email address hidden> Tue, 23 May 2017 17:18:03 +1000

Changed in libgweather (Ubuntu):
status: New → Fix Released
Changed in gnome-shell (Ubuntu):
status: Confirmed → Invalid
Tim Lunn (darkxst) on 2017-05-26
description: updated
Jeremy Bicha (jbicha) on 2017-05-26
no longer affects: gnome-shell (Ubuntu Zesty)
Changed in libgweather (Ubuntu Zesty):
status: New → In Progress
importance: Undecided → High
Changed in libgweather (Ubuntu):
importance: Undecided → High
Changed in ubuntu-gnome:
status: New → Fix Committed
importance: Undecided → High
summary: gnome-shell assert failure: *** Error in `/usr/bin/gnome-shell': free():
- invalid pointer: 0x00000000082dcf30 ***
+ invalid pointer: 0x00000000082dcf30 *** in g_strfreev() from
+ g_themed_icon_finalize() from g_object_unref() from
+ desktop_entry_unref()
Changed in libgweather:
status: Confirmed → Fix Released
chris pollock (cpollock) wrote :

Gnome shell crashed while updating these packages:

Start-Date: 2018-02-14 08:14:44
Commandline: apt-get -y install libegl1-mesa libegl1-mesa-dev libgbm-dev libgbm1 libgl1-mesa-dev libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libgles2-mesa libgles2-mesa-dev libosmesa6 libwayland-egl1-mesa libxatracker2 mesa-common-dev mesa-vdpau-drivers
Upgrade: libgles2-mesa:amd64 (17.2.4-0ubuntu1~16.04.4, 17.2.8-0ubuntu0~16.04.1), libegl1-mesa-dev:amd64 (17.2.4-0ubuntu1~16.04.4, 17.2.8-0ubuntu0~16.04.1), libglapi-mesa:amd64 (17.2.4-0ubuntu1~16.04.4, 17.2.8-0ubuntu0~16.04.1), libglapi-mesa:i386 (17.2.4-0ubuntu1~16.04.4, 17.2.8-0ubuntu0~16.04.1), mesa-common-dev:amd64 (17.2.4-0ubuntu1~16.04.4, 17.2.8-0ubuntu0~16.04.1), libxatracker2:amd64 (17.2.4-0ubuntu1~16.04.4, 17.2.8-0ubuntu0~16.04.1), libegl1-mesa:amd64 (17.2.4-0ubuntu1~16.04.4, 17.2.8-0ubuntu0~16.04.1), libgbm1:amd64 (17.2.4-0ubuntu1~16.04.4, 17.2.8-0ubuntu0~16.04.1), libwayland-egl1-mesa:amd64 (17.2.4-0ubuntu1~16.04.4, 17.2.8-0ubuntu0~16.04.1), libgles2-mesa-dev:amd64 (17.2.4-0ubuntu1~16.04.4, 17.2.8-0ubuntu0~16.04.1), libgl1-mesa-dev:amd64 (17.2.4-0ubuntu1~16.04.4, 17.2.8-0ubuntu0~16.04.1), libgl1-mesa-dri:amd64 (17.2.4-0ubuntu1~16.04.4, 17.2.8-0ubuntu0~16.04.1), libgl1-mesa-dri:i386 (17.2.4-0ubuntu1~16.04.4, 17.2.8-0ubuntu0~16.04.1), libosmesa6:amd64 (17.2.4-0ubuntu1~16.04.4, 17.2.8-0ubuntu0~16.04.1), libosmesa6:i386 (17.2.4-0ubuntu1~16.04.4, 17.2.8-0ubuntu0~16.04.1), libgl1-mesa-glx:amd64 (17.2.4-0ubuntu1~16.04.4, 17.2.8-0ubuntu0~16.04.1), libgl1-mesa-glx:i386 (17.2.4-0ubuntu1~16.04.4, 17.2.8-0ubuntu0~16.04.1), libgbm-dev:amd64 (17.2.4-0ubuntu1~16.04.4, 17.2.8-0ubuntu0~16.04.1), mesa-vdpau-drivers:amd64 (17.2.4-0ubuntu1~16.04.4, 17.2.8-0ubuntu0~16.04.1), mesa-vdpau-drivers:i386 (17.2.4-0ubuntu1~16.04.4, 17.2.8-0ubuntu0~16.04.1)
End-Date: 2018-02-14 08:19:10

Here is a link to output of /var/log/syslog on PasteBin - https://pastebin.com/q7qsWCKq

chris pollock (cpollock) wrote :

Happened again during software update. Hopefully this is fixed in 18.04LTS

Syslog output here - https://pastebin.com/yhW3ZSJP

Daniel van Vugt (vanvugt) wrote :

Chris,

You seem to have opened two bugs for this crash. Bug 1706203 is almost the same.

If it's still happening then let's continue using bug 1706203.

On Fri, 2018-04-27 at 01:32 +0000, Daniel van Vugt wrote:
> Chris,
>
> You seem to have opened two bugs for this crash. Bug 1706203 is
> almost
> the same.
>
> If it's still happening then let's continue using bug 1706203.
>
Sounds good to me, I'll just have to remember the next time it happens
and 1616651 comes up to actually post any output into 1706203.

--
Chris
KeyID 0xE372A7DA98E6705C
31.11972; -97.90167 (Elev. 1092 ft)
20:57:55 up 3:48, 1 user, load average: 0.91, 0.79, 0.75
Description: Ubuntu 16.04.4 LTS, kernel 4.13.0-39-generic

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.