private mount doesn't work when launching applications from within /tmp

Bug #1592402 reported by Jamie Strandboge on 2016-06-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
snap-confine
Undecided
Unassigned
ubuntu-core-launcher (Ubuntu)
Medium
Jamie Strandboge
Xenial
Medium
Unassigned
Yakkety
Medium
Jamie Strandboge

Bug Description

Thanks to Christian Ehrhardt (paelzer) for finding it, and John Lenton (chipaca) for boiling it down into a digestible mulch.

$ cd /tmp
$ mkdir foo
$ hello-world.sh # from snap install hello-world
bash-4.3$ touch foo/bar
bash-4.3$ exit
$ ls /tmp/foo/
bar

We consider this a bug and not a security vulnerability because it is not attacker controlled.

Changed in ubuntu-core-launcher (Ubuntu Xenial):
status: New → Triaged
Changed in ubuntu-core-launcher (Ubuntu Yakkety):
status: New → Triaged
importance: Undecided → Medium
Changed in ubuntu-core-launcher (Ubuntu Xenial):
importance: Undecided → Medium
Changed in ubuntu-core-launcher (Ubuntu Yakkety):
assignee: nobody → Jamie Strandboge (jdstrand)
summary: - private mount doesn't work when launching applications from /tmp
+ private mount doesn't work when launching applications from within /tmp
John Lenton (chipaca) on 2016-06-14
description: updated
Changed in ubuntu-core-launcher (Ubuntu Yakkety):
status: Triaged → In Progress
Zygmunt Krynicki (zyga) on 2016-06-28
Changed in snap-confine:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers