Fix shrinking behavior in rrCheckPixmapBounding

Bug #1715586 reported by Kai-Heng Feng on 2017-09-07
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
xorg-server (Ubuntu)
Kai-Heng Feng

Bug Description

When using extended mode on an slave-output connected external monitor, RRSetCrtc calls rrCheckPixmapBounding, which shrinks the output area. It makes the slave-output configured to scan-out an area which completely falls outside of the screen-pixmap, and end up with
a black display on the external monitor.

We need these two commits:
a46afee84d45fbff4e4dad9376afc95bbcc31d7c randr: rrCheckPixmapBounding: do not shrink the screen_pixmap
3b624aa9a9df86dc7d48149e0f18ca223b4355f1 randr: rrCheckPixmapBounding: Do not substract crtc non 0 x,y from screen size

[Test Case]
Enable NVIDIA PRIME, plug an external monitor, and change to extended mode.

[Regression Potential]
There should be none, the shrinking behavior wasn't right at the first place.

tags: added: originate-from-1704921 somerville
Kai-Heng Feng (kaihengfeng) wrote :

The attachment "lp1715586.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Brian Murray (brian-murray) wrote :

Is this fixed in the development release of Ubuntu, Artful Aardvark?

Timo Aaltonen (tjaalton) wrote :

Yes, they're upstream since xserver 1.19.1, we have 1.19.3

Hello Kai-Heng, or anyone else affected,

Accepted xorg-server into xenial-proposed. The package will build now and be available at in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at . Thank you in advance!

Changed in xorg-server (Ubuntu Xenial):
status: New → In Progress
importance: Undecided → Critical
Changed in xorg-server (Ubuntu):
status: Confirmed → Fix Released
Changed in xorg-server (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-xenial
Hao-Sheng Lu ( wrote :

Tested the package and found issue still can be reproduced,
"Internal Only" mode is missing in the switch mode cycle.

tags: added: verification-failed-xenial
Alex Tu (alextu) wrote :

with AOC monitor, it issued an unexpected acpi event after external monitor be disabled, that caused mode switching.

 u@u-Vostro-7570:~$ sudo acpi_listen

 # now disable external screen by $DISPLAY=:0 xrandr --output HDMI-0 --off
 jack/lineout LINEOUT unplug
 jack/videoout VIDEOOUT unplug

 # wait for about 15 secs, this acpi event somehow be issued.
 video/switchmode VMOD 00000080 00000000
 jack/lineout LINEOUT plug
 jack/videoout VIDEOOUT plug

But, this issue not happens to Dell monitor, and this proposed package passed both with Dell monitor ST2320L and P2415Qb. So, the patches helps actually.

tags: added: verification-done-xenial
removed: verification-failed-xenial
tags: removed: verification-needed-xenial
tags: added: verification-done
removed: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers