vim.gtk3 crashes frequently with SIGSEGV in ffi_call_unix64()

Bug #1611363 reported by Gilles Schintgen
122
This bug affects 25 people
Affects Status Importance Assigned to Milestone
vim
Confirmed
Undecided
Unassigned
unity-gtk-module (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
vim (Ubuntu)
High
Unassigned
Xenial
High
Unassigned

Bug Description

Hi, vim-gtk3 crashes so often on my system that it's borderline unusable.
My system is a clean install of Ubuntu 16.04. I also (temporarily) renamed my customized ~/.vimrc and ~/.vim. My system is up-to-date as of today (2016-08-09); installed vim-gtk3 is 2:7.4.1689-3ubuntu1.1.

The crash happens only (but very frequently, not always) when I launch gvim, either by calling it from a shell or by double-clicking a file in Nautilus. Note that the crash is independent of whether I'm opening a file or not. (At least I tried both variations from the terminal.)

There's also a report on vim's bugtracker, but since unity appears in the backtrace, the consensus is that it's probably Ubuntu-specific.

ProblemType: Crash
DistroRelease: Ubuntu 16.04
Package: vim-gtk3 2:7.4.1689-3ubuntu1.1
ProcVersionSignature: Ubuntu 4.4.0-31.50-generic 4.4.13
Uname: Linux 4.4.0-31-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CurrentDesktop: Unity
Date: Tue Aug 9 14:34:31 2016
ExecutablePath: /usr/bin/vim.gtk3
InstallationDate: Installed on 2016-07-10 (29 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
ProcCmdline: gvim -f /home/username/Documents/schoul/2016/1G-TODO/01-systemes-equations-TODO/chap01_systemes-equations-NOTES.tex
Signal: 11
SourcePackage: vim
StacktraceTop:
 ?? () from /usr/lib/x86_64-linux-gnu/libunity-gtk3-parser.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 ffi_call_unix64 () from /usr/lib/x86_64-linux-gnu/libffi.so.6
Title: vim.gtk3 crashed with SIGSEGV in ffi_call_unix64()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Revision history for this message
Gilles Schintgen (shigi) wrote :
Revision history for this message
Gilles Schintgen (shigi) wrote :

I forgot to add a reference to vim's bugtracker on github:
https://github.com/vim/vim/issues/851
but as I said before, "libunity-gtk3-parser.so.0" seems to make it Ubuntu-specific.

information type: Private → Public
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 unity_gtk_menu_section_get_item_attributes (model=<optimized out>, item_index=<optimized out>, attributes=0x7ffc3358c440) at ../../../lib/unity-gtk-menu-section.c:130
 g_menu_model_real_iterate_item_attributes () from /tmp/apport_sandbox_vzSPUV/usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 g_menu_exporter_menu_describe_item.isra () from /tmp/apport_sandbox_vzSPUV/usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 g_menu_exporter_menu_items_changed () from /tmp/apport_sandbox_vzSPUV/usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 ffi_call_unix64 () from /tmp/apport_sandbox_vzSPUV/usr/lib/x86_64-linux-gnu/libffi.so.6

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : StacktraceSource.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in vim (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in vim (Ubuntu):
status: New → Confirmed
Revision history for this message
Brian Murray (brian-murray) wrote :
Changed in vim (Ubuntu):
importance: Medium → High
Changed in vim (Ubuntu Xenial):
status: New → Confirmed
importance: Undecided → High
Revision history for this message
David Barnett (mu-mind) wrote :

So vim.gtk3 crashes consistently for all Ubuntu users on Unity desktop? Is anyone still working on a fix?

Changed in vim:
status: Unknown → Fix Released
Revision history for this message
David Barnett (mu-mind) wrote :

Where can I see the fix? What package was it in?

Revision history for this message
John A Meinel (jameinel) wrote :

Given the Assignee: auto-github-vim-vim #851
I think what happened is that someone noticed this is also the bug in github. However, if you read the bug in github, they closed *that* bug because they said it was an Ubuntu bug. So I think there is no Fix Released, as upstream said it was an Ubuntu bug.

This is hitting me as well.

Changed in vim:
importance: Unknown → Undecided
status: Fix Released → New
Revision history for this message
John A Meinel (jameinel) wrote :

I'm removing the direct remote watch as they said it is an Ubuntu bug.

Changed in vim:
status: New → Confirmed
tags: added: rls-z-incoming
Revision history for this message
djp (djpnewton) wrote :

workaround for me is to remove package vim-gtk3 and replace with vim-gtk

Revision history for this message
Honghe Wu (honghe) wrote :

@djp Thanks, it is the solution until this bug is fixed.

Revision history for this message
David Barnett (mu-mind) wrote :

Can you patch vim-gnome to point to vim-gtk instead of vim-gtk3 in the meantime?

I know many people who are used to installing "vim-gnome" to get the desktop integration and were baffled when their vim broke. It's not so obvious that several of the packages Ubuntu offered are just broken and you need to uninstall those and try again.

Revision history for this message
dino99 (9d9) wrote :

Looks like the real problem comes from GTK syntax error:
https://github.com/node-ffi/node-ffi/issues/324

Googling about ffi_call_unix64() find many apps crashing; so there is a need for code review with many apps using actual GTK.

tags: added: rls-aa-incoming
removed: rls-z-incoming
tags: removed: rls-aa-incoming
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-gtk-module (Ubuntu Xenial):
status: New → Confirmed
Changed in unity-gtk-module (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.