Unity overrides refresh rate setting

Bug #1475462 reported by Nathan Best on 2015-07-17
26
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Unity
New
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned

Bug Description

After installing the proprietary Nvidia drivers and then using the included Nvidia X Server Settings utility to manually set the resolution to 1920x1080 and the refresh rate to 144Hz (I have a 144Hz monitor), Unity still seems to move at the default f/s cap, which also limits the f/s in non-fullscreen games, including borderless window games. Setting the refresh rate in Compiz Configuration Settings Manager seems to have no affect. Also, on booting up the machine, the refresh rate setting gets overridden and reset to the default. For anyone with a high refresh rate monitor, this makes the Unity desktop environment a no-go. KDE and XFCE do not have this issue.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: unity (not installed)
ProcVersionSignature: Ubuntu 3.16.0-41.57~14.04.1-generic 3.16.7-ckt11
Uname: Linux 3.16.0-41-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.1-0ubuntu3.11
Architecture: amd64
CurrentDesktop: XFCE
Date: Thu Jul 16 18:41:37 2015
InstallationDate: Installed on 2015-06-23 (23 days ago)
InstallationMedia: Xubuntu 14.04.2 LTS "Trusty Tahr" - Release amd64 (20150218.1)
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Nathan Best (nathan173ab) wrote :
Levi (leviguiney) wrote :

This affects me as well. Super annoying. I really enjoy Unity, but this needs to be fixed asap. Running Ubuntu 14.04. GTX 970 with latest proprietary drivers from official PPA. 144 hz monitor.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Will Cooke (willcooke) on 2015-09-10
tags: added: rls-w-incoming
tags: added: rls-x-incoming
removed: rls-w-incoming
Will Cooke (willcooke) on 2015-11-23
tags: removed: rls-x-incoming
Martin Dueren (martin-dueren) wrote :

Are you by chance using two monitors, one of which is not 144 hz? As soon as I unplugged my older monitor everything worked. Here is my askubuntu qeustion I opened: http://askubuntu.com/questions/745980/dual-monitors-60-hz-and-144-hz-games-can-only-run-in-144-hz-if-i-unplug-the-60

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments