Switching from multiple to one screen causes windows to go missing

Bug #1126221 reported by Alan Pope 🍺🐧🐱 🦄 on 2013-02-15
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Unity
Confirmed
High
Unassigned
unity (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned

Bug Description

For this you need a machine with multiple displays.

Setup your desktop with a single workspace (the now default of 13.04?)
Enable multiple monitors, side by side.
Open a window on one monitor (such as nautilus) and another on the other monitor
Use the display control panel to switch off one of the monitors.

Observe that one of the windows is now lost offscreen. It appears in the alt-tab list, but you can't make it appear on screen.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: unity 6.12.0daily13.02.14-0ubuntu1 [origin: LP-PPA-ubuntu-unity-daily-build]
ProcVersionSignature: Ubuntu 3.8.0-6.13-generic 3.8.0-rc7
Uname: Linux 3.8.0-6-generic x86_64
ApportVersion: 2.8-0ubuntu4
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,grid,imgpng,gnomecompat,scale,workarounds,mousepoll,regex,wall,move,place,vpswitch,resize,unitymtgrabhandles,snap,session,expo,ezoom,unityshell]
CrashDB: unity
Date: Fri Feb 15 13:16:40 2013
EcryptfsInUse: Yes
InstallationDate: Installed on 2012-06-29 (230 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MarkForUpload: True
SourcePackage: unity
UpgradeStatus: Upgraded to raring on 2013-01-18 (27 days ago)

Andrea Azzarone (azzar1) wrote :

Ubuntu 13.04 has reached end of life and is no longer supported. Also I'm pretty sure we've already fixed this (cannot find the duplicate right now). Please reopen if you can still reproduce this.

Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Invalid
Changed in unity:
status: Incomplete → Invalid
Neal McBurnett (nealmcb) wrote :

I see the same problem on Trusty 14.04.1 LTS.
I have a VGA monitor on the left, and an HDMI monitor on the right, and a laptop screen that is turned off since I can't seem to run 3 displays at once. The HDMI goes to sleep after 2 hours of inactivity.

It doesn't happen every time, but after several of these sleep cycles, a window like psensor or Totem will often disappear as described.

xrandr snippets:

Screen 0: minimum 320 x 200, current 3600 x 1108, maximum 32767 x 32767
LVDS1 connected (normal left inverted right x axis y axis)
VGA1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 520mm x 290mm
HDMI1 connected 1680x1050+1920+58 (normal left inverted right x axis y axis) 1060mm x 626mm

Changed in unity (Ubuntu):
status: Invalid → Confirmed
Andrea Azzarone (azzar1) on 2015-02-02
Changed in unity:
status: Invalid → Confirmed
importance: Undecided → High
Reece (reece) wrote :

Affects me also. 14.04, x86_64, dual monitor (laptop+external).

The symptom is that some windows move after suspend/resume. Some windows move a little bit (vertically only), and others disappear altogether. The disappearing windows do show up in the panel and tab switcher.

What's the status of this ticket? Seems odd that a 2 year old bug marked as high importance is still open.

Will Cooke (willcooke) on 2015-07-31
tags: added: 16.04-hit-list
Will Cooke (willcooke) on 2015-11-23
tags: removed: 16.04-hit-list
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers