Spread (Super+W) causes maximised windows to resize/repaint and not just scale

Bug #1121941 reported by Alan Pope 🍺🐧🐱 🦄 on 2013-02-11
50
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Unity
Triaged
Medium
Unassigned
7.2
Invalid
Medium
Unassigned
compiz (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned

Bug Description

Open two windows of an application on Raring
Press Super+W to enable spread.
Observe that the windows shrink vertically and repaint when entering spread and re-expand when leaving spread.
I expect the windows should scale and not repaint or resize when entering or leaving spread.

Test case #1.
Start a virtualbox VM (with guest additions enabled so desktop resizing is automatic)
Maximise the virtualbox window.
Open a terminal in virtualbox and run the following command:-

watch xrandr

This will show the current resolution (which on my 1080p desktop is 1855x1034) - attached max.png
Enter spread on the host with Super+W
Observe the guest repainting the desktop
Wait a second or two for xrandr to display the new resolution (which on my machine goes to 1855x1006 - a reduction of 28px) - attached spread.png
Exit spread and observe the screen size goes back to what it was before.

Test case #2
Open a terminal
Enter the following command in the terminal
watch -d -n 0.5 "tput cols && tput lines"
Maximise the window
Press Super+W
Observe the number of lines is reduced by one when switching to spread, and increases back up again when leaving spread.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: compiz 1:0.9.9~daily13.02.08-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-5.10-generic 3.8.0-rc6
Uname: Linux 3.8.0-5-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.8-0ubuntu4
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,grid,imgpng,gnomecompat,scale,workarounds,mousepoll,regex,wall,move,place,vpswitch,resize,unitymtgrabhandles,snap,session,expo,ezoom,unityshell]
CompositorRunning: compiz
Date: Mon Feb 11 11:05:19 2013
DistUpgraded: 2013-01-18 10:34:11,775 DEBUG enabling apt cron job
DistroCodename: raring
DistroVariant: ubuntu
DkmsStatus:
 vboxhost, 4.2.4, 3.2.0-36-generic, x86_64: installed
 vboxhost, 4.2.4, 3.5.0-22-generic, x86_64: installed
 vboxhost, 4.2.4, 3.8.0-3-generic, x86_64: installed
 vboxhost, 4.2.4, 3.8.0-4-generic, x86_64: installed
 vboxhost, 4.2.4, 3.8.0-5-generic, x86_64: installed
EcryptfsInUse: Yes
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:21da]
InstallationDate: Installed on 2012-06-29 (226 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MachineType: LENOVO 4287CTO
MarkForUpload: True
PackageArchitecture: all
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-5-generic root=UUID=c8438547-b9fb-46af-8012-4663c77c70e7 ro quiet splash vt.handoff=7
SourcePackage: compiz
UpgradeStatus: Upgraded to raring on 2013-01-18 (23 days ago)
dmi.bios.date: 12/05/2012
dmi.bios.vendor: LENOVO
dmi.bios.version: 8DET67WW (1.37 )
dmi.board.asset.tag: Not Available
dmi.board.name: 4287CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8DET67WW(1.37):bd12/05/2012:svnLENOVO:pn4287CTO:pvrThinkPadX220:rvnLENOVO:rn4287CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 4287CTO
dmi.product.version: ThinkPad X220
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.9~daily13.02.08-0ubuntu1
version.ia32-libs: ia32-libs 20090808ubuntu36
version.libdrm2: libdrm2 2.4.42-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0.2-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0.2-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.13.2-0ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.1.0-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.0-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.6-0ubuntu2
xserver.bootTime: Mon Feb 11 09:38:59 2013
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.13.2-0ubuntu2
xserver.video_driver: intel

summary: - Spread (Super+W) causes windows to resize/repaint and not just scale
+ Spread (Super+W) causes maximised windows to resize/repaint and not just
+ scale
Andrea Azzarone (azzar1) on 2013-02-11
Changed in compiz (Ubuntu):
status: New → Invalid
Changed in unity (Ubuntu):
status: New → In Progress
Changed in unity:
status: New → In Progress
importance: Undecided → Medium
milestone: none → 7.0.0
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Stephen M. Webb (bregma) on 2013-04-04
Changed in unity:
milestone: 7.0.0 → 7.0.1
Andrea Azzarone (azzar1) on 2013-06-03
Changed in unity:
milestone: 7.0.1 → 7.1.3
status: In Progress → Triaged
Changed in unity (Ubuntu):
status: In Progress → Confirmed
Benjamin Xiao (ben-r-xiao) wrote :

The resizing issue also occurs when minimizing and maximizing VMware windows. Window resizes and causes the guest VM to resize as well.

Stephen M. Webb (bregma) on 2013-10-10
Changed in unity:
milestone: 7.1.3 → 7.2.0
Stephen M. Webb (bregma) on 2014-04-15
Changed in unity:
milestone: 7.2.0 → 7.2.1
Stephen M. Webb (bregma) on 2014-06-04
Changed in unity:
milestone: 7.2.1 → 7.2.2
Changed in unity:
milestone: 7.2.2 → 7.2.3
Changed in unity:
milestone: 7.2.3 → 7.3.1
Stephen M. Webb (bregma) on 2015-02-11
Changed in unity:
milestone: 7.3.1 → 7.3.2
Stephen M. Webb (bregma) on 2015-03-19
Changed in unity:
milestone: 7.3.2 → 7.3.3
Alex Baggott (alex-baggott) wrote :

Thank you for taking the time to report this bug. We have tried to recreate this on the latest release of Ubuntu and cannot reproduce it. This bug is being marked as Invalid. If you believe the problem to still exist in the latest version of Ubuntu please comment on why that is the case and change the bug status to NEW.

Changed in unity (Ubuntu):
status: Confirmed → Invalid
Changed in unity:
status: Triaged → Invalid

Sorry, you're incorrect, it does still happen with the latest 15.10 release. I have added a simpler test case to show this.

description: updated
Changed in unity (Ubuntu):
status: Invalid → Confirmed
Changed in unity:
status: Invalid → Triaged
Alex Baggott (alex-baggott) wrote :

Just tried Test Case #2 and it does happen. However, I couldn't reproduce Test Case #1 on my machine.

tags: added: rls-w-incoming
Changed in unity:
milestone: 7.3.3 → 7.4.0
tags: added: rls-x-incoming
removed: rls-w-incoming
Will Cooke (willcooke) on 2015-11-23
tags: removed: rls-x-incoming
tags: added: unity-backlog
Andrea Azzarone (azzar1) on 2017-10-13
Changed in unity:
assignee: Andrea Azzarone (azzar1) → nobody
Changed in unity (Ubuntu Xenial):
assignee: Andrea Azzarone (azzar1) → nobody
Changed in unity (Ubuntu):
assignee: Andrea Azzarone (azzar1) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers