unity-greeter scaling factor changes after a delay

Bug #1571640 reported by Dennis Olivetti on 2016-04-18
110
This bug affects 18 people
Affects Status Importance Assigned to Milestone
unity-greeter (Ubuntu)
High
Unassigned
Xenial
High
Unassigned
Yakkety
High
Unassigned
unity-settings-daemon (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Yakkety
Undecided
Unassigned

Bug Description

[Impact]

 * Unity Greeter does not have the right scale at the beginning, after a short delay, it changes to the right scale.

[Test Case]

 * It can be easily observed on HiDPI display, when Unity Greeter is starting.

[Regression Potential]

 * If u-s-d failed to launch, Unity Greeter stuck at waiting u-s-d's signal and failed to proceed. But it's not likely to happen.

----

Just after the upgrade to ubuntu 16.04, when lightdm starts the resolution is 2560x1600. Then, after about half a second it is automatically changed to 1280x800. This happens systematically at each boot. No external monitor is connected.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: lightdm 1.18.1-0ubuntu1
Uname: Linux 4.5.0-040500-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity
Date: Mon Apr 18 14:39:03 2016
EcryptfsInUse: Yes
InstallationDate: Installed on 2014-11-09 (525 days ago)
InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Release amd64 (20141022.1)
SourcePackage: lightdm
UpgradeStatus: Upgraded to xenial on 2016-04-18 (0 days ago)

Related branches

Dennis Olivetti (oliden) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed
TJ (tj) wrote :

Yes, I saw this... assumed it was supposed to happen.

Were you able to confirm the actual resolution as reported by xrandr had changed, rather than just the scaling of the display elements ?

Robert Ancell (robert-ancell) wrote :

Is this the resolution of the greeter or the session?

Changed in lightdm (Ubuntu):
status: Confirmed → Incomplete
TJ (tj) wrote :

Robert; the greeter run by lightdm. I was going to do some debugging on it myself today. First time I've installed a Unity desktop in several years so I thought it was intended to ensure the greeter elements were readable on high DPI displays.

Here it's on an Asus T300 Chi with a 2560x1440 display. greeter starts at that resolution then switches to 1280x720 as can be seen in the attached /var/log/lightdm/x-0-greeter.log

[+0.59s] DEBUG: main-window.vala:185: Screen is 2560x1440 pixels
[+0.59s] DEBUG: main-window.vala:193: Monitor 0 is 2560x1440 pixels at 0,0
[+0.60s] DEBUG: menubar.vala:537: Adding indicator object 0xcfa2e0 at position 2
[+0.60s] DEBUG: Building new application entry: :1.15 with icon: nm-no-connection at position 0
[+0.61s] DEBUG: menubar.vala:537: Adding indicator object 0xf4ae00 at position 3
[+0.63s] DEBUG: menubar.vala:537: Adding indicator object 0xcfa860 at position 2
[+0.64s] DEBUG: unity-greeter.vala:240: starting system-ready sound
[+0.66s] DEBUG: background.vala:121: Render of background /usr/share/backgrounds/warty-final-ubuntu.png complete

** (unity-settings-daemon:1279): WARNING **: Unable to register client: GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: No such method 'RegisterClient'
[+0.82s] DEBUG: main-window.vala:185: Screen is 1280x720 pixels
[+0.82s] DEBUG: main-window.vala:193: Monitor 0 is 1280x720 pixels at 0,0
[+0.86s] DEBUG: background.vala:483: Regenerating backgrounds
[+0.86s] DEBUG: background.vala:68: Making background /usr/share/backgrounds/warty-final-ubuntu.png at 1280x720
[+1.02s] DEBUG: background.vala:121: Render of background /usr/share/backgrounds/warty-final-ubuntu.png complete

Changed in lightdm (Ubuntu):
status: Incomplete → Confirmed
TJ (tj) wrote :

Here's the matching timestamps extract from lightdm.log, centred around 0.62s.

TJ (tj) wrote :

Looks like revision 1839 could be responsible. Will try a bisect later today.

http://bazaar.launchpad.net/~unity-greeter-team/unity-greeter/16.04/revision/1839

I am also having this problem while using Thinkpad T460s with a 2560x1440 resolution monitor.

Ian Canino (ian-canino) wrote :

I am having a similar problem to this on the Macbook Pro 11,1 (Retina) on a tabula rasa install of 16.04 LTS). However this resolution switch only occurs on the first time (from boot-up). Each subsequent times, it maintains the correct resolution and remembers the user's wallpaper.
After a reboot, the wallpaper is set to default (purple background) instead of remember the user's last used wallpaper.

affects: lightdm (Ubuntu) → unity-greeter (Ubuntu)
Changed in unity-greeter (Ubuntu):
importance: Undecided → High
Sebastien Bacher (seb128) wrote :

Thank you for your report, what you seems to describe is not that the resolution change but that the greeter scales to be hidpi friendly, but that happens after a small delay when unity-settings-daemon start. Does that sound correct to you?

If so, how does one permanently prevent the unity-greeter-daemon scaling to
account for HiDPI? I have the following set:

Unity Tweak Tools->Fonts-> "Text Scaling Factor" has been set to 1.00
System Settings->Displays->"Scale for menu and title bars" has been set
to 1

Note, that this "scaling" effect does not occur after the first instance
(immediately after booting up). Each subsequent calls to the greeter results
in the greeter remembering the User's wallpaper and changing it accordingly
and maintains a consistent screen resolution.

\--

Ian G Canino
Telegram: [@iangadev](telegram.me/iangadev)

Telephone: 347-225-4146

Sent from [Nylas N1](https://nylas.com/n1?ref=n1), the extensible, open source
mail client.

On May 10 2016, at 1:56 am, Sebastien Bacher &lt;<email address hidden>&gt; wrote:

> Thank you for your report, what you seems to describe is not that the
resolution change but that the greeter scales to be hidpi friendly, but
that happens after a small delay when unity-settings-daemon start. Does
that sound correct to you?

>

> \--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1571640

>

> Title:
  lightdm changing resolution

>

> Status in unity-greeter package in Ubuntu:
  Confirmed

>

> Bug description:
  Just after the upgrade to ubuntu 16.04, when lightdm starts the
  resolution is 2560x1600. Then, after about half a second it is
  automatically changed to 1280x800. This happens systematically at each
  boot. No external monitor is connected.

>

> ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: lightdm 1.18.1-0ubuntu1
  Uname: Linux 4.5.0-040500-generic x86_64
  NonfreeKernelModules: wl
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Mon Apr 18 14:39:03 2016
  EcryptfsInUse: Yes
  InstallationDate: Installed on 2014-11-09 (525 days ago)
  InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Release amd64
(20141022.1)
  SourcePackage: lightdm
  UpgradeStatus: Upgraded to xenial on 2016-04-18 (0 days ago)

>

> To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/unity-
greeter/+bug/1571640/+subscriptions

The same for Dell XPS 9350 with 16.04:

First greeter starts properly:
[+0,48s] DEBUG: unity-greeter.vala:240: starting system-ready sound
(nm-applet:1146): GLib-GObject-WARNING **: invalid unclassed pointer in cast to 'GtkWidget'
(nm-applet:1146): Gtk-CRITICAL **: gtk_widget_show: assertion 'GTK_IS_WIDGET (widget)' failed
[+0,76s] DEBUG: main-window.vala:185: Screen is 3200x1800 pixels
[+0,76s] DEBUG: main-window.vala:193: Monitor 0 is 3200x1800 pixels at 0,0
[+0,76s] DEBUG: Building new application entry: :1.13 with icon: nm-stage03-connecting01 at position 0

but after a moment:

** (unity-settings-daemon:1163): WARNING **: Unable to register client: GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: No such method 'RegisterClient'
[+1,10s] DEBUG: main-window.vala:185: Screen is 1600x900 pixels
[+1,10s] DEBUG: main-window.vala:193: Monitor 0 is 1600x900 pixels at 0,0
[+1,13s] DEBUG: background.vala:483: Regenerating backgrounds

The full log: http://pastie.org/10838109

Furthermore, initial greeter have correct background (the wallpaper that I currently use). However, the second low-resolution one has some previously used.

Ian Canino (ian-canino) wrote :

While mucking about trying to get fbterm to run as default for the tty's I stumbled upon a solution of sorts for the resolution change as specified in this bug report:

add "nomodeset" to the grub configuration file. (This solution works on the Macbook Pro Retina 11,1 running 16.04LTS)

Kai-Heng Feng (kaihengfeng) wrote :

Hi,

Can you guys try my merge proposals? They should fix the issue.
Both unity-greeter and unity-settings-daemon are needed.

Thanks!

Robert Ancell (robert-ancell) wrote :

Kai-Heng - do you plan to SRU this to Xenial? Can you make a merge proposal to lp:unity-greeter/16.04 if so.

Changed in unity-greeter (Ubuntu):
status: Confirmed → Fix Committed
Robert Ancell (robert-ancell) wrote :

And update the description here suitable for an SRU - https://wiki.ubuntu.com/StableReleaseUpdates

description: updated
Changed in unity-greeter (Ubuntu Xenial):
importance: Undecided → High
Sebastien Bacher (seb128) wrote :

Robert, the SRU currently waiting in the xenial queue as a "Require unity-settings-daemon that has xsettings signal fixes." changelog entry but the version used doesn't have it and we currently don't have a u-s-d SRU with that fix backported (we need to do a SRU next with some cherrypicked changes including that one)

Martin Pitt (pitti) wrote :

Thus the Recommends: version bump is insufficient, I reject the upload. Please re-upload after u-s-d is available and depend on that.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-greeter (Ubuntu Xenial):
status: New → Confirmed
Martin Pitt (pitti) wrote :
Changed in unity-settings-daemon (Ubuntu Yakkety):
status: New → Fix Released

Hello Dennis, or anyone else affected,

Accepted unity-settings-daemon into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unity-settings-daemon/15.04.1+16.04.20160701-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity-settings-daemon (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed
summary: - lightdm changing resolution
+ unity-greeter scaling factor changes after a delay
Sebastien Bacher (seb128) wrote :

using the new version for a while I can confirm that it works fine but doesn't solve the issue (yet) because the unity-greeter changes didn't get uploaded, setting as verification-done the update includes other fixes and there is no reason to block on this change

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-greeter - 16.10.1-0ubuntu2

---------------
unity-greeter (16.10.1-0ubuntu2) yakkety; urgency=medium

  * debian/control:
    - Require unity-settings-daemon that has xsettings signal fixes.

 -- Robert Ancell <email address hidden> Fri, 24 Jun 2016 09:21:10 +1200

Changed in unity-greeter (Ubuntu Yakkety):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-settings-daemon - 15.04.1+16.04.20160701-0ubuntu1

---------------
unity-settings-daemon (15.04.1+16.04.20160701-0ubuntu1) xenial; urgency=medium

  [ Robert Ancell ]
  * Correctly check value of XDG_CURRENT_DESKTOP.

  [ Marco Trevisan (Treviño) ]
  * PowerManager: connect to keyboard BrightnessChanged signal to update
    the cached current value properly (LP: #1510344)
  * GsdPowerManager: don't cache kbd backlight current value (LP:
    #1583861)
  * common: backport g-s-d commits for having single shared dbus proxies
  * ScreensaverProxy: redirect supported calls to gnome screensaver APIs
    (LP: #1415265, LP: #1584161)

  [ Sebastien Bacher ]
  * Don't hit an xerror when a device is removed while being configured
    (LP: #1503758)
  * wacom: don't segfault when a device is removed while being
    configured. (LP: #1439427)

  [ Marco Trevisan (Treviño) ]
  * GsdPowerManager: use proper return value for upower_kbd_toggle
    wherever we use it (LP: #1592816)

  [ Kai-Heng Feng ]
  * SettingsManager: Queue up signals before getting D-Bus connection.
    (LP: #1571640)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Fri, 01 Jul 2016 13:28:54 +0000

Changed in unity-settings-daemon (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for unity-settings-daemon has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Hi

I'm using unity-settings-daemon (15.04.1+16.04.20160701-0ubuntu1) on 16.04 LTS (upgraded from 15.10) on my Toshiba Kira with desktop resolution 2560x1440. With 15.10 the greeter worked ok, but now with 16.04 I'm still facing the same situation as described by "TJ (tj) on 2016-04-26".

Is some other action still needed?

Thanks!

Chris Kankiewicz (phlak) wrote :

Is there a release for unity-greeter planned to fix this issue? I'm running unity-settings-daemon 15.04.1+16.04.20160701-0ubuntu1 on 16.04.1 and still having this issue.

Tian Yong (htian) wrote :

unity-settings-daemon 15.04.1+16.04.20160701-0ubuntu1 on 16.04.1 still not working

Changed in snapd-glib (Ubuntu):
status: New → Fix Released
Changed in snapd-glib (Ubuntu Yakkety):
status: New → Fix Released
Changed in snapd-glib (Ubuntu Xenial):
importance: Undecided → High
Changed in snapd-glib (Ubuntu Yakkety):
importance: Undecided → High
Changed in snapd-glib (Ubuntu):
importance: Undecided → High
no longer affects: snapd-glib (Ubuntu)
no longer affects: snapd-glib (Ubuntu Xenial)
no longer affects: snapd-glib (Ubuntu Yakkety)
Bjarne (bjarne-grimstad) wrote :

Experiencing the same issue. Running unity-settings-daemon 15.04.1+16.04.20160701-0ubuntu1 on 16.04.1.

Steve McKay (smmckay) wrote :

AIUI unity-greeter 16.04.3 should fix this issue now, but it was rejected because at the time the fix to u-s-d wasn't available in xenial. There's an additional issue that the dependency on u-s-d was updated to require a fixed version of u-s-d, but that was done incorrectly and so the control file is kinda broken. If I'm wrong about any of this, please correct me.

I'm willing to do some work here, but I don't know what's the right thing (i.e., will get merged and released) to do. Fix the dependency in debian/control to >= 15.04.1+16.04.20160701-0ubuntu1?

I see the same thing at 16.04
The problem is that I want the first native resolution and not the scaled up version.
When it scales up it looks like something a 800 x 600 386 days.

At 16.10 it just goes straight to the wrong resolution.

This seems like a case of 2 wrong turns don't make a right turn.
Is there work to fix this so it goes to native resolution and then only goes to a different scaled resolution if that was specifically chosen.

I think its a looks a little amateurish to have a lock screen at one resolution and a login in screen at another.

Is there a patch that lets me specify the scaling? That I could test on 16.10?

Justin Ropella (jropella) wrote :

Currently having this problem with 16.04. Even if I specify a resolution for LightDM to use via a display script, unity greeter overrides it and resets to whatever the preferred resolution is. Running Ubuntu in VMWare.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers