git-svn coredumps

Bug #1451028 reported by Jens Elkner on 2015-05-02
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
subversion (Debian)
Fix Released
Unknown
subversion (Ubuntu)
Medium
Unassigned
Xenial
Medium
Unassigned

Bug Description

[Impact]

Subversion's Perl bindings randomly crash. This is most typically seen when using git-svn, since it's a heavy user of the bindings.

[Test Case]

"git svn clone -s svn://svn.code.sf.net/p/flightgear/fgaddon". With the existing package in xenial, git-svn kept crashing while trying to checkout the first revision. With the updated package, I've successfully processed 2400 revisions before being interrupted by a network issue.

[Regression Potential]

This brings the code up to date with current released Subversion code in this area. The upstream release which included these changes (1.9.5) has been in Debian since 2016-11-29 and I've received no further reports of issues.

[Other Info]

> gdb perl core
GNU gdb (Ubuntu 7.8-1ubuntu4) 7.8.0.20141001-cvs
[...]
[New LWP 3503]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Core was generated by `/usr/bin/perl /usr/lib/git-core/git-svn clone --rewrite-root=x://. svn+ssh://iw'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0 0x00002b39f9092a31 in _wrap_svn_txdelta_apply ()
   from /usr/lib/x86_64-linux-gnu/perl5/5.20/auto/SVN/_Delta/_Delta.so
(gdb) where
#0 0x00002b39f9092a31 in _wrap_svn_txdelta_apply ()
   from /usr/lib/x86_64-linux-gnu/perl5/5.20/auto/SVN/_Delta/_Delta.so
#1 0x00002b39f5400f1b in Perl_pp_entersub ()
   from /usr/lib/x86_64-linux-gnu/libperl.so.5.20

So right now git-svn seems to be useless on ubuntu 14.10 (Linux lubdev 3.16.0-24-generic #32-Ubuntu SMP Tue Oct 28 13:07:32 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux).

It seems to be related to http://svn.haxx.se/dev/archive-2015-03/0220.shtml

Jens Elkner (jelmd) on 2015-05-02
affects: libsvn-mirror-perl (Ubuntu) → git (Ubuntu)
Byoungchan Lee (bclee) wrote :

Debian patch over subversion 1.9.4 (ref: https://blueprints.launchpad.net/debian/+source/subversion/1.9.4-3 ) solved this problem and corresponding patch ( debian/patches/perl-swig-crash ) can be applied on subversion 1.9.3~2ubuntu1 (Ubuntu 16.04). After applying the patch, this issue is gone.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in git (Ubuntu):
status: New → Confirmed
Changed in subversion (Ubuntu):
status: New → Confirmed
Severn Tsui (severnt) wrote :

I built the Ubuntu package with the perl-swig-crash patch bclee mentioned in #2 and it no longer crashes. PPA https://launchpad.net/~severnt/+archive/ubuntu/subversion

James McCoy (jamessan) wrote :

[Impact]

Subversion's Perl bindings randomly crash. This is most typically seen when using git-svn, since it's a heavy user of the bindings.

[Test case]

"git svn clone -s svn://svn.code.sf.net/p/flightgear/fgaddon". With the existing package in xenial, git-svn kept crashing while trying to checkout the first revision. With the updated package, I've successfully processed 2400 revisions before being interrupted by a network issue.

[Regression potential]

This brings the code up to date with current released Subversion code in this area. The upstream release which included these changes (1.9.5) has been in Debian since 2016-11-29 and I've received no further reports of issues.

no longer affects: git (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

affects: subversion → ubuntu
Changed in ubuntu:
status: New → Confirmed
no longer affects: ubuntu
Changed in subversion (Ubuntu):
importance: Undecided → Medium
tags: added: patch patch-accepted-debian patch-accepted-upstream
Changed in subversion (Debian):
status: Unknown → Fix Released
description: updated
tags: added: xenial
Logan Rosen (logan) on 2019-03-04
Changed in subversion (Ubuntu):
status: Confirmed → Fix Released
Changed in subversion (Ubuntu Xenial):
importance: Undecided → Medium
Simon Quigley (tsimonq2) wrote :

Uploaded to Xenial.

Changed in subversion (Ubuntu Xenial):
status: New → In Progress
Robie Basak (racb) wrote :

I adjusted the changelog entry to make the bug reference work correctly, and reuploaded.

Changed in subversion (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-xenial

Hello Jens, or anyone else affected,

Accepted subversion into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/subversion/1.9.3-2ubuntu1.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.