default dependancy should be python3-powerline

Bug #1575802 reported by Scott Palmer on 2016-04-27
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Medium
Unassigned
powerline (Debian)
Fix Released
Unknown
powerline (Ubuntu)
Medium
Unassigned
Xenial
Medium
Brian Murray

Bug Description

Test Case
---------
1) sudo apt-get install powerline vim-addon-manager
2) vim-addon-manager install powerline
3) run vim
4) observe the following crash:

Traceback (most recent call last):
  File "<string>", line 4, in <module>
ImportError: No module named 'powerline'
During handling of the above exception, another exception occurred:
Traceback (most recent call last):
  File "<string>", line 9, in <module>
ImportError: No module named 'powerline'
An error occurred while importing powerline module.
This could be caused by invalid sys.path setting,
or by an incompatible Python version (powerline requires
Python 2.6, 2.7 or 3.2 and later to work). Please consult
the troubleshooting section in the documentation for
possible solutions.
Unable to import powerline, is it installed?
Press ENTER or type command to continue

With the version of the package from -proposed there will be no Traceback.

Regression Potential
--------------------
Little as we are just adding a recommends which has been added the package since zesty.

Original Description
--------------------
powerline should depend on python3-powerline instead of python-powerline by default for 16.04

ProblemType: BugDistroRelease: Ubuntu 16.04
Package: powerline 2.3-1
ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
Uname: Linux 4.4.0-21-generic x86_64
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CurrentDesktop: GNOME
Date: Wed Apr 27 10:29:59 2016
InstallationDate: Installed on 2016-04-01 (25 days ago)
InstallationMedia: Ubuntu-GNOME 16.04 LTS "Xenial Xerus" - Beta amd64 (20160323.1)SourcePackage: powerline
UpgradeStatus: No upgrade log present (probably fresh install)

Scott Palmer (skewty) wrote :
summary: - default dependancy should be python3
+ default dependancy should be python3-powerline
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in powerline (Ubuntu):
status: New → Confirmed
Ralf Heiringhoff (frosty-geek) wrote :

I can confirm that installing python3-powerline after upgrading to 16.04 fixed my problem

Changed in powerline (Ubuntu):
importance: Undecided → Medium
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → Medium
Scott Palmer (skewty) wrote :

This bug is rated medium and it has been over a year.

Here is what I get in Ubuntu 17.10:

$ apt show powerline
Package: powerline
Version: 2.5-1.1
Priority: optional
Section: universe/python
Origin: Ubuntu
Maintainer: Ubuntu Developers <email address hidden>
Original-Maintainer: Jerome Charaoui <email address hidden>
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 251 kB
Depends: python:any (>= 2.7.5-5~), libc6 (>= 2.4), python-powerline
Recommends: fonts-powerline, python3-powerline
Suggests: python-powerline-doc, vim-addon-manager
Breaks: python-powerline (<< 0~20140216-2)
Replaces: python-powerline (<< 0~20140216-2)
Enhances: awesome, bash, ipython, tmux, vim-nox, zsh
Homepage: https://github.com/Lokaltog/powerline
Download-Size: 42.5 kB
APT-Sources: http://ca.archive.ubuntu.com/ubuntu artful/universe amd64 Packages
Description: prompt and statusline utility
 Powerline is a statusline plugin for vim, and provides statuslines and
 prompts for several other applications, including zsh, bash, tmux,
 IPython, Awesome and Qtile.
 .
 This package contains the Powerline executables.

$ sudo apt install -y python3-powerline
...
$ powerline
The program 'powerline' is currently not installed. You can install it by typing:
sudo apt install powerline
$ sudo apt install -y powerline
...
The following NEW packages will be installed:
  fonts-powerline powerline python-powerline python-psutil
...
$

Is it correct to assume that the desire to move Ubuntu to Python3 in 16.04 has lost almost all of its momentum. If this is indeed still a priority, it would be nice to get this resolved before 18.04.

TJ (tj) wrote :

In 17.10 it seems the fix was to add to debian/control:

Recommends: python3-powerline

TJ (tj) wrote :
TJ (tj) wrote :

Was fixed in 17.04 too; the fix wasn't backported/SRU-ed to 16.04 though.

The attachment "Add Recommends: python3-powerline" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Brian Murray (brian-murray) wrote :

It's uploaded and awaiting review by an SRU team member.

description: updated
Changed in powerline (Ubuntu):
status: Confirmed → Fix Released
Changed in powerline (Ubuntu Xenial):
status: New → In Progress
assignee: nobody → Brian Murray (brian-murray)
importance: Undecided → Medium
Changed in powerline (Debian):
status: Unknown → Fix Released

Hello Scott, or anyone else affected,

Accepted powerline into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/powerline/2.3-1ubuntu0 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in powerline (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-xenial
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.