BBC weather dataengine broken due to changed RSS feed

Bug #1769010 reported by Simon Quigley on 2018-05-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
plasma-workspace (Ubuntu)
Medium
Unassigned
Xenial
Medium
Unassigned

Bug Description

The URLs of the BBC weather feeds seem to have changed, resulting in the dataengine to use no longer existing URLs.

[Impact]

This is a user-impacting regression that could result in weather feeds being non-functional for some users.

[Test Case]

Existing configured weather applets using a location from a BBC weather service should work again. Newly configured weather applets using a BBC weather service should also work.

[Regression Potential]

The regression happened in the first place due to the RSS feeds changing on the BBC site. If they change again, this will regress again.

Simon Quigley (tsimonq2) wrote :

Bionic will be addressed when Plasma 5.12.5 is SRUed. Other releases need explicit SRUs to them.

Changed in plasma-workspace (Ubuntu):
status: New → Fix Released
importance: Undecided → High
Changed in plasma-workspace (Ubuntu Trusty):
importance: Undecided → High
Changed in plasma-workspace (Ubuntu):
importance: High → Medium
Changed in plasma-workspace (Ubuntu Trusty):
importance: High → Medium
Changed in plasma-workspace (Ubuntu Xenial):
importance: Undecided → High
status: New → In Progress
Changed in plasma-workspace (Ubuntu Trusty):
status: New → In Progress
Changed in plasma-workspace (Ubuntu Xenial):
importance: High → Medium
assignee: nobody → Simon Quigley (tsimonq2)
Changed in plasma-workspace (Ubuntu Trusty):
assignee: nobody → Simon Quigley (tsimonq2)
no longer affects: plasma-workspace (Ubuntu Trusty)
Simon Quigley (tsimonq2) wrote :

Backporting the patch will take a bit of effort + time (that I don't have right now).

Changed in plasma-workspace (Ubuntu Xenial):
assignee: Simon Quigley (tsimonq2) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers