systemd init scripts not setting correct conf file

Bug #1516471 reported by Andrew Bramley on 2015-11-16
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
openstack-trove (Ubuntu)
High
Unassigned
Wily
High
Unassigned
Xenial
High
Unassigned
Yakkety
High
Unassigned

Bug Description

In january the trove install packages were changed to use systemd in this commit:
http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/wily/openstack-trove/wily/revision/21
This caused all services to startup using the same configuration file.

trove 16464 1 0 Nov13 ? 00:09:24 /usr/bin/python /usr/bin/trove-api --config-file=/etc/trove/trove.conf --log-file=/var/log/trove/trove-api.log
trove 16510 1 0 Nov13 ? 00:09:13 /usr/bin/python /usr/bin/trove-conductor --config-file=/etc/trove/trove.conf --log-file=/var/log/trove/trove-conductor.log
trove 16574 16464 0 Nov13 ? 00:00:00 /usr/bin/python /usr/bin/trove-api --config-file=/etc/trove/trove.conf --log-file=/var/log/trove/trove-api.log
trove 16575 16464 0 Nov13 ? 00:00:00 /usr/bin/python /usr/bin/trove-api --config-file=/etc/trove/trove.conf --log-file=/var/log/trove/trove-api.log
trove 16576 16510 0 Nov13 ? 00:00:02 /usr/bin/python /usr/bin/trove-conductor --config-file=/etc/trove/trove.conf --log-file=/var/log/trove/trove-conductor.log
trove 16579 16510 0 Nov13 ? 00:00:02 /usr/bin/python /usr/bin/trove-conductor --config-file=/etc/trove/trove.conf --log-file=/var/log/trove/trove-conductor.log
trove 28190 1 0 14:32 ? 00:00:00 /usr/bin/python /usr/bin/trove-taskmanager --config-file=/etc/trove/trove.conf --log-file=/var/log/trove/trove-taskmanager.log

You will notice that all services are using trove.conf when they should be using trove-conductor.conf, trove-taskmanager.conf etc

The *.init.in files need updating to include settings like: CONFIG_FILE=/etc/${PROJECT_NAME}/trove-taskmanager.conf

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in openstack-trove (Ubuntu):
status: New → Confirmed
Matt Kassawara (ionosphere80) wrote :

James,

Can you assist?

Thanks,
Matt

James Page (james-page) on 2016-05-23
Changed in openstack-trove (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
James Page (james-page) on 2016-05-23
Changed in openstack-trove (Ubuntu Yakkety):
status: Triaged → Fix Committed
Changed in openstack-trove (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → High
Changed in openstack-trove (Ubuntu Wily):
status: New → Triaged
importance: Undecided → High
James Page (james-page) wrote :

Pushed fixes to master branch for newton packages; not quite sure how we managed to miss this bug (I found it having read the trove part of the install guide) so apologies for the lag.

Pete MacKinnon (pmackinn) wrote :

Actually oslo_config should compute and search for the appropriate config files for you. For example, in the case of trove-taskmanager, it will take the program name ("trove-taskmanager"), prepend it with a dir based on the project name ("/etc/trove"), and append the ".conf" extension.

['/usr/share/trove/trove-dist.conf',
 None,
 '/etc/trove/trove.conf',
 '/etc/trove/trove-taskmanager.conf']

Thus, it shouldn't be necessary to specify the config file at all given a standard install. YMMV

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openstack-trove - 1:6.0.0~b2-0ubuntu1

---------------
openstack-trove (1:6.0.0~b2-0ubuntu1) yakkety; urgency=medium

  [ Corey Bryant ]
  * New upstream milestone for OpenStack Newton.
  * d/control: Align (build-)depends with upstream.
  * d/rules: Run unit tests with ostestr.
  * d/p/patch-default-config-file.patch: Rebased.

  [ James Page ]
  * New upstream version.
  * d/p/fix-base-unit-test-class.patch: Drop, no longer required.
  * d/*.init.in: Use correct configuration file for each of the trove
    daemons (LP: #1516471).
  * d/p/*: Refresh.

  [ David Della Vecchia ]
  * d/p/skip-failing-tests.patch: Rebased.

 -- Corey Bryant <email address hidden> Mon, 11 Jul 2016 16:06:09 -0400

Changed in openstack-trove (Ubuntu Yakkety):
status: Fix Committed → Fix Released

Hello Andrew, or anyone else affected,

Accepted openstack-trove into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/openstack-trove/1:5.0.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in openstack-trove (Ubuntu Xenial):
status: Triaged → Fix Committed
tags: added: verification-needed
Corey Bryant (corey.bryant) wrote :

Hi Brian, I've successfully verified openstack-trove 1:5.1.0-0ubuntu1.

tags: added: verification-done
removed: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers