Remove obsolete versioned dependency on initramfs-tools

Bug #1716818 reported by Steve Langasek on 2017-09-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mdadm (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Steve Langasek

Bug Description

[SRU Justification]
In xenial and earlier, mdadm declares a versioned dependency on initramfs-tools. This was an Ubuntu-specific dependency only needed for upgrades, and the version referenced is ancient (ca. 2008). In zesty and later, the dependency has been removed.

Since this is no longer relevant for upgrades and we would not otherwise have a dependency on initramfs-tools, we should drop this dependency to support building of images with initramfs-tools removed for systems that we know don't require an initramfs.

[Test case]
1. On a xenial default cloud image install, try to run 'sudo apt purge initramfs-tools'.
2. Verify that this tries to remove mdadm.
3. Cancel the removal.
4. Install mdadm from xenial-proposed.
5. Run 'sudo apt purge initramfs-tools' again.
6. Verify that mdadm is not removed.
7. Run 'sudo apt install --reinstall mdadm' and confirm that the package can be installed successfully without initramfs-tools installed.

[Regression Potential]
If a user needs an initramfs in order to mount their root device (whether or not it's on RAID), and mdadm is the only package on their system which depends on initramfs-tools, it is possible that the user may remove initramfs-tools and render their system unbootable.

This is unlikely because initramfs-tools is still part of the 'minimal' seed and is therefore a dependency of ubuntu-minimal; and it remains a dependency of the generic kernel image.

So long as initramfs-tools is installed, mdadm's initramfs hooks will continue to function as intended when required.

Steve Langasek (vorlon) on 2017-09-13
Changed in mdadm (Ubuntu):
status: New → Fix Released
Changed in mdadm (Ubuntu Xenial):
status: New → In Progress
assignee: nobody → Steve Langasek (vorlon)
description: updated
Steve Langasek (vorlon) on 2017-09-13
description: updated
Brian Murray (brian-murray) wrote :

I accepted the package but the update bug part of the operation failed, anyway this is in -proposed now.

Changed in mdadm (Ubuntu Xenial):
status: In Progress → Fix Committed
Steve Langasek (vorlon) wrote :

This SRU fails verification, the new binary still depends on initramfs-tools. Apparently I failed to edit debian/control correctly in the previous upload.

tags: added: verification-failed-xenial

Hello Steve, or anyone else affected,

Accepted mdadm into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mdadm/3.3-2ubuntu7.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed verification-needed-xenial
removed: verification-failed-xenial
Steve Langasek (vorlon) wrote :

With mdadm 3.3-2ubuntu7.4, this works as expected.

tags: added: verification-done-xenial
removed: verification-needed verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mdadm - 3.3-2ubuntu7.4

---------------
mdadm (3.3-2ubuntu7.4) xenial; urgency=medium

  * Drop versioned dependency on initramfs-tools, which was only needed for
    upgrades and now keeps initramfs-tools installed on systems that don't
    need it. LP: #1716818.
  * Guard calls to update-initramfs -u in the maintainer scripts for a
    check that the script is present.

 -- Steve Langasek <email address hidden> Wed, 13 Sep 2017 03:52:18 +0000

Changed in mdadm (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for mdadm has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers