open-vm-tools status is toolsNotInstalled after deploy cloud image groovy-server-cloudimg-amd64.ova

Bug #1893898 reported by vmware-gos-Yuhua on 2020-09-02
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
cloud-images
High
John Chittum
livecd-rootfs (Ubuntu)
Undecided
John Chittum
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
Focal
Undecided
Unassigned
Groovy
Undecided
Unassigned

Bug Description

[Impact]

 * with groovy-server-cloudimg-amd64.ova daily build, when only deploy OVA and don't power on VM, the VMTools status is "toolsNotInstalled"
But in fact, we have installed open-vm-tools.

[Test Case]

 * build vmdk image and verify that buildlog now mentions emitting ddb.toolsVersion = "2147483647" field for the image. See https://bugs.launchpad.net/ubuntu/+source/open-vm-tools/+bug/1893898/comments/12

[Regression Potential]

 * The change affects Vagrant / VMware ova/vmdk formatted images, which all use modify_vmdk_header function.

Related branches

Pengpeng Sun (pengpengs) wrote :

To include VMTools version info to ova template, write 'ddb.toolsVersion=2147483647' to the VMDK file before create the template.

VDDK SDK VixDiskLib_WriteMetadata API can be used to write "ddb.toolsVersion" metadata - https://code.vmware.com/docs/11750/virtual-disk-development-kit-programming-guide/GUID-C13FE900-6B19-4082-A040-354FB1F60BCB.html
VDDK SDK: https://code.vmware.com/web/sdk/7.0/vddk

Here is an example: https://github.com/vmware/photon/blob/master/support/image-builder/ovagenerator.py#L53

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in open-vm-tools (Ubuntu):
status: New → Confirmed

Hi,
is that a bug in open-vm-tools at all?
Or more likely in the way the .ova is built?

I start to ping some people, but if it is clear to you Yuhua/Penppeng then please let me know.

If it is in open-vm-tools what would you expect to change there?

information type: Public → Private
information type: Private → Public
Robert C Jennings (rcj) wrote :

The OVA we're providing[1] is built with this[2] binary hook in livecd-rootfs which wraps up the VMDK created using the create_vmdk[3] function. That function calls modify_vmdk_header to set the tools version; this code is unchanged from when it was added in early 2017.

[1] https://cloud-images.ubuntu.com/groovy/current/groovy-server-cloudimg-amd64.ova
[2] https://git.launchpad.net/livecd-rootfs/tree/live-build/ubuntu-cpc/hooks.d/base/vmdk-ova-image.binary
[3] https://git.launchpad.net/livecd-rootfs/tree/live-build/functions#n229

Robert C Jennings (rcj) wrote :

But that function is sed'ing the file created by python3-vmdkstream so we'll look into it. The vmdk-stream-converter source package has had a minor change between focal and groovy but it doesn't explain this issue.

Robert C Jennings (rcj) wrote :

Okay, the vmdk lacks the version in bionic, focal, and groovy. The ddb.comment field that toolsVersion uses is missing:

# Disk Descriptor File
# Created by VMDKstream
version=1
CID=7e5b80a7
parentCID=ffffffff
createType="streamOptimized"

# Extent description
RDONLY 20971520 SPARSE "call-me-stream.vmdk"

#DDB

ddb.adapterType = "lsilogic"
# 20971520 / 63 / 255 rounded up
ddb.geometry.cylinders = "1306"
ddb.geometry.heads = "255"
ddb.geometry.sectors = "63"
ddb.longContentID = "8f15b3d0009d9a3f456ff7b28d324d2a"
ddb.virtualHWVersion = "7"^@^@^@^

Robert C Jennings (rcj) wrote :

So we need to fix livecd-rootfs to correctly add the tools version field to the vmdk header *and* add a check that it got there.

Robert C Jennings (rcj) wrote :

Thank you for the bug report. I have confirmed this issue and flagged the correct project, livecd-rootfs, for this work.

Changed in livecd-rootfs (Ubuntu):
status: New → Confirmed
Changed in cloud-images:
status: New → Confirmed
Changed in livecd-rootfs (Ubuntu):
milestone: none → ubuntu-20.10
Changed in open-vm-tools (Ubuntu):
status: Confirmed → Invalid
Pengpeng Sun (pengpengs) wrote :

Thanks Robert for the quick confirmation, so I assume that the bionic, focal, and groovy images will be updated to include VMTools version info. We will let customer to retry once the new images are available.

John Chittum (jchittum) on 2020-10-14
Changed in livecd-rootfs (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → John Chittum (jchittum)
Changed in cloud-images:
status: Confirmed → In Progress
assignee: nobody → John Chittum (jchittum)
importance: Undecided → High
John Chittum (jchittum) wrote :

Also confirmed that this affects Xenial images.

MP is up, will make revisions shortly based on feedback. Due to the release Thursday, this won't be included in the Groovy Gorilla day 1. We'll have this in shortly after release, and work work the SRU process from the H release to Groovy, Focal, Bionic, and Xenial.

Changed in livecd-rootfs (Ubuntu):
milestone: ubuntu-20.10 → groovy-updates
vmware-gos-Yuhua (yhzou) wrote :

hit the issue with groovy-server-cloudimg-amd64.ova daily build 23-Oct-2020

John Chittum (jchittum) wrote :

initial fix has been merged into Hirsute, and is currently in proposed. I did the following test using the deb src of release 2.697 from proposed (now superseded by 2.698)

1. downloaded dev source
2. unpacked
3. used ubuntu-oldfashioned/scripts/ubuntu-bartender to run a hirsute build

```
./ubuntu-bartender --livecd-rootfs-dir /home/jchittum/dev01/troubleshooting/various-rootfs/2.697/livecd-rootfs/ --build-provider multipass -- --series hirsute --project ubuntu-cpc --image-target vmdk
```
4. Verified via the log the new descriptor was written. The build log now prints the descriptor files. copied below
5. Verified ova and vmdk booted using Virtualbox.

Once the package moves from proposed to updates, we'll be able to produce a test hirsute image to verify the change, then work on SRUing the changes to all suites.

build log below:

+ echo 'Cat'\''ing original descriptor to console for debugging.'
Cat'ing original descriptor to console for debugging.
+ cat /tmp/tmp.LMSTXgWc8d
# Disk Descriptor File
# Created by VMDKstream
version=1
# Believe this is random
CID=7e5b80a7
# Indicates no parent
parentCID=ffffffff
createType="streamOptimized"

# Extent description
RDONLY 20971520 SPARSE "call-me-stream.vmdk"

# The Disk Data Base
#DDB

ddb.adapterType = "lsilogic"
# 20971520 / 63 / 255 rounded up
ddb.geometry.cylinders = "1306"
ddb.geometry.heads = "255"
ddb.geometry.sectors = "63"
# Believe this is random
ddb.longContentID = "8f15b3d0009d9a3f456ff7b28d324d2a"
ddb.virtualHWVersion = "7"
+ echo ''
+ echo -n 'ddb.toolsVersion = "2147483647"'
+ echo 'Printing diff of original and new descriptors.'
Printing diff of original and new descriptors.
+ cat
+ diff --text /tmp/tmp.LMSTXgWc8d /tmp/tmp.K3j1jxkbgk
23c23,24
< ddb.virtualHWVersion = "7"^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@
\ No newline at end of file
---
> ddb.virtualHWVersion = "7"
> ddb.toolsVersion = "2147483647"
\ No newline at end of file

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.698

---------------
livecd-rootfs (2.698) hirsute; urgency=medium

  * amd64: always install grub-pc with shim-signed (LP: #1901906)
  * control: install qemu-utils & snapd on riscv64.

 -- Dimitri John Ledkov <email address hidden> Thu, 29 Oct 2020 22:22:30 +0000

Changed in livecd-rootfs (Ubuntu):
status: In Progress → Fix Released
vmware-gos-Yuhua (yhzou) wrote :

I will verify it. Thanks

John Chittum (jchittum) wrote :

The latest hirsute cloud image ova and vmdk include this change. These can be downloaded from:

http://cloud-images.ubuntu.com/hirsute/20201103/

My initial checks show correct headers and images boot fine using Virtualbox. I'll await confirmation from vmware-gos-Yuhua before marking complete and beginning the SRU process.

Robert C Jennings (rcj) on 2020-11-03
no longer affects: open-vm-tools (Ubuntu Xenial)
no longer affects: open-vm-tools (Ubuntu Bionic)
no longer affects: open-vm-tools (Ubuntu Focal)
no longer affects: open-vm-tools (Ubuntu Groovy)
Changed in livecd-rootfs (Ubuntu Groovy):
status: New → In Progress
description: updated
vmware-gos-Yuhua (yhzou) wrote :

> John Chittum (jchittum) wrote on 2020-11-03: #15
> The latest hirsute cloud image ova and vmdk include this change. These can be downloaded from:

  > http://cloud-images.ubuntu.com/hirsute/20201103/

Hi John Chitum:
  I hit 404 not found when click http://cloud-images.ubuntu.com/hirsute/20201103/

Best regards
Yuhua Zou

vmware-gos-Yuhua (yhzou) wrote :

   > Hi John Chitum:
   > I hit 404 not found when click http://cloud-images.ubuntu.com/hirsute/20201103/

Please ignore the risk. I am downloading OVA from http://cloud-images.ubuntu.com/hirsute/current for testing

Best regards
Yuhua Zou

Hello vmware-gos-Yuhua, or anyone else affected,

Accepted livecd-rootfs into groovy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.694.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-groovy to verification-done-groovy. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-groovy. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in livecd-rootfs (Ubuntu Groovy):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-groovy
vmware-gos-Yuhua (yhzou) wrote :

The tools status is "Not running, version:2147483647 (Guest Managed)" after
deploy OVA without PowerOn with cloud image from http://cloud-images.ubuntu.com/hirsute/20201108/

The tools version is not correct.

After PowerOn, the tools status is "Running, version:11328 (Guest Managed)"
After PowerOn and PowerOff, the tools status is "Not running, version:11328 (Guest Managed)"

We expect the tools status is "Not running, version:11328 (Guest Managed)" after
deploy OVA without PowerOn.

Best regards
Yuhua Zou

John Chittum (jchittum) wrote :

I've confirmed the Groovy change using the following test:

1. downloaded source for proposed package
2. used ubuntu-old-fashioned/scripts/ubuntu-bartender to run a build
3. used Virtualbox to load the ova and vmdk
4. ensured the ova and vmdk loaded, cloud-init loaded, systemd completed with no issues, and kernel was loaded
5. created a custom recipe with the proposed code from git(emulating our exact build process)
6. ran a livebuild from the uploaded recipe
7. downloaded the ova and vmdk
8. using Virtualbox, ensured the ova and vmdk loaded, cloud-init loaded, systemd completed with no issues, and kernel was loaded.

tags: added: verification-done-groovy
removed: verification-needed-groovy
vmware-gos-Yuhua (yhzou) wrote :

Hi John Chittum or anyone else:
   The tools status is OK with the OVA http://cloud-images.ubuntu.com/hirsute/20201108/.
   But tools version is not correct. It seems to be random number.

   If you have any updated OVA, please let me know. I will verify it with your provided OVA.
   Thanks very much.

Best regards
Yuhua Zou

vmware-gos-Yuhua (yhzou) wrote :

  > vmware-gos-Yuhua (yhzou)#21

clarification from vmware'dev:
  For ubuntu cloud image(with suffix .ova ), the tools status is "Not running, version:2147483647 (Guest Managed)" after deploy OVA without PowerOn.
  The magic number 2147483647 is expected. Once it's power-on, the version will be overwritten

Best regards
Yuhua Zou

vmware-gos-Yuhua (yhzou) wrote :

Hi John Chittum or anyone else:
   Pass the test with you provided OVA http://cloud-images.ubuntu.com/hirsute/20201108/.

   Thanks very much.

Best regards
Yuhua Zou

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.694.1

---------------
livecd-rootfs (2.694.1) groovy; urgency=medium

  * livecd-rootfs SRU of change up to 2.699 from hirsute to groovy.

  = hyperv gallery image =
  [ Jinming Wu, Patrick ]
  * hyper-v hook: Fix writing of pkla file out to correct scratch
    directory for image build. LP: #1901846
  [ Dimitri John Ledkov ]
  * auto/config: seed ubuntu-desktop when building hyperv image LP: #1901846
  * auto/config: scope ubuntu:desktop-preinstalled:raspi image options LP: #1901846

  = CPC cloud images =
  [ Dimitri John Ledkov & Joshua Powers ]
  * amd64: always install grub-pc with shim-signed (LP: #1901906), and
    ensure to autoremove packages
  [ John Chittum ]
  * Ensure vmtools version entered into vmdk header (LP: #1893898)

  = RISC-V port =
  * control: install qemu-utils & snapd on riscv64. (LP: #1903034)

 -- Dimitri John Ledkov <email address hidden> Thu, 05 Nov 2020 11:54:14 +0000

Changed in livecd-rootfs (Ubuntu Groovy):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for livecd-rootfs has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

vmware-gos-Yuhua (yhzou) wrote :

It does not include the fix when check with groovy-server-cloudimg-amd64.ova daily build 2020-11-18. Currently this is the newest daily build on http://uec-images.ubuntu.com/groovy/current/.

I will get daily build to check a few days later.

vmware-gos-Yuhua (yhzou) wrote :

pass test with groovy-server-cloudimg-amd64.ova daily build 2020-11-25.

Hello vmware-gos-Yuhua, or anyone else affected,

Accepted livecd-rootfs into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.525.48 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in livecd-rootfs (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed-bionic
Steve Langasek (vorlon) wrote :

Hello vmware-gos-Yuhua, or anyone else affected,

Accepted livecd-rootfs into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.408.64 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in livecd-rootfs (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed-xenial
Steve Langasek (vorlon) wrote :

Hello vmware-gos-Yuhua, or anyone else affected,

Accepted livecd-rootfs into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.664.10 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in livecd-rootfs (Ubuntu Focal):
status: New → Fix Committed
tags: added: verification-needed-focal

All autopkgtests for the newly accepted livecd-rootfs (2.408.64) for xenial have finished running.
The following regressions have been reported in tests triggered by the package:

livecd-rootfs/2.408.64 (amd64)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/xenial/update_excuses.html#livecd-rootfs

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

John Chittum (jchittum) wrote :

I've confirmed the Bionic change using the following test:

1. downloaded source for proposed package
2. used ubuntu-old-fashioned/scripts/ubuntu-bartender to run a build
3. used Virtualbox to load the ova and vmdk
4. ensured the ova and vmdk loaded, cloud-init loaded, systemd completed with no issues, and kernel was loaded
5. created a custom recipe with the proposed code from git(emulating our exact build process)
6. ran a livebuild from the uploaded recipe
7. downloaded the ova and vmdk
8. using Virtualbox, ensured the ova and vmdk loaded, cloud-init loaded, systemd completed with no issues, and kernel was loaded.
9 checked build logs for bartender and lp to ensure that a diff was generated for the 2 headers and that ddb.toolsVersion = "2147483647" was present in the diff presented in the log (example in #12)

tags: added: verification-done-bionic
removed: verification-needed-bionic
John Chittum (jchittum) wrote :

I've confirmed the Focal change using the following test:

1. downloaded source for proposed package
2. used ubuntu-old-fashioned/scripts/ubuntu-bartender to run a build
3. used Virtualbox to load the ova and vmdk
4. ensured the ova and vmdk loaded, cloud-init loaded, systemd completed with no issues, and kernel was loaded
5. created a custom recipe with the proposed code from git(emulating our exact build process)
6. ran a livebuild from the uploaded recipe
7. downloaded the ova and vmdk
8. using Virtualbox, ensured the ova and vmdk loaded, cloud-init loaded, systemd completed with no issues, and kernel was loaded.
9 checked build logs for bartender and lp to ensure that a diff was generated for the 2 headers and that ddb.toolsVersion = "2147483647" was present in the diff presented in the log (example in #12)

LP builds have been a bit slow today for images and recipes.

For Xenial, I believe I have to wait for a fix in livecd-rootfs related to a different change.

tags: added: verification-done-focal
removed: verification-needed-focal
vmware-gos-Yuhua (yhzou) wrote :

The latest daily Build OVA is on 03-Dec-2020 at http://uec-images.ubuntu.com/.
I am afraid this daily build doesn't have the fix yet.

I will test the latest daily build OVA a few days later.

Best regards
Yuhua Zou

John Chittum (jchittum) wrote :

   image builds are only built after the SRU process is complete and livecd-rootfs is in the updates pocket. This wiki page will help explain the SRU process in more detail:

https://wiki.ubuntu.com/StableReleaseUpdates

   My verification is being done by building images against the livecd-rootfs project in proposed. After verification by all the bugs affecting a version of a package, a minimum 7 day wait period for community testing against proposed, the package will move to updates

   Once the package has been accepted into updates, the CPC pipeline will pick up the accepted version of livecd-rootfs, and create daily images.

   I'll update this ticket once we have confirmed daily builds for the suites that are still affected.

Mathew Hodson (mhodson) on 2020-12-11
no longer affects: open-vm-tools (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.664.10

---------------
livecd-rootfs (2.664.10) focal; urgency=medium

  * Do not hard-code the UC20 amd64 image size to 8GB as now ubuntu-image
    should be able to properly calculate the needed size itself.
  * But per discussion, we might want to keep the UC20 images a bit bigger than
    what's defined via the gadget/rootfs contents, to make sure writable is
    comfortably big enough. Use the same hard-coded value as for UC16 and UC18.
    (LP: #1905990)

livecd-rootfs (2.664.9) focal; urgency=medium

   [ John Chittum]
   * Backport Ensure toolsVersion set in vmdk header (LP: #1893898)

   [ Dimitri John Ledkov & Joshua Powers ]
   * amd64: always install grub-pc with shim-signed (LP: #1901906), and
     ensure to autoremove packages

 -- Łukasz 'sil2100' Zemczak <email address hidden> Fri, 27 Nov 2020 17:58:38 +0100

Changed in livecd-rootfs (Ubuntu Focal):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.525.48

---------------
livecd-rootfs (2.525.48) bionic; urgency=medium

   [ John Chittum ]
   * Ensure vmtools version entered into vmdk header (LP: #1893898)

   [ Dimitri John Ledkov & Joshua Powers ]
   * amd64: always install grub-pc with shim-signed (LP: #1901906), and
     ensure to autoremove packages

   [ Patrick Viafore ]
   * Increase Vagrant disk size from 10G to 40G (LP: #1580596)

 -- Robert C Jennings <email address hidden> Fri, 20 Nov 2020 15:08:54 -0600

Changed in livecd-rootfs (Ubuntu Bionic):
status: Fix Committed → Fix Released
vmware-gos-Yuhua (yhzou) wrote :

check focal-server-cloudimg-amd64.ova and find the latest daily build 10-Dec-2020 at http://uec-images.ubuntu.com/ doesn't have the fix.

John Chittum (jchittum) wrote :

focal and bionic builds with this fix were not completed prior to the December holidays. Builds with the changes for focal and bionic should happen soon in 2021.

Xenial is still awaiting a fix to be committed.

Joshua Powers (powersj) wrote :

Hi! The packages were released into the archive on December 15, 2020. Our last build of 2020 was on December 10. The first daily builds of 2021 should have this fix.

vmware-gos-Yuhua (yhzou) wrote :

Hi jchitum, Powers,
   Thanks for the info.

Best regards
Yuhua Zou

Hello vmware-gos-Yuhua, or anyone else affected,

Accepted livecd-rootfs into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.408.65 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

All autopkgtests for the newly accepted livecd-rootfs (2.408.65) for xenial have finished running.
The following regressions have been reported in tests triggered by the package:

ubuntu-image/1.10+16.04ubuntu1 (amd64)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/xenial/update_excuses.html#livecd-rootfs

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

vmware-gos-Yuhua (yhzou) wrote :

The latest xenial-server-cloudimg-amd64.ova 2021-01-12 doesn't have the fix.
I will wait next available build to verify it.

Thanks
Yuhua Zou

John Chittum (jchittum) wrote :

Focal Daily serial 20210112 has the expected change and is available for download:

http://cloud-images.ubuntu.com/daily/server/focal/20210112/

Bionic Daily serial 20120112 has the expected change, and is available for download:

http://cloud-images.ubuntu.com/daily/server/bionic/20210112/

Xenial: I am qualifying livecd-rootfs now. Once livecd-rootfs is qualified and moved to -updates, the cpc build process will take the change.

John Chittum (jchittum) wrote :

I've verified a build on xenial using 2.408.65

1. downloaded source for proposed package
2. used ubuntu-old-fashioned/scripts/ubuntu-bartender to run a build
3. used Virtualbox to load the ova and vmdk
4. ensured the ova and vmdk loaded, cloud-init loaded, systemd completed with no issues, and kernel was loaded

tags: added: verification-done-xenial
removed: verification-needed-xenial
vmware-gos-Yuhua (yhzou) wrote :

It has the fix with latest daily build for bionic-server-cloudimg-amd64.ova and focal-server-cloudimg-amd64.ova

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers