SRU: bootable buildd images for all releases

Bug #1863024 reported by Cody Shepherd on 2020-02-12
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
livecd-rootfs (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

We want to backport bootable enabling bootable buildd images to bionic
and xenial.

[Impact]

 * We don't have bootable buildd images, and we need them for Multipass.

[Test Case]

 * Perform livefs build with project ubuntu-base and subproject buildd

 * Boot .img file using Multipass, confirm it boots

 * Perform a livecd-rootfs build using the generated buildd lxd tarball

[Regression Potential]

 * Break existing artifacts in the buildd subproject

 * Cause buildd subproject to fail to build

[Other Info]

 * None

Related branches

description: updated
description: updated
description: updated
Brian Murray (brian-murray) wrote :

livecd-rootfs (2.634) focal; urgency=medium

  * Only build bootable buildd images for amd64.
  * Properly setup the chroot before using the network.

 -- David Krauser <> Thu, 12 Dec 2019 13:50:58 -0400

Changed in livecd-rootfs (Ubuntu):
status: New → Fix Released
tags: added: id-5e31aadaa8a647228b5dde23
description: updated
description: updated
Robert C Jennings (rcj) on 2020-03-26
no longer affects: livecd-rootfs (Ubuntu Eoan)
description: updated
Robert C Jennings (rcj) on 2020-03-27
Changed in livecd-rootfs (Ubuntu Bionic):
status: New → In Progress
Robert C Jennings (rcj) on 2020-03-30
Changed in livecd-rootfs (Ubuntu Bionic):
status: In Progress → Fix Committed

Hello Cody, or anyone else affected,

Accepted livecd-rootfs into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.525.43 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-bionic
David Krauser (davidkrauser) wrote :

I did the following to validate v2.525.43:

 - Performed livefs build with project ubuntu-base and subproject buildd
 - Ensured the img artifact from that build boots using Multipass
 - Performed a livecd-rootfs build using the rootfs tarball from that build

Everything appears to be working as it should.

tags: added: verification-done-bionic
removed: verification-needed-bionic
Robert C Jennings (rcj) on 2020-04-15
tags: added: verification-done
removed: verification-needed
Robert C Jennings (rcj) on 2020-04-15
tags: added: verification-needed
removed: verification-done
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.525.43

---------------
livecd-rootfs (2.525.43) bionic; urgency=medium

  [ David Krauser ]
  * Add bootable buildd image w/ fixes (LP: #1863024)

 -- Robert C Jennings <email address hidden> Mon, 30 Mar 2020 09:39:16 -0500

Changed in livecd-rootfs (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for livecd-rootfs has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Hello Cody, or anyone else affected,

Accepted livecd-rootfs into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.408.61 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in livecd-rootfs (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed-xenial
Cody Shepherd (codyshepherd) wrote :

I've built the ubuntu-base/buildd project and verified that the resulting .img boots in multipass.

Using the lxd tarball to do a build is still pending.

Cody Shepherd (codyshepherd) wrote :

The xenial changes for 2.408.61 are currently failing verification for me. Depending on the value of the --image-format argument passed to the livefs build, the build results in either a .img that boots (--image-format ext4) or lxd/rootfs tarballs that work (--image-format none), but not both in the same build.

Steve Langasek (vorlon) on 2020-10-09
tags: added: verification-failed-xenial
removed: verification-needed-xenial

The version of livecd-rootfs in the proposed pocket of Xenial that was purported to fix this bug report has been removed because one or more bugs that were to be fixed by the upload have failed verification and been in this state for more than 10 days.

Changed in livecd-rootfs (Ubuntu Xenial):
status: Fix Committed → Won't Fix
tags: removed: verification-needed

Hello Cody, or anyone else affected,

Accepted livecd-rootfs into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.408.64 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in livecd-rootfs (Ubuntu Xenial):
status: Won't Fix → Fix Committed
tags: added: verification-needed verification-needed-xenial
removed: verification-failed-xenial

All autopkgtests for the newly accepted livecd-rootfs (2.408.64) for xenial have finished running.
The following regressions have been reported in tests triggered by the package:

livecd-rootfs/2.408.64 (amd64)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/xenial/update_excuses.html#livecd-rootfs

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Hello Cody, or anyone else affected,

Accepted livecd-rootfs into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.408.65 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

All autopkgtests for the newly accepted livecd-rootfs (2.408.65) for xenial have finished running.
The following regressions have been reported in tests triggered by the package:

ubuntu-image/1.10+16.04ubuntu1 (amd64)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/xenial/update_excuses.html#livecd-rootfs

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers