cpu_hot_plug test in ubuntu_kernel_selftest failed on X/B/C s390x KVM

Bug #1809439 reported by Po-Hsu Lin
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-kernel-tests
Undecided
Colin Ian King
linux (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
Cosmic
Undecided
Unassigned

Bug Description

$ sudo make -C linux/tools/testing/selftests TARGETS=cpu-hotplug run_tests
make: Entering directory '/home/ubuntu/src/linux/tools/testing/selftests'
make[1]: Entering directory '/home/ubuntu/src/linux/tools/testing/selftests/cpu-hotplug'
make[1]: Nothing to be done for 'all'.
make[1]: Leaving directory '/home/ubuntu/src/linux/tools/testing/selftests/cpu-hotplug'
make[1]: Entering directory '/home/ubuntu/src/linux/tools/testing/selftests/cpu-hotplug'
TAP version 13
selftests: cpu-on-off-test.sh
========================================
pid 18238's current affinity mask: 3
pid 18238's new affinity mask: 1
CPU online/offline summary:
  Cpus in online state: 0-1
  Cpus in offline state: 2
Limited scope test: one hotplug cpu
  (leaves cpu in the original state):
  online to offline to online: cpu 1
  offline to online to offline: cpu 2
./cpu-on-off-test.sh: line 85: /sys/devices/system/cpu/cpu2/online: No such file or directory
online_cpu_expect_success 2: unexpected fail
not ok 1..1 selftests: cpu-on-off-test.sh [FAIL]
make[1]: Leaving directory '/home/ubuntu/src/linux/tools/testing/selftests/cpu-hotplug'
make: Leaving directory '/home/ubuntu/src/linux/tools/testing/selftests'

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: linux-image-4.15.0-43-generic 4.15.0-43.46
ProcVersionSignature: Ubuntu 4.15.0-43.46-generic 4.15.18
Uname: Linux 4.15.0-43-generic s390x
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
AlsaDevices: Error: command ['ls', '-l', '/dev/snd/'] failed with exit code 2: ls: cannot access '/dev/snd/': No such file or directory
AplayDevices: Error: [Errno 2] No such file or directory: 'aplay': 'aplay'
ApportVersion: 2.20.9-0ubuntu7.5
Architecture: s390x
ArecordDevices: Error: [Errno 2] No such file or directory: 'arecord': 'arecord'
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
CurrentDmesg:

Date: Fri Dec 21 10:38:05 2018
HibernationDevice: RESUME=UUID=caaee9b2-6bc1-4c8e-b26c-69038c092091
IwConfig: Error: [Errno 2] No such file or directory: 'iwconfig': 'iwconfig'
Lspci:

Lsusb: Error: command ['lsusb'] failed with exit code 1:
PciMultimedia:

ProcFB: Error: [Errno 2] No such file or directory: '/proc/fb'
ProcKernelCmdLine: root=UUID=c7d7bbcb-a039-4ead-abfe-7672dea0add4 crashkernel=196M
RelatedPackageVersions:
 linux-restricted-modules-4.15.0-43-generic N/A
 linux-backports-modules-4.15.0-43-generic N/A
 linux-firmware 1.173.2
RfKill: Error: [Errno 2] No such file or directory: 'rfkill': 'rfkill'
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Po-Hsu Lin (cypressyew) wrote :
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote : Missing required logs.

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1809439

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Revision history for this message
Po-Hsu Lin (cypressyew) wrote : Re: cpu_hot_plug test in ubuntu_kernel_selftest failed on B s390x KVM

This issue looks like a bug for s390x in the kernel.

There are only two processors listed on this Bionic s390x KVM, not sure why it will report CPU 0-1 are in online state, 2 in offline state:

$ cat /proc/cpuinfo
vendor_id : IBM/S390
# processors : 2
bogomips per cpu: 3033.00
max thread id : 0
features : esan3 zarch stfle msa ldisp eimm dfp edat etf3eh highgprs te vx
facilities : 0 1 2 3 4 6 7 8 9 10 13 14 16 17 18 19 20 21 22 23 24 25 26 27 28 30 31 32 33 34 35 36 37 40 41 42 43 44 45 47 48 49 50 51 52 53 57 64 69 71 73 74 75 76 77 78 80 81 82 129 131 138
cache0 : level=1 type=Data scope=Private size=128K line_size=256 associativity=8
cache1 : level=1 type=Instruction scope=Private size=96K line_size=256 associativity=6
cache2 : level=2 type=Data scope=Private size=2048K line_size=256 associativity=8
cache3 : level=2 type=Instruction scope=Private size=2048K line_size=256 associativity=8
cache4 : level=3 type=Unified scope=Shared size=65536K line_size=256 associativity=16
cache5 : level=4 type=Unified scope=Shared size=491520K line_size=256 associativity=30
processor 0: version = FF, identification = 268F67, machine = 2964
processor 1: version = FF, identification = 268F67, machine = 2964

cpu number : 0
cpu MHz dynamic : 5000
cpu MHz static : 5000

cpu number : 1
cpu MHz dynamic : 5000
cpu MHz static : 5000

Revision history for this message
Po-Hsu Lin (cypressyew) wrote :

Verified with the test suite upstream, this issue still exist.

Po-Hsu Lin (cypressyew)
no longer affects: ubuntu-kernel-tests
Po-Hsu Lin (cypressyew)
summary: - cpu_hot_plug test in ubuntu_kernel_selftest failed on B s390x KVM
+ cpu_hot_plug test in ubuntu_kernel_selftest failed on X/B/C s390x KVM
Revision history for this message
Po-Hsu Lin (cypressyew) wrote :

This issue has been addressed by Colin's commit:
https://kernel.ubuntu.com/git/ubuntu/autotest-client-tests.git/commit/?id=53ef6cf2cc35cbd13a16c363af05e22a0cbcbb75

We could expect that to land on the upstream branch in the future as well.

Changed in ubuntu-kernel-tests:
status: New → Fix Released
assignee: nobody → Colin Ian King (colin-king)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers