(grub2 doesn't boot unverified kernel under UEFI, SB state unknown) package shim-signed 1.28+0.9+1474479173.6c180c6-1ubuntu1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #1695065 reported by Gary Budd on 2017-06-01
86
This bug affects 14 people
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
High
Mathieu Trudel-Lapierre
Trusty
High
Mathieu Trudel-Lapierre
Xenial
High
Mathieu Trudel-Lapierre
Yakkety
Undecided
Unassigned
Zesty
Undecided
Unassigned
Artful
High
Mathieu Trudel-Lapierre

Bug Description

the program error form just popped up without any apparant reason

ProblemType: Package
DistroRelease: Ubuntu 17.04
Package: shim-signed 1.28+0.9+1474479173.6c180c6-1ubuntu1
ProcVersionSignature: Ubuntu 4.10.0-21.23-generic 4.10.11
Uname: Linux 4.10.0-21-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
.proc.sys.kernel.moksbstate_disabled: 0
.sys.firmware.efi.efivars.MokSBStateRT-605dab50-e046-4300-abb6-3dd810dd8b23: 

Gary Budd (gkbudd) wrote :
tags: removed: need-duplicate-check

Thank you for reporting this bug. Your report shows that you had an unattended upgrade that ran and upgraded the version of the nvidia dkms module that you have installed; and that this triggered a request from shim to disable SecureBoot on your system, because dkms modules are incompatible with SecureBoot currently.

Do you remember being prompted previously about turning off SecureBoot? Did you elect not to turn off SecureBoot? Or, did you choose the option to disable SecureBoot, but not confirm this selection on reboot?

This may be the same as bug #1694986.

summary: - package shim-signed 1.28+0.9+1474479173.6c180c6-1ubuntu1 failed to
- install/upgrade: subprocess installed post-installation script returned
- error exit status 1
+ (unattended-upgrade, already-installed dkms modules) package shim-signed
+ 1.28+0.9+1474479173.6c180c6-1ubuntu1 failed to install/upgrade:
+ subprocess installed post-installation script returned error exit status
+ 1
Changed in shim-signed (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (cyphermox)
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in shim-signed (Ubuntu):
status: New → Confirmed
Steve Langasek (vorlon) wrote :

I understand this was an issue with how grub2 was booting unsigned kernels which has been resolved with grub2 2.02~beta3-4ubuntu4 in artful.

affects: shim-signed (Ubuntu) → grub2 (Ubuntu)
Changed in grub2 (Ubuntu):
status: Confirmed → Fix Released
Steve Langasek (vorlon) on 2017-06-03
Changed in grub2 (Ubuntu Trusty):
status: New → Triaged
Changed in grub2 (Ubuntu Xenial):
status: New → Triaged
Changed in grub2 (Ubuntu Trusty):
importance: Undecided → High
Changed in grub2 (Ubuntu Xenial):
importance: Undecided → High
Changed in grub2 (Ubuntu Trusty):
assignee: nobody → Mathieu Trudel-Lapierre (cyphermox)
Changed in grub2 (Ubuntu Xenial):
assignee: nobody → Mathieu Trudel-Lapierre (cyphermox)
milestone: none → ubuntu-16.04.3
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grub2 (Ubuntu Yakkety):
status: New → Confirmed
Changed in grub2 (Ubuntu Zesty):
status: New → Confirmed
Steve Langasek (vorlon) on 2017-06-03
summary: - (unattended-upgrade, already-installed dkms modules) package shim-signed
- 1.28+0.9+1474479173.6c180c6-1ubuntu1 failed to install/upgrade:
- subprocess installed post-installation script returned error exit status
- 1
+ (grub2 doesn't boot unverified kernel under UEFI, SB state unknown)
+ package shim-signed 1.28+0.9+1474479173.6c180c6-1ubuntu1 failed to
+ install/upgrade: subprocess installed post-installation script returned
+ error exit status 1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers