fails on multipath: cannot find /dev/sda1

Bug #1681932 reported by Mathieu Trudel-Lapierre on 2017-04-11
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
grub-installer (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Yakkety
Undecided
Unassigned
Zesty
Undecided
Unassigned
Artful
Undecided
Unassigned
grub2 (Ubuntu)
Undecided
Mathieu Trudel-Lapierre
Xenial
Undecided
Unassigned
Yakkety
Undecided
Unassigned
Zesty
Undecided
Unassigned
Artful
Undecided
Mathieu Trudel-Lapierre

Bug Description

Install on ppc64el with multipath (so /dev/sda1 is claimed by /dev/mapper/mpatha1) fails to complete at the grub-installer step:

Apr 11 20:02:24 grub-installer: info: Installing grub on '/dev/sda1'
Apr 11 20:02:24 grub-installer: info: grub-install does not support --no-floppy
Apr 11 20:02:24 grub-installer: info: Running chroot /target grub-install --force "/dev/sda1"
Apr 11 20:02:24 grub-installer: Installing for powerpc-ieee1275 platform.
Apr 11 20:02:25 grub-installer: grub-install: error: cannot find a GRUB drive for /dev/sda1. Check your device.map.
Apr 11 20:02:25 grub-installer: error: Running 'grub-install --force "/dev/sda1"' failed.
Apr 11 20:08:17 main-menu[1853]: WARNING **: Configuring 'grub-installer' failed with error code 1
Apr 11 20:08:17 main-menu[1853]: WARNING **: Menu item 'grub-installer' failed.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1681932

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub-installer - 1.128ubuntu8

---------------
grub-installer (1.128ubuntu8) zesty; urgency=medium

  * Fix a typo in PReP bootdev selection code; we should not skip over a valid
    mpath device in favor of the underlying block device, since it won't be
    available for grub-install later. (LP: #1681932)

 -- Mathieu Trudel-Lapierre <email address hidden> Tue, 11 Apr 2017 16:21:30 -0400

Changed in grub-installer (Ubuntu):
status: New → Fix Released

Looks like grub also fails, for the same reason (grub carries its own copy of prep-bootdev).

Checking artful correctly to make sure this behaves as expected. This may well be a direct side-effect of using VMs to do the testing.

Changed in grub2 (Ubuntu Artful):
assignee: nobody → Mathieu Trudel-Lapierre (cyphermox)
status: New → In Progress
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grub-installer (Ubuntu Xenial):
status: New → Confirmed
Changed in grub-installer (Ubuntu Yakkety):
status: New → Confirmed
Changed in grub-installer (Ubuntu Zesty):
status: New → Confirmed
Changed in grub2 (Ubuntu Xenial):
status: New → Confirmed
Changed in grub2 (Ubuntu Yakkety):
status: New → Confirmed
Changed in grub2 (Ubuntu Zesty):
status: New → Confirmed
tags: added: id-597a82a58c992098c3bbcb0a
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers