Bump go-systemd in Ubuntu Xenial

Bug #1568902 reported by kay on 2016-04-11
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
fleet (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
golang-github-coreos-go-systemd (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned

Bug Description

Current fleet build has an issue with incorrect serialization order. This issue was fixed in go-systemd v4 (https://github.com/coreos/go-systemd/commit/3130945d94f8300bece93f1c4ca6a0be965072fa). It is not possible to use fleet out-of-the-box because of this bug. I'd recommend to bump go-systemd release for the Xenial release.

More details are here: https://github.com/coreos/fleet/issues/1402

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in golang-github-coreos-go-systemd (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) on 2016-07-21
tags: added: upgrade-software-version
Changed in golang-github-coreos-go-systemd (Ubuntu):
status: Confirmed → Fix Released
Changed in fleet (Ubuntu Xenial):
status: New → Confirmed
Changed in fleet (Ubuntu):
status: New → Confirmed
Changed in golang-github-coreos-go-systemd (Ubuntu Xenial):
status: New → Confirmed
Jeremy Bicha (jbicha) wrote :

Ubuntu 16.10 development "yakkety" has golang-github-coreos-go-systemd 0.5 so marking this fixed there.

Jeremy Bicha (jbicha) wrote :

^ actually it's 5-1 not 0.5

Subscribing Michael Hudson Doyle - is there any SRU activity related to this planned?
I know that go is always special in that regard so I wanted to ask you.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers