/sbin/upstart:indicator-session-unknown-user-error

Bug #1447099 reported by errors.ubuntu.com bug bridge on 2015-04-22
196
This bug affects 82 people
Affects Status Importance Assigned to Milestone
upstart
Undecided
Unassigned
upstart (Ubuntu)
High
Dimitri John Ledkov
Vivid
Undecided
Unassigned
Wily
High
Unassigned

Bug Description

The Ubuntu Error Tracker has been receiving reports about a problem regarding upstart. This problem was most recently seen with version 1.13.2-0ubuntu13, the problem page at https://errors.ubuntu.com/problem/09ab1b2ed4cff7556ed135307deb9f99c107193a contains more details.

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in upstart (Ubuntu):
status: New → Confirmed
Changed in upstart (Ubuntu):
importance: Undecided → High
Changed in upstart (Ubuntu):
assignee: nobody → Dimitri John Ledkov (xnox)
status: Confirmed → Triaged
Changed in upstart (Ubuntu Vivid):
status: New → Confirmed

I was directed to a duplicate report of this by Apport. It hits me at login on Wily.

Guntbert Reiter (guntbert) wrote :

This issue still exists in Ubuntu 15.10, (upgraded several times).

Changed in upstart (Ubuntu Wily):
assignee: Dimitri John Ledkov (xnox) → nobody
Changed in upstart (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package upstart - 1.13.2-0ubuntu19

---------------
upstart (1.13.2-0ubuntu19) xenial; urgency=medium

  * Set bzr vcs to lp:~ubuntu-core-dev/upstart/ubuntu
  * Do not start upstart event bridge, when pid1 is systemd LP: #1447099
  * In init-checkconf, use /sbin/upstart path

 -- Dimitri John Ledkov <email address hidden> Wed, 03 Feb 2016 14:04:04 +0000

Changed in upstart (Ubuntu):
status: Fix Committed → Fix Released
Reinhard Tartler (siretart) wrote :

Does this patch also apply to wily, and thus needs to be uploaded there as well?

MrStone (rkj) wrote :

I updated from 14.04 LTS to 15.10 and this started happening. My upstart version is 1.13.2

MrStone (rkj) wrote :

ok, turns out removeing plexmediaserver and restarting helped.

Thomas Mayer (thomas303) wrote :

I updated from 14.04 to 16.04. That said, xenial is also affected. Apport error message was shown shortly after login.

Apport forwarded me to https://bugs.launchpad.net/bugs/1452849 which duplicates this issue.

iGadget (igadget) wrote :

I can confirm #9 as it just happened on my 16.04 system as well. However, mine was a fresh install instead of an update from 14.04.

AnonymouseP (anonymouse.p) wrote :

Just had this on reboot after today's updates. Error report brought me to bug#1452849, useful feature that!
Xenial 16.04 fresh install.

Same error in 16.04.01
fresh install

Bob Briggs (bob-briggs) wrote :

It's still here, 16.04.1

Chuck Ritola (cobra176) wrote :

Still getting the error.
xubuntu 16.04, x86-64, last updated 05-25-2017.

Michael Lee (michaellee8) wrote :

This bugs still exists here, 16.04, but only presents in some specific user account.

pelm (pelle-ekh) wrote :

Just get the error on a 16.04.3 system. Haven't had anything like this before. The system is a freshly installed Xenial Xerus 16.04 updated to 16.04.3. Without the HWE stack.

Gabriel Urban (gebri) wrote :

Still ocasionaly hiting this error on Ubuntu 16.04.3 LTS
Can be this error related to using "external users"?
My computer is joined to ActiveDirectory (AD) domain, and I'm loged as domain user.
Probably when starting upstart there are no info from user account.
I never hit this error when logged with local account.
Can I install upstart version with debug/trace info, or see what exactly goes wrong?
Or otherwise help to fix this error?

pelm (pelle-ekh) wrote :

I see this occasionally, not always, and I'm only using a local user account.

andrewanswer (andrewanswer) wrote :

If you change in /usr/share/upstart/sessions/upstart-event-bridge.conf (Ubuntu 16.04.3 LTS)

test -d /run/systemd/system && { stop; exit 0; }
to
test ! -d /run/systemd/system || { stop; exit 0; }

(like in applied patch) then error is gone.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers