[SRU] Add support for liberty cloud-archive

Bug #1472586 reported by James Page on 2015-07-08
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Undecided
Corey Bryant
Trusty
Undecided
Corey Bryant
Wily
Undecided
Corey Bryant

Bug Description

Please add support for:

   cloud-archive:liberty
   cloud-archive:liberty-proposed

This will also need to be SRU'ed back to trusty.

[Impact]
End users have to manually enable the liberty cloud archive pockets.

[Test case]
sudo add-apt-repository cloud-archive:liberty
sudo add-apt-repository cloud-archive:liberty-proposed

[Regression potential]
Limited - just a data item addition

James Page (james-page) on 2015-07-08
Changed in software-properties (Ubuntu):
assignee: nobody → Corey Bryant (corey.bryant)
description: updated
Changed in software-properties (Ubuntu Trusty):
assignee: nobody → Corey Bryant (corey.bryant)
summary: - Add support for liberty cloud-archive
+ [SRU] Add support for liberty cloud-archive
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.96.10

---------------
software-properties (0.96.10) wily; urgency=medium

  * cloudarchive: Enable support for the Liberty Ubuntu Cloud Archive on
    14.04 (LP: #1472586).

 -- Corey Bryant <email address hidden> Wed, 02 Sep 2015 12:35:10 -0400

Changed in software-properties (Ubuntu Wily):
status: New → Fix Released

Hello James, or anyone else affected,

Accepted software-properties into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/software-properties/0.92.37.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in software-properties (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
James Page (james-page) wrote :

(trusty-amd64)root@armstrong:~# add-apt-repository cloud-archive:liberty
 Ubuntu Cloud Archive for OpenStack Liberty
 More info: https://wiki.ubuntu.com/ServerTeam/CloudArchive
Press [ENTER] to continue or ctrl-c to cancel adding it

Reading package lists...
Building dependency tree...
Reading state information...
The following NEW packages will be installed:
  ubuntu-cloud-keyring
0 upgraded, 1 newly installed, 0 to remove and 6 not upgraded.
Need to get 5086 B of archives.
After this operation, 34.8 kB of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu/ trusty/universe ubuntu-cloud-keyring all 2012.08.14 [5086 B]
Fetched 5086 B in 0s (0 B/s)
Selecting previously unselected package ubuntu-cloud-keyring.
(Reading database ... 14372 files and directories currently installed.)
Preparing to unpack .../ubuntu-cloud-keyring_2012.08.14_all.deb ...
Unpacking ubuntu-cloud-keyring (2012.08.14) ...
Setting up ubuntu-cloud-keyring (2012.08.14) ...
Importing ubuntu-cloud.archive.canonical.com keyring
OK
Processing ubuntu-cloud.archive.canonical.com removal keyring
gpg: /etc/apt/trustdb.gpg: trustdb created
OK
(trusty-amd64)root@armstrong:~# add-apt-repository cloud-archive:liberty-proposed
 Ubuntu Cloud Archive for OpenStack Liberty [proposed]
 More info: https://wiki.ubuntu.com/ServerTeam/CloudArchive
Press [ENTER] to continue or ctrl-c to cancel adding it

Reading package lists...
Building dependency tree...
Reading state information...
ubuntu-cloud-keyring is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 6 not upgraded.
(trusty-amd64)root@armstrong:~# cat /etc/apt/sources.list.
sources.list.d/ sources.list.save
(trusty-amd64)root@armstrong:~# cat /etc/apt/sources.list.d/cloudarchive-liberty
cloudarchive-liberty-proposed.list cloudarchive-liberty.list cloudarchive-liberty.list.save
(trusty-amd64)root@armstrong:~# cat /etc/apt/sources.list.d/cloudarchive-liberty*
deb http://ubuntu-cloud.archive.canonical.com/ubuntu trusty-proposed/liberty main
# deb-src http://ubuntu-cloud.archive.canonical.com/ubuntu trusty-proposed/liberty main
deb http://ubuntu-cloud.archive.canonical.com/ubuntu trusty-updates/liberty main
# deb-src http://ubuntu-cloud.archive.canonical.com/ubuntu trusty-updates/liberty main
deb http://ubuntu-cloud.archive.canonical.com/ubuntu trusty-updates/liberty main
# deb-src http://ubuntu-cloud.archive.canonical.com/ubuntu trusty-updates/liberty main

tags: added: verification-done
removed: verification-needed
James Page (james-page) wrote :

LGTM +1

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.92.37.5

---------------
software-properties (0.92.37.5) trusty-proposed; urgency=medium

  * cloudarchive: Enable support for the Liberty Ubuntu Cloud Archive on
    14.04 (LP: #1472586).
  * Revert SRU changes for "fix importing keys from path with special chars"
    due to verification-failed in trusty-proposed.

 -- Corey Bryant <email address hidden> Wed, 02 Sep 2015 12:31:11 -0400

Changed in software-properties (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for software-properties has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers