ubuntu-ui-toolkit-autopilot should have ${binary:Version} depends on qtdeclarative5-ubuntu-ui-toolkit-plugin

Bug #1236085 reported by Francis Ginther on 2013-10-06
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu UI Toolkit
Fix Released
Low
Zoltan Balogh
ubuntu-ui-toolkit (Ubuntu)
Undecided
Unassigned
Vivid
Undecided
Unassigned

Bug Description

The ubuntu-ui-toolkit-autopilot should have the following dependency:
    qtdeclarative5-ubuntu-ui-toolkit-plugin (>= ${source:Version}),

The reason is that functionality in the emulators are tied to specific changes in the plugin. For example, the recent tab index changes:
https://code.launchpad.net/~zsombi/ubuntu-ui-toolkit/tab-index/+merge/188769

I believe this lack of a dependency results in errors in the core apps autopilot tests:
http://91.189.93.70:8080/job/generic-mediumtests/751

The apps have a dependency on ubuntu-ui-toolkit-autopilot. I found that when testing with ppa:ubuntu-sdk-team/ppa enabled, the core apps tests would pull in the latest emulators from ubuntu-ui-toolkit-autopilot, but that in turn would NOT pull in the latest plugin as one was already local installed. The problem is then that there is a mismatch between what the emulator and the plugin are doing. I was able to get these test to pass locally by forcing install of the latest qtdeclarative5-ubuntu-ui-toolkit-plugin to match the ubuntu-ui-toolkit-autopilot version.

Related branches

Zoltan Balogh (bzoltan) on 2013-10-11
Changed in ubuntu-ui-toolkit:
assignee: nobody → Zoltan Balogh (bzoltan)
Changed in ubuntu-ui-toolkit:
status: New → Confirmed
importance: Undecided → Low
Zoltan Balogh (bzoltan) wrote :
Changed in ubuntu-ui-toolkit:
status: Confirmed → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-ui-toolkit/staging at revision None, scheduled for release in ubuntu-ui-toolkit, milestone Unknown

Changed in ubuntu-ui-toolkit:
status: In Progress → Fix Committed
Zoltan Balogh (bzoltan) on 2014-10-01
Changed in ubuntu-ui-toolkit:
status: Fix Committed → Fix Released
Zsombor Egri (zsombi) on 2015-07-14
Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers