Turning the screen on/off eventually causes USC to crash on krillin with 0.13

Bug #1454201 reported by Alexandros Frantzis on 2015-05-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Unassigned
Mir
Fix Released
Critical
Alexandros Frantzis
mir (Ubuntu)
Undecided
Unassigned
Vivid
Undecided
Unassigned

Bug Description

Turning the screen on/off eventually causes USC to crash on krillin with 0.13. The crash occurs when trying to destroy program or shader objects when an EGL context is current. Note that doing so is permitted by the GL specification:

"If program is not the current program for any GL context, it is deleted immediately. Otherwise, program is flagged for deletion and will be deleted when it is no longer the current program for any context"

Related branches

Alexandros Frantzis (afrantzis) wrote :
Changed in mir:
milestone: none → 0.14.0
status: Confirmed → Triaged
Changed in mir (Ubuntu):
status: New → Invalid
Changed in mir:
status: Triaged → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:mir at revision 2578, scheduled for release in mir, milestone 0.14.0

Changed in mir:
status: In Progress → Fix Committed
no longer affects: mir/0.13
Daniel van Vugt (vanvugt) wrote :

Fix seems to be present in the 0.13.0 release tarball.

Changed in mir:
milestone: 0.14.0 → 0.13.0
no longer affects: mir/0.13
Changed in mir:
status: Fix Committed → Fix Released
Pat McGowan (pat-mcgowan) wrote :

for tracking

Changed in canonical-devices-system-image:
importance: Undecided → Critical
milestone: none → ww22-2015
status: New → Fix Released
Changed in mir (Ubuntu):
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments