vino-server crashed with SIGABRT in __libc_message()

Bug #987287 reported by Andrius Skerla on 2012-04-23
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Fix Released
vino (Ubuntu)

Bug Description

dont know

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: vino 3.4.0-0ubuntu3
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu3
Architecture: amd64
CrashCounter: 1
Date: Mon Apr 23 16:13:57 2012
ExecutablePath: /usr/lib/vino/vino-server
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
ProcCmdline: /usr/lib/vino/vino-server --sm-disable
 PATH=(custom, no user)
Signal: 6
SourcePackage: vino
 raise () from /lib/x86_64-linux-gnu/
 abort () from /lib/x86_64-linux-gnu/
 ?? () from /lib/x86_64-linux-gnu/
 ?? () from /lib/x86_64-linux-gnu/
 FreeUPNPUrls () from /usr/lib/
Title: vino-server crashed with SIGABRT in raise()
UpgradeStatus: Upgraded to precise on 2012-04-02 (21 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Andrius Skerla (rainder) wrote :

 __libc_message (do_abort=2, fmt=0x7f76ac5d50d0 "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:201
 malloc_printerr (action=3, str=0x7f76ac5d2081 "free(): invalid pointer", ptr=<optimized out>) at malloc.c:5007
 FreeUPNPUrls (urls=0x2607580) at miniupnpc.c:759
 clean_upnp_data (upnp=0x25fb1f0) at server/vino-upnp.c:61
 update_upnp_status (upnp=0x25fb1f0) at server/vino-upnp.c:83

Changed in vino (Ubuntu):
importance: Undecided → Medium
summary: - vino-server crashed with SIGABRT in raise()
+ vino-server crashed with SIGABRT in __libc_message()
tags: removed: need-amd64-retrace
tags: added: quantal
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in vino (Ubuntu):
status: New → Confirmed
tags: added: running-unity
visibility: private → public
Changed in vino (Ubuntu):
importance: Medium → High
Changed in vino (Ubuntu Quantal):
milestone: none → quantal-updates
Sebastien Bacher (seb128) wrote :
no longer affects: vino (Ubuntu Quantal)
Changed in vino (Ubuntu):
status: Confirmed → Fix Committed
milestone: quantal-updates → none
Changed in vino:
importance: Unknown → Medium
status: Unknown → Fix Released
Mathew Hodson (mathew-hodson) wrote :

Not in trusty-proposed.

Changed in vino (Ubuntu Trusty):
status: Fix Committed → Confirmed
autra (autra) wrote :

Is there a chance to see it landed soon ?

Changed in vino (Ubuntu):
status: Fix Committed → Triaged
Changed in vino (Ubuntu Trusty):
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vino - 3.8.1-0ubuntu7

vino (3.8.1-0ubuntu7) xenial; urgency=medium

  * debian/patches/git_struct_init.patch:
    - "Be more careful with memory allocation", should fix some of the
      segfault issues reports (lp: #987287)
  * debian/patches/git_small_bugfixes.patch:
    - backport some easy bugfixes
  * debian/patches/git_no_http_server.patch:
    - remove http server, it's not used and listen on interfaces for no
      reason (lp: #984093)

 -- Sebastien Bacher <email address hidden> Fri, 20 Nov 2015 16:51:19 +0100

Changed in vino (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.