Can not stop wired network via "All Setting->Network->Wired" on Ubuntu OS

Bug #1354987 reported by Howy on 2014-08-11
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OEM Priority Project
Medium
anagha
gnome-control-center (Ubuntu)
Medium
Unassigned
Trusty
Undecided
Unassigned
unity-control-center (Ubuntu)
Medium
Mathieu Trudel-Lapierre
Trusty
Undecided
Unassigned

Bug Description

Install Ubuntu 14.04 on the machine.
After installation complete and go through OOBE to desktop, connect wired network cable to the UUT, and then open "All Setting->Network->Wired", find that the wired network can not be stopped.

Please see the attached file for detail.

Note:
1 .Ubuntu 14.04 LTS
2. Can start or stop wired network via check or uncheck "Enable Networking" item at the top right corner.

Steps to Reproduce:
1.Install Ubuntu 14.04 on the machine.
2.Go through OOBE to desktop.
3.Connect wired network,try to stop wired network at"All Setting->Network->Wired".

Related branches

Howy (howy1979) wrote :
Howy (howy1979) on 2014-08-11
affects: network-manager → oem-priority
Kent Lin (kent-jclin) on 2014-08-11
description: updated
Kent Lin (kent-jclin) on 2014-08-11
Changed in oem-priority:
importance: Undecided → Medium

This isn't a NetworkManager bug; reassigning to gnome-control-center/unity-control-center.

Looks like (at quick glance, without digging into the code) the switch is triggering the wrong thing in NM, rather than disabling wired it's doing something else.

affects: network-manager (Ubuntu) → gnome-control-center (Ubuntu)
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in unity-control-center (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Changed in unity-control-center (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-control-center - 14.10.0+14.10.20140922-0ubuntu1

---------------
unity-control-center (14.10.0+14.10.20140922-0ubuntu1) utopic; urgency=low

  [ Robert Ancell ]
  * Fix Vcs-Bzr link that was pointing to gnome-control-center packaging
  * Use libunity-settings-daemon to replace functionality that is being
    changed/removed in libgnome-desktop (LP: #1372240)

  [ David Henningsson ]
  * Make sure selecting a bluetooth input works even when the headset is
    in A2DP mode, and make sure the correct levels are shown in the
    level bar (Bug 1367693) (LP: #1367693)

  [ Mathieu Trudel-Lapierre ]
  * Deactivate the wired device when wired is switched off. (LP:
    #1354987)
 -- Ubuntu daily release <email address hidden> Mon, 22 Sep 2014 11:36:24 +0000

Changed in unity-control-center (Ubuntu):
status: Triaged → Fix Released
Ara Pulido (ara) wrote :

We need to backport this fix to trusty

Changed in oem-priority:
status: New → Triaged
anagha (anghakc) on 2015-11-15
Changed in oem-priority:
assignee: nobody → anagha (anghakc)
status: Triaged → Confirmed
Ara Pulido (ara) on 2016-05-19
Changed in oem-priority:
status: Confirmed → Fix Released
no longer affects: oem-priority/trusty
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers