Precise w/Trusty HWE -> Trusty release upgrade fails : ubuntu-desktop fails to configure

Bug #1347964 reported by Erick Brunzell on 2014-07-23
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Trusty
High
Michael Vogt

Bug Description

TEST CASE:
#1: Install Ubuntu 12.04.4 which has the Saucy HWE kernel and X-stack
#2: Update Ubuntu 12.04.4 and reboot when prompted
#3: After reboot open Software Updater, accept the HWE upgrade, and reboot again
#4: Perform the upgrade to Trusty using update-manager -d -c

== Original Description ==

This will probably go down in history as the worst bug report I've ever filed but I'm a bit clueless here. I've actually repeated this twice with similar results and I know no more than I knew after the first failure. I'm certain though that we can't just let this one slip by because we'll recommend Precise -> Trusty upgrades when 14.04.1 is released - people are expecting it. And the Trusty HWE upgrade was disastrous for a number of users.

Ultimately I'm going to need someone with more knowledge of the process to reproduce this so:

#1: Install Ubuntu 12.04.4 which has the Saucy HWE kernel and X-stack
#2: Update Ubuntu 12.04.4 and reboot when prompted
#3: After reboot open Software Updater, accept the HWE upgrade, and reboot again
#4: Perform the upgrade to Trusty using update-manager -d -c

In my first test I was running 12.04.4 amd64 with the Trusty HWE and the Unity DE. Shortly after the upgrade began I got a crash report telling me that the update manager crashed so I selected relaunch and left the report button ticked but no report window ever appeared in Firefox. The upgrade process did continue however - it seemed to take much longer than usual but finally showed "errors were encountered while processing ubuntu-desktop", then it proceeded to search for obsolete packages which took a long time but never prompted me with a list of what it wanted to remove or gave any choice. The next thing I saw was the reboot to complete upgrade dialog so I did. Thereafter I was unable to load the Ubuntu session. TTY output was insane, for instance apt-get -f install produced a list to autoremove that was so long it scrolled off the screen. So I moved on to test #2.

In my second test I was running Ubuntu 12.04.4 i386 with the Trusty HWE and the flashback (metacity) DE. Once again I got that update manager crash report but this time I did not select relaunch. I did once again leave send report ticked but no report was sent. The upgrade continued, once again taking much longer than usual, and once again saying "errors were encountered while processing ubuntu-desktop", searching for obsolete packages, and not displaying any prompt until telling me to reboot. This time I just closed without rebooting and filed this bug report.

So I'm still booted into this desktop - luckily I already had Firefox open, but no apps will display, nautilus doesn't work, but I was able to open the terminal with Ctrl+Alt+T so I could file this. Once filed I'll dig around a bit and see if I can find anything else in the logs that might be useful.

Sorry I can't be more helpful but I'm in over my head this time.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: ubuntu-release-upgrader-core 1:0.220.2
ProcVersionSignature: Ubuntu 3.13.0-32.57~precise1-generic 3.13.11.4
Uname: Linux 3.13.0-32-generic i686
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: i386
CrashDB: ubuntu
CurrentDesktop: GNOME
Date: Wed Jul 23 17:23:23 2014
InstallationDate: Installed on 2014-07-19 (4 days ago)
InstallationMedia: Ubuntu 12.04.4 LTS "Precise Pangolin" - Release i386 (20140204)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubuntu-release-upgrader
Symptom: ubuntu-release-upgrader
UpgradeStatus: Upgraded to trusty on 2014-07-23 (0 days ago)
VarLogDistupgradeAptclonesystemstate.tar.gz: Error: command ['pkexec', 'cat', '/var/log/dist-upgrade/apt-clone_system_state.tar.gz'] failed with exit code -1:
VarLogDistupgradeTermlog:

Erick Brunzell (lbsolost) wrote :
Erick Brunzell (lbsolost) wrote :

I had copied this text from that initial update manager crash that never filed:

update-manager crashed with TypeError: pulse() takes exactly 1 argument (2 given)

I was trying to find the older crash logs but can't. Maybe cloned somewhere during upgrade? I know there were some but can't find them now.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1347964

tags: added: iso-testing
Erick Brunzell (lbsolost) wrote :
Download full text (6.1 KiB)

Before rebooting I thought I'd try to collect a bit more info:

lance@lance-desktop:~$ sudo apt-get -f install
[sudo] password for lance:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  apg checkbox-ng checkbox-ng-service cheese-common
  compiz-plugins-main-default compizconfig-backend-gconf consolekit
  cups-pk-helper empathy-common espeak folks-common foomatic-db-engine
  gir1.2-dbusmenu-gtk-0.4 gir1.2-gst-plugins-base-0.10 gir1.2-gstreamer-0.10
  gir1.2-gtk-2.0 gir1.2-indicate-0.7 gir1.2-launchpad-integration-3.0
  gir1.2-polkit-1.0 gir1.2-totem-1.0 gir1.2-totem-plparser-1.0 gkbd-capplet
  gnome-control-center-data gnome-control-center-shared-data gnome-games-data
  gnome-online-accounts gnome-video-effects gstreamer0.10-nice
  gstreamer1.0-nice gstreamer1.0-plugins-bad-faad
  gstreamer1.0-plugins-bad-videoparsers gtk2-engines guile-1.8-libs
  gwibber-service gwibber-service-facebook gwibber-service-identica
  gwibber-service-twitter ibus-pinyin-db-android launchpad-integration
  libaccount-plugin-1.0-0 libaccounts-qt5-1 libappindicator1 libarchive12
  libatk-adaptor-schemas libavahi-gobject0 libavahi-ui-gtk3-0 libbind9-80
  libboost-serialization1.46.1 libbrlapi0.5 libcamel-1.2-29 libcelt0-0
  libchromaprint0 libck-connector0 libclass-isa-perl libclutter-1.0-common
  libcmis-0.2-0 libcogl-common libcupsdriver1 libcurl3-nss libdbusmenu-qt5
  libdconf-dbus-1-0 libdconf-qt0 libdconf0 libdee-qt5-3 libdiscid0 libdns81
  libdotconf1.0 libebackend-1.2-1 libecal-1.2-10 libedata-cal-1.2-13
  libedataserver-1.2-15 libegl1-mesa-drivers-lts-trusty
  libegl1-mesa-lts-trusty libexiv2-11 libfarstream-0.1-0 libfarstream-0.2-2
  libfftw3-3 libfftw3-long3 libfluidsynth1 libfolks-eds25 libfolks-telepathy25
  libfolks25 libgbm1-lts-trusty libgconf2-4 libgcr-3-1 libgd2-xpm libgdu-gtk0
  libgdu0 libgexiv2-1 libglew1.6 libglewmx1.6 libgnome-bluetooth8
  libgnome-menu2 libgnome2-common libgnomekbd-common libgnomekbd7 libgnomekbd8
  libgoa-1.0-0 libgoa-1.0-common libgphoto2-2 libgphoto2-port0 libgrail5
  libgsettings-qt1 libgssdp-1.0-3 libgstreamer-plugins-bad1.0-0 libgtkglext1
  libgtkspell-3-0 libgupnp-1.0-4 libgupnp-igd-1.0-4 libgweather-3-0
  libgwibber-gtk2 libgwibber2 libhud2 libibus-1.0-0 libical0 libilmbase6
  libimobiledevice2 libindicate-gtk3 libindicate5 libindicator7 libisc83
  libisccc80 libisccfg82 libjs-jquery libkpathsea5
  liblaunchpad-integration-3.0-1 liblaunchpad-integration-common liblcms1
  libllvm3.3 liblua5.1-0 liblwres80 libmeanwhile1 libmission-control-plugins0
  libmng1 libmpc2 libmpg123-0 libmusicbrainz3-6 libnice10 libnux-2.0-0
  libnux-2.0-common libopencv-calib3d2.4 libopencv-contrib2.4
  libopencv-core2.4 libopencv-features2d2.4 libopencv-flann2.4
  libopencv-highgui2.4 libopencv-imgproc2.4 libopencv-legacy2.4
  libopencv-ml2.4 libopencv-objdetect2.4 libopencv-video2.4 libopenexr6
  libopenspc0 libopenvg1-mesa-lts-trusty libpam-ck-connector libpocketsphinx1
  libpoppler19 libprotobuf7 libprotoc7 libprotoc8 libpth20 libpurple-bin
  libpurple0 libqt5core5a libqt5dbus5 libqt...

Read more...

Erick Brunzell (lbsolost) wrote :

And this:

lance@lance-desktop:~$ sudo apt-get dist-upgrade -s
[sudo] password for lance:
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 ubuntu-desktop : Depends: checkbox-gui but it is not installed
                  Depends: ubuntu-session but it is not installed
                  Depends: unity-control-center but it is not installed
                  Depends: unity-settings-daemon but it is not installed
                  Recommends: cheese but it is not installed
                  Recommends: empathy but it is not installed
                  Recommends: totem but it is not installed
                  Recommends: totem-mozilla but it is not installed
                  Recommends: unity-webapps-common but it is not installed
                  Recommends: xul-ext-unity but it is not installed
                  Recommends: xul-ext-webaccounts but it is not installed
E: Unmet dependencies. Try using -f.

Erick Brunzell (lbsolost) wrote :

This is the last thing I can think of:

lance@lance-desktop:~$ apt-cache policy ubuntu-desktop
ubuntu-desktop:
  Installed: 1.325
  Candidate: 1.325
  Version table:
 *** 1.325 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/main i386 Packages
        100 /var/lib/dpkg/status
lance@lance-desktop:~$ apt-cache policy ubuntu-session
ubuntu-session:
  Installed: (none)
  Candidate: 3.9.90-0ubuntu12
  Version table:
     3.9.90-0ubuntu12 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/main i386 Packages
lance@lance-desktop:~$ sudo apt-get install ubuntu-desktop -s
Reading package lists... Done
Building dependency tree
Reading state information... Done
ubuntu-desktop is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 ubuntu-desktop : Depends: checkbox-gui but it is not going to be installed
                  Depends: ubuntu-session but it is not going to be installed
                  Depends: unity-control-center but it is not going to be installed
                  Depends: unity-settings-daemon but it is not going to be installed
                  Recommends: cheese but it is not going to be installed
                  Recommends: empathy but it is not going to be installed
                  Recommends: totem but it is not going to be installed
                  Recommends: totem-mozilla but it is not going to be installed
                  Recommends: unity-webapps-common but it is not going to be installed
                  Recommends: xul-ext-unity but it is not going to be installed
                  Recommends: xul-ext-webaccounts but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Erick Brunzell (lbsolost) wrote :

I'm trying a Precise -> Trusty upgrade with a Precise still running the 3.2 series kernel and Precise X-stack just to see what happens and I still get that update manager crash so wanted to post these before they get hidden:

lance@lance-desktop:~$ ls /var/crash
_usr_bin_update-manager.1000.crash _usr_bin_update-manager.1000.uploaded
_usr_bin_update-manager.1000.upload

Erick Brunzell (lbsolost) wrote :

That's the only one of those three I can post.

Erick Brunzell (lbsolost) wrote :

OK this last upgrade worked, I'd started with a fully updated 12.04.1 so using the Precise kernel and X-stack. At the end I get the prompt to remove or keep obsolete packages, I chose to remove, then rebooted when prompted. It booted OK with some crash reports that I chose to file:

lance@lance-desktop:~$ ls /var/crash
_usr_lib_i386-linux-gnu_libgtk-3-0_gtk-update-icon-cache-3.0.0.crash
_usr_lib_i386-linux-gnu_libgtk-3-0_gtk-update-icon-cache-3.0.0.upload
_usr_lib_i386-linux-gnu_libgtk-3-0_gtk-update-icon-cache-3.0.0.uploaded
_usr_sbin_cupsd.0.crash
_usr_sbin_cupsd.0.upload
_usr_sbin_cupsd.0.uploaded

But they never did seem to actually file, maybe some apport tweak is needed?

No idea what will happen with Precise + the Quantal, Raring, or Saucy HWE, eg; 12.04.2, 12.04.3, or 12.04.4.

Too tired to do more ATM.

Thanks for your report. From the upgrade logs, this is what failed in the original upgrade:
Setting up yelp (3.10.2-0ubuntu1) ...
dpkg: dependency problems prevent configuration of ubuntu-desktop:
 ubuntu-desktop depends on checkbox-gui; however:
  Package checkbox-gui is not installed.
 ubuntu-desktop depends on ubuntu-session; however:
  Package ubuntu-session is not installed.
 ubuntu-desktop depends on unity-control-center; however:
  Package unity-control-center is not installed.
 ubuntu-desktop depends on unity-settings-daemon; however:
  Package unity-settings-daemon is not installed.

dpkg: error processing package ubuntu-desktop (--configure):
 dependency problems - leaving unconfigured

Changed in ubuntu-release-upgrader (Ubuntu):
importance: Undecided → High
status: New → Triaged

I'm about to begin a Precise w/Saucy HWE -> Trusty upgrade.

I'll follow up on those two post-upgrade crash reports I spoke of in comment #9 later as they're not nearly as critical.

summary: - Precise -> Trusty upgrade fails critically
+ Precise w/Trusty HWE -> Trusty upgrade fails critically
summary: - Precise w/Trusty HWE -> Trusty upgrade fails critically
+ Precise w/Trusty HWE -> Trusty release upgrade fails critically
summary: - Precise w/Trusty HWE -> Trusty release upgrade fails critically
+ Precise w/Trusty HWE -> Trusty release upgrade fails : ubuntu-desktop
+ fails to configure
Changed in ubuntu-release-upgrader (Ubuntu):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
importance: High → Critical
description: updated
Erick Brunzell (lbsolost) wrote :

Just happened to notice that I had not explicitly said this, so ............

This does only effect Precise -> Trusty upgrades where the Trusty HWE stack has been installed in Precise prior to the upgrade. I did test the upgrade process using a fully updated 12.04.1 install as well as 12.04.2 with the Quantal HWE, 12.04.3 with Raring HWE, and 12.04.4 with Saucy HWE - they were all successful even though bug #1348067 appeared early in the upgrade process.

Michael Vogt (mvo) wrote :

Thanks Erick, it seems like "libgbm1-lts-trusty" and "libglapi-mesa-lts-trusty" is the offenders here. It seems like this is a side-effect of #1318616

Michael Vogt (mvo) wrote :

As a workaround, if you enable precise-proposed, the upgrade works for me. The -lts-trusty transitional packages are available in trusty-proposed, just not yet in trusty-updates.

Michael Vogt (mvo) on 2014-07-28
Changed in ubuntu-release-upgrader (Ubuntu):
status: Triaged → In Progress
Michael Vogt (mvo) on 2014-07-29
Changed in ubuntu-release-upgrader (Ubuntu Trusty):
status: New → Triaged
importance: Undecided → High
milestone: none → ubuntu-14.04.2
Changed in ubuntu-release-upgrader (Ubuntu Utopic):
assignee: Canonical Foundations Team (canonical-foundations) → Michael Vogt (mvo)
Changed in ubuntu-release-upgrader (Ubuntu Trusty):
assignee: nobody → Michael Vogt (mvo)
Changed in ubuntu-release-upgrader (Ubuntu Utopic):
status: In Progress → Invalid
Changed in ubuntu-release-upgrader (Ubuntu Trusty):
status: Triaged → Fix Released
cx1964 (cx1964-y) wrote :

I want to add the following.
I think this problem is related.
On my Sony viao laptop model VPCF13Z1E with a Intel I7 processor with Ubuntu 12.04.4 amd64 software manager does not see
Ubuntu 14.04.

My machine has the following characteristics:

uname -a gives:
Linux SonyVaioF1 3.2.0-67-generic #101-Ubuntu SMP Tue Jul 15 17:46:11 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

lsb_release -a gives:
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.4 LTS
Release: 12.04
Codename: precise

I hope this info may solve the problem

uname -r gives:
3.2.0-67-generic

Erick Brunzell (lbsolost) wrote :

Could I please get someone to look at my new documentation bug #1351826 regarding the lack of upgrade notifications and the failure to mention so in the release notes. A lot of people are wondering why they're not yet able to upgrade from Precise.

no longer affects: ubuntu-release-upgrader (Ubuntu)
no longer affects: ubuntu-release-upgrader (Ubuntu Utopic)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers