cannot install steam using software-center

Bug #1416140 reported by Chris J Arges on 2015-01-29
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Undecided
Unassigned
Trusty
Critical
Unassigned

Bug Description

[Impact]
Users cannot install steam using the graphical Ubuntu Software Center.
Note the following works just fine:
sudo apt-get install steam

[ Test Case ]
1) Launch Ubuntu Software Center
2) Type 'steam'
3) Try to install it.

I've also attached screenshots that show the issues I had when trying to install it.
a) There are two Steam icons, and no buttons on the righthand side that ask me to install it
b) Clicking on the first result shows (Not found)
c) I can click on the second entry and click 'Buy...' then I am presented with this screen.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: software-center 13.10-0ubuntu4.1
ProcVersionSignature: Ubuntu 3.13.0-44.73-lowlatency 3.13.11-ckt12
Uname: Linux 3.13.0-44-lowlatency x86_64
ApportVersion: 2.14.1-0ubuntu3.6
Architecture: amd64
CurrentDesktop: Unity
Date: Thu Jan 29 16:19:21 2015
EcryptfsInUse: Yes
InstallationDate: Installed on 2014-07-18 (195 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
PackageArchitecture: all
SourcePackage: software-center
UpgradeStatus: No upgrade log present (probably fresh install)

Chris J Arges (arges) wrote :
Chris J Arges (arges) wrote :
Chris J Arges (arges) wrote :
Changed in software-center (Ubuntu):
importance: Critical → Undecided
Changed in software-center (Ubuntu Trusty):
importance: Undecided → Critical
Changed in software-center (Ubuntu):
status: New → Fix Released
status: Fix Released → New
summary: - cannot install steam on 14.04
+ cannot install steam using software-center
Chris J Arges (arges) wrote :

Using vivid shows other issues as well.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu Trusty):
status: New → Confirmed
Changed in software-center (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers