colord-sane assert failure: colord-sane: simple-watch.c:454: avahi_simple_poll_prepare: Assertion `s->state == STATE_INIT || s->state == STATE_DISPATCHED || s->state == STATE_FAILURE' failed.

Bug #1351286 reported by Fred
418
This bug affects 89 people
Affects Status Importance Assigned to Milestone
sane-backends (Ubuntu)
Medium
Unassigned
Trusty
Low
Unassigned
Xenial
Medium
Unassigned
Yakkety
Medium
Unassigned
Zesty
Medium
Unassigned

Bug Description

[Impact]
A bug in the SANE Kodak driver can cause a SANE device scan to crash the client that is using it (e.g. colord, simple-scan).

[Test Case]
1. Run a SANE client on a system that is failing Avahi scans (exact cause not determined).

Expected result:
Client works without crashing.

Observed result:
Client crashes.

[Regression Potential]
Code fix could cause a change in behaviour of successful Avahi scans for Kodak devices, though the fix matches the Avahi documentation for correct usage.

Revision history for this message
Fred (eldmannen+launchpad) wrote :
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 __assert_fail_base (fmt=0x7fcda3d688b0 "%s%s%s:%u: %s%sAssertion `%s' failed.\n%n", assertion=assertion@entry=0x7fcd926f9fb0 "s->state == STATE_INIT || s->state == STATE_DISPATCHED || s->state == STATE_FAILURE", file=file@entry=0x7fcd926f9ee8 "simple-watch.c", line=line@entry=454, function=function@entry=0x7fcd926fa140 "avahi_simple_poll_prepare") at assert.c:92
 __GI___assert_fail (assertion=0x7fcd926f9fb0 "s->state == STATE_INIT || s->state == STATE_DISPATCHED || s->state == STATE_FAILURE", file=0x7fcd926f9ee8 "simple-watch.c", line=454, function=0x7fcd926fa140 "avahi_simple_poll_prepare") at assert.c:101
 avahi_simple_poll_prepare () from /tmp/apport_sandbox_6pKceT/usr/lib/x86_64-linux-gnu/libavahi-common.so.3
 avahi_simple_poll_iterate () from /tmp/apport_sandbox_6pKceT/usr/lib/x86_64-linux-gnu/libavahi-common.so.3
 kodak_network_discovery (host=0x0) at kodakaio.c:2339

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : StacktraceSource.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in colord (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in colord (Ubuntu):
status: New → Confirmed
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

I got this after upgrade to vivid

information type: Private → Public
Revision history for this message
Singtoh (singtoh) wrote :

Fresh install a couple of days ago. This error appeared after a "cold boot" after the machine was off and after updates were installed. Nothing more to add.

Singtoh

Revision history for this message
Sebastien Bacher (seb128) wrote :

seems an issue with libsane-kodakaio.so.1

affects: colord (Ubuntu) → sane-backends (Ubuntu)
Revision history for this message
Lars Hallberg (lah) wrote :

Got this in 15.04. Also at times get the avahi disabled .local warning if they may be related.

Revision history for this message
sergeyfromminsk (shu-mail) wrote :

15.04 confirm

Revision history for this message
Paul (pinger) wrote :

15.04 confirm, only after first boot.

Revision history for this message
Jackson Doak (noskcaj) wrote :

Does this affect anyone on 15.10?

Revision history for this message
Terrem (terrem88) wrote :

yes, it does.

Revision history for this message
Adrian Guenter (adrianguenter) wrote :

@lah Same here.

Revision history for this message
pltxtra (pltxtra) wrote :

Is this ever going to be fixed? I'm on 15.04. Annoying to see this every time I log in.

Revision history for this message
Gumuiyul (gumuiyul) wrote :

I have same proglem in Ubuntu Gnome 15.04.

Revision history for this message
Ake Lerttriluck (akeonly) wrote :

I'm having the same problem, I'd be more than happy to help but I don't know where to start if anyone could point me to the right direction that would be great.

Thanks

Revision history for this message
Ville Ranki (ville-ranki) wrote :

Any sane developers following this? It's very annoying to see the crash notification on every boot.

Revision history for this message
PeterW (peter-waltman) wrote :

Ditto on Ville Ranki's question. Not an Earth-shattering problem, but annoying nonetheless.

tags: added: wily
Revision history for this message
demicat (mark-demicat) wrote :

After update today sep 27 2015 I start to have the same problem, I have this problem on 3 ubuntu version from 2011. May be somebody try to remove this useless program from default installation? please! please!, 4 years you cant fix it, may be simple remove it and stop this hard sex with colord sane ) Thx developers this program! may be this gays start to working on ms windows? - linux is not right OS for this gays )

Revision history for this message
demicat (mark-demicat) wrote :

15.04 steel active bug!

Revision history for this message
CRAFT (craft37) wrote :

15.10 latest daily.
still bores me every time computers starts, ouch!
pls fix it somehow, cause I can deal only with html

Revision history for this message
chm0ntf (nickform) wrote :

I've had this for what seems like ages now. The apport dialog has an "Ignore future problems of this type" which works but is apparently reset by system updates, which is pretty frequently. :-(

Revision history for this message
Ilya Kharin (akscram) wrote :

15.04 on every boot appears.

Revision history for this message
Ari Torhamo (ari-torhamo) wrote :

I have experienced this bug as long as I can remember, years anyway. My hardware has changed completely during that time, but the bug stays :-)

I haven't let send the automatic bug report often, because I have thought that sending too many of them annoys the developers. Would it be better to send them all, or perhaps one every week or couple so that the developers know that the bug still exists ?

I'm using 15.10 now, and currently the crash happens at every boot.

Revision history for this message
Yuriy (priymayuriy) wrote :

The same bug on Ubuntu 15.10
I send data about this bug
I think It could be because of the f.lux. It not works on Ubuntu 15.10 and i changed code to force it work
f.lux make screen not so bright
maybe it could help u guys

Revision history for this message
Jos Flachs (jos-4) wrote :

After upgrading to 15.10 I get this error every day when I start up.

Revision history for this message
Taras Perebeynosov (taras-perebeynosov) wrote :

I don't really use scanner, so I decided to simply remove buggy packages:

sudo apt-get remove sane-utils
sudo apt-get remove colord

Revision history for this message
peterK (peter-kanderholm) wrote :

Thank you Taras for the instructions! Finally got rid of this crash after 1 year.

In Ubutnu Software center I remove the installed "Simple Scan" application
then removed the packages

 sudo apt-get remove sane-utils
 sudo apt-get remove colord
 sudo apt-get autoremove

Problem gone, finally no crashes any more!

Revision history for this message
Anton Johansson (anton-johansson) wrote :

Had the same problem, and decided to go with Taras suggestion. Works like a charm, no more crashes. Thanks!

Revision history for this message
Anton Eliasson (eliasson) wrote :

Still happens on Ubuntu 16.04.

tags: added: xenial
Revision history for this message
Jan D. (chakko007) wrote :

Same issue here on Ubuntu 15.10 64-bit, and also the Avahi disabled .local warning mentioned in reply #10. Hope this gets resolved soon...

Revision history for this message
postadelmaga (postadelmaga) wrote :

As share above, on Ubuntu 15.10 I got the crash every day, that is very annoying

Revision history for this message
SilSie (silsie) wrote :

The bug is still present on 16.04 beta build 1.

Revision history for this message
Gumuiyul (gumuiyul) wrote :

Same bug on 16.04 daily build 20160406.
Log file attached in /var/crash/

Revision history for this message
ssr (seremin) wrote :

Got it on 16.04 LTS final release as well.
Followed earlier instructions to remove colord, so it is really does not bother me, but might spoil the impression of newcomers

Revision history for this message
Sergey Ostapov (sergey-ostapov) wrote :

I have this bug on final version 16.04 LTS (i386) after cold restart every time!

Revision history for this message
Sarraceno (jfhtomas) wrote :

I have a fresh install for Ubuntu 16.04, updated, and same issue.

After read the peterK (peter-kanderholm) post wrote on 2016-01-08, I couldn't accept it, I do use regular basis a scanner...

Then per the bug reported I did remember the "Color" and "Color Profile Viewer", entered there and almost immediately was recommended to install Gnome Color Manager, accepted.

Then twice reboot no bug, no more crashes.

I do remember this come after I did plug a second monitor to my laptop, could this be a coincidence?

Regards!

Revision history for this message
Anton Eliasson (eliasson) wrote :

I tried installing Gnome Color Manager as well, and while colord no longer seems to crash on every boot, it still sometimes crashes after waking from suspend on the same failed assertion.

Revision history for this message
Maxwell Young (yangzmaxwell) wrote :

I have this bug on final version 16.04 LTS (x64) after every starting !
It occured after upgrading to 16.04 from 15.10. Please give a solution ! Too annoy !!

Revision history for this message
Janne Uusitalo (janne-uusitalo-gmail) wrote :

Yep, installing gnome-color-manager helps. Thanks, Sarraceno!

Revision history for this message
Sergey Saraev (sergey-saraev) wrote :

I installed gnome-color-manager. It does not work completely. Error appears periodically on Ubuntu 16.04.1 LTS.

Revision history for this message
Bulat (venima) wrote :

Ubuntu 16.04.1 LTS: colord-sane always crashes. Installed gnome-color-manager today. Let's see what happens next...

Revision history for this message
Bulat (venima) wrote :

Problem stays unsolved.

Revision history for this message
Yan Filippovsky (vater) wrote :

The problem has disappeared after I have plugged back my scanner (Mustek BearPaw 1200 TA)

tags: added: yakkety
Rolf Leggewie (r0lf)
tags: added: vivid
Revision history for this message
Mike Krall (mkrall-wyo) wrote :

End March install 16.04.2. First boot... not all boots... few reboots.

Revision history for this message
Eldar Khayrullin (eldar) wrote :

Ubuntu 16.10 has the same bug

Changed in sane-backends (Ubuntu):
status: Confirmed → Triaged
Changed in sane-backends (Ubuntu Yakkety):
status: New → Triaged
Changed in sane-backends (Ubuntu Xenial):
status: New → Triaged
Changed in sane-backends (Ubuntu Trusty):
status: New → Triaged
importance: Undecided → Low
Changed in sane-backends (Ubuntu Xenial):
importance: Undecided → Medium
Changed in sane-backends (Ubuntu Yakkety):
importance: Undecided → Medium
description: updated
Changed in sane-backends (Ubuntu Xenial):
status: Triaged → Fix Committed
Changed in sane-backends (Ubuntu Yakkety):
status: Triaged → Fix Committed
Changed in sane-backends (Ubuntu Zesty):
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sane-backends - 1.0.25+git20150528-1ubuntu4

---------------
sane-backends (1.0.25+git20150528-1ubuntu4) zesty; urgency=medium

  * debian/patches/kodak_avahi_crash.patch:
    - Fix crash when Avahi fails scanning for Kodak scanners (LP: #1351286)

 -- Robert Ancell <email address hidden> Tue, 04 Apr 2017 11:56:59 +1200

Changed in sane-backends (Ubuntu Zesty):
status: Fix Committed → Fix Released
Revision history for this message
Brian Murray (brian-murray) wrote :
tags: added: verification-needed
Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello Fred, or anyone else affected,

Accepted sane-backends into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/sane-backends/1.0.25+git20150528-1ubuntu2.16.10.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Revision history for this message
Brian Murray (brian-murray) wrote :

Hello Fred, or anyone else affected,

Accepted sane-backends into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/sane-backends/1.0.25+git20150528-1ubuntu2.16.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Revision history for this message
Robert Ancell (robert-ancell) wrote :

Crash reports on errors.ubuntu.com:
https://errors.ubuntu.com/problem/8b9ed48be6c32a738c54fc1fc36cccf2058be60b

I couldn't find any reports with crashes using the updated libsane, but this was just a random selection. I don't know of a method to get all these reports easily and check the libsane dependency?

The small number of 17.04 reports gives me hope this is really fixed...

Revision history for this message
Łukasz Zemczak (sil2100) wrote : Change of SRU verification policy

As part of a recent change in the Stable Release Update verification policy we would like to inform that for a bug to be considered verified for a given release a verification-done-$RELEASE tag needs to be added to the bug where $RELEASE is the name of the series the package that was tested (e.g. verification-done-xenial). Please note that the global 'verification-done' tag can no longer be used for this purpose.

Thank you!

Revision history for this message
Amr Ibrahim (amribrahim1987) wrote :

Please verify for Xenial.

fubbleskag (fubbleskag)
tags: added: verification-done-xenial
Revision history for this message
Chanakan Mungtin (chanakan6771) wrote :

I have this Problem on ubuntu 16.04 after i am update my ubuntu.

Revision history for this message
Łukasz Zemczak (sil2100) wrote :

I see someone marked this bug as verified but did not provide any testing summary. Remember that it is required to put at least an overview of what tests have been performed and on which package versions for the SRU team to consider a bug as verified.

Could you please provide the necessary information? We cannot release it otherwise. Thank you.

tags: added: verification-needed-xenial
removed: verification-done-xenial
Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote : [sane-backends/xenial] verification still needed

The fix for this bug has been awaiting testing feedback in the -proposed repository for xenial for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now, the package will be removed from the -proposed repository.

tags: added: removal-candidate
Revision history for this message
Ivan Frederiks (idfred) wrote :

This bug seems to be fixed in Xenial proposed package. My system reported about saned crashes (caused by assertion failure described in this bug) on every boot. Then I installed updated package and I do not observe any sane related crashes anymore.

Revision history for this message
Łukasz Zemczak (sil2100) wrote : Proposed package removed from archive

The version of sane-backends in the proposed pocket of Xenial that was purported to fix this bug report has been removed because the bugs that were to be fixed by the upload were not verified in a timely (105 days) fashion.

tags: removed: verification-needed-xenial
Changed in sane-backends (Ubuntu Xenial):
status: Fix Committed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers