pulseaudio crashed with SIGABRT in pa_xmalloc()

Bug #1298842 reported by Jonas G. Drange
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
High
Unassigned
Trusty
Medium
Unassigned

Bug Description

1. Powered up laptop from a powered off state
2. Logged in
3. Was presented with "A system error has occurred"
4. Later notice that "No PulseAudio daemon running, or not running as session daemon."

I cannot control the volume, since no pulseaudio daemon is running
$ pacmd does not work due to 4

Trying to start pulseaudio gives me

$ pulseaudio
E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: pa_pid_file_create() failed.

Trying to kill it yields

$ pulseaudio -k
E: [pulseaudio] main.c: Failed to kill daemon: No such file or directory

"I have no idea what I am doing":

$ sudo pulseaudio -k
[sudo] password for jonas:
E: [pulseaudio] core-util.c: Home directory not accessible: Permission denied
E: [pulseaudio] main.c: Failed to kill daemon: Success

jonas@jonas-xps:~$ pulseaudio -k
E: [pulseaudio] main.c: Failed to kill daemon: No such file or directory

jonas@jonas-xps:~$ pulseaudio
W: [pulseaudio] pid.c: Stale PID file, overwriting.
E: [pulseaudio] module-device-restore.c: Failed to parse module arguments
E: [pulseaudio] module.c: Failed to load module "module-device-restore" (argument: "restore_device=false"): initialization failed.
E: [pulseaudio] main.c: Module load failed.
E: [pulseaudio] main.c: Failed to initialize daemon.
E: [pulseaudio] xmalloc.c: Assertion 'size > 0' failed at pulse/xmalloc.c:62, function pa_xmalloc(). Aborting.
Aborted (core dumped)

Happens due to
load-module module-device-restore restore_device=false

ProblemType: Crash
DistroRelease: Ubuntu 14.04
Package: pulseaudio 1:4.0-0ubuntu10
ProcVersionSignature: Ubuntu 3.13.0-19.40-generic 3.13.6
Uname: Linux 3.13.0-19-generic x86_64
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/by-path', '/dev/snd/controlC0', '/dev/snd/hwC0D0', '/dev/snd/hwC0D3', '/dev/snd/pcmC0D0c', '/dev/snd/pcmC0D0p', '/dev/snd/pcmC0D3p', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
CrashCounter: 1
CurrentDesktop: Unity
Date: Fri Mar 28 09:17:13 2014
DistributionChannelDescriptor:
 # This is a distribution channel descriptor
 # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
 canonical-oem-somerville-precise-amd64-20120703-2
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/pulseaudio
InstallationDate: Installed on 2013-08-27 (212 days ago)
InstallationMedia: Ubuntu 12.04 "Precise" - Build amd64 LIVE Binary 20120703-15:08
ProcCmdline: /usr/bin/pulseaudio --start --log-target=syslog
PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No PulseAudio daemon running, or not running as session daemon.
Signal: 6
SourcePackage: pulseaudio
StacktraceTop:
 pa_xmalloc () from /usr/lib/x86_64-linux-gnu/pulseaudio/libpulsecommon-4.0.so
 pa_module_unload_all () from /usr/lib/libpulsecore-4.0.so
 main ()
Title: pulseaudio crashed with SIGABRT in pa_xmalloc()
UpgradeStatus: Upgraded to trusty on 2014-03-20 (7 days ago)
UserGroups: adm cdrom dip libvirtd lp lpadmin plugdev sambashare sudo
dmi.bios.date: 05/15/2013
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A09
dmi.board.name: 0PJHXN
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnDellInc.:bvrA09:bd05/15/2013:svnDellInc.:pnDellSystemXPSL322X:pvr:rvnDellInc.:rn0PJHXN:rvrA00:cvnDellInc.:ct8:cvr0.1:
dmi.product.name: Dell System XPS L322X
dmi.sys.vendor: Dell Inc.
modified.conffile..etc.pulse.default.pa: [modified]
mtime.conffile..etc.pulse.default.pa: 2014-03-27T13:17:10.652148

Revision history for this message
Jonas G. Drange (jonas-drange) wrote :
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 pa_xmalloc (size=<optimized out>) at pulse/xmalloc.c:62
 _pa_xnew_internal (k=4, n=<optimized out>) at ./pulse/xmalloc.h:66
 pa_module_unload_all (c=c@entry=0x2240160) at pulsecore/module.c:221
 main (argc=<optimized out>, argv=<optimized out>) at daemon/main.c:1183

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : StacktraceSource.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in pulseaudio (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
description: updated
Changed in pulseaudio (Ubuntu):
importance: Medium → Undecided
status: New → Incomplete
description: updated
Revision history for this message
David Henningsson (diwic) wrote :

Crash is fixed upstream:

commit ada83601f04f73177ea5f8bda01f02a38ba55409
Author: Tanu Kaskinen <email address hidden>
Date: Thu Jul 11 13:35:24 2013 +0300

    module: Fix crash in pa_module_unload_all()

If this bug hits many people, we should consider cherrypicking it and make an SRU for PulseAudio.

Changed in pulseaudio (Ubuntu):
status: Incomplete → Fix Committed
information type: Private → Public
Changed in pulseaudio (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pulseaudio (Ubuntu Trusty):
status: New → Confirmed
Revision history for this message
Robert Tari (robert-tari) wrote :

Confirmed.

I started getting the very same crash from the first day I installed 15.10. It occurs 4-5 times a day - from what I can tell triggered by any application using gstreamer for audio playback.

Let me know if you need any additional info.

Changed in pulseaudio (Ubuntu Trusty):
importance: Undecided → Medium
Changed in pulseaudio (Ubuntu):
importance: Undecided → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers