nova should provide a nova-compute-minimal (or similar)package

Bug #1207930 reported by Adam Gandelman on 2013-08-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nova (Ubuntu)
Undecided
Unassigned
Trusty
Wishlist
Unassigned

Bug Description

Currently, most/all nova-compute-* packages are tied to a specific hypervisor, usually associated with libvirt. As a result, you cannot install a bare minim nova-compute service that does not pull in a ton of dependencies. If a user wishes to run nova-compute using one of the drivers that directly offloads compute tasks to an external resource (VMware, oVirt, etc), they'll install 'nova-compute' (and libvirt-bin, qemu-kvm, etc.) I propose it would make sense to include a package (nova-compute-minimal?) that depends on nova-common + python-nova and installs only the minimum, eg: an upstart job and an empty /etc/nova/nova-compute.conf.

James Page (james-page) on 2013-10-17
Changed in nova (Ubuntu):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers