libosmesa6 conflicts with libglapi-mesa-lts-*

Bug #1424059 reported by Doug McMahon on 2015-02-20
168
This bug affects 33 people
Affects Status Importance Assigned to Milestone
mesa (Ubuntu)
Trusty
High
Timo Aaltonen

Bug Description

[Impact]

libosmesa6 10.1.3-0ubuntu0.3 amd64 can't be installed because it depends on libglapi-mesa (= 10.1.3-0ubuntu0.3), but libglapi-mesa-lts-utopic 10.3.2-0ubuntu1~trusty2 amd64 is '10.3.2-0ubuntu1' not '10.1.3-0ubuntu0.3'.

A possible solution is to include Utopic's libosmesa(-dev) in the LTS enablement stack so versions match.

[Test Case]

>sudo aptitude install libosmesa6
The following NEW packages will be installed:
  libglapi-mesa{a} libosmesa6
0 packages upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,009 kB of archives. After unpacking 3,682 kB will be used.
The following packages have unmet dependencies:
 xserver-xorg-lts-utopic : Conflicts: libglapi-mesa (>= 0~) but 10.1.3-0ubuntu0.3 is to be installed.
 libglapi-mesa-lts-utopic : Conflicts: libglapi-mesa but 10.1.3-0ubuntu0.3 is to be installed.

Also check that reverse dependencies install and continue to work such as libosmesa6-dev, desmume, crossover, and wine.

[Other Info]

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: libglapi-mesa-lts-utopic 10.3.2-0ubuntu1~trusty2
ProcVersionSignature: Ubuntu 3.16.0-31.41~14.04.1-generic 3.16.7-ckt5
Uname: Linux 3.16.0-31-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.7
Architecture: amd64
CurrentDesktop: Unity
Date: Fri Feb 20 15:45:52 2015
Dependencies:
 gcc-4.9-base 4.9.1-0ubuntu1
 libc6 2.19-0ubuntu6.5
 libgcc1 1:4.9.1-0ubuntu1
 multiarch-support 2.19-0ubuntu6.5
InstallationDate: Installed on 2015-02-08 (12 days ago)
InstallationMedia: Ubuntu 14.04.2 LTS "Trusty Tahr" - Release amd64 (20150203.2)
SourcePackage: mesa-lts-utopic
UpgradeStatus: No upgrade log present (probably fresh install)

Doug McMahon (mc3man) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mesa-lts-utopic (Ubuntu):
status: New → Confirmed

After enabling the Hardware Enablement Stack for Trusty shipped with 14.04.2, I am experiencing the same issue, when trying to install build dependencies for various packages, f.e. vtk using "sudo apt-get build-dep vtk"

Doug McMahon (mc3man) wrote :

Nobody you wants the full range of devel packages should go anywhere near 14.04.2 or install the lts-utopic mesa packages on a 14.04 or 14.04.1 install
It's just a decent case of fubar
(- another example - freeglut3-dev

Tholl1989 (mariajcore) wrote :

libosmesa6/trusty-updates 10.1.3-0ubuntu0.3 amd64 can't be installed because it depends on libglapi-mesa (= 10.1.3-0ubuntu0.3), but libglapi-mesa-lts-utopic/trusty-updates,trusty-security 10.3.2-0ubuntu1~trusty2 amd64 is 10.3.2-0ubuntu1 not 10.1.3-0ubuntu0.3.

So utopic's libosmesa6 needs to be backported to match the new libglapi-mesa.

Tholl1989 (mariajcore) on 2015-03-07
summary: - Failure to build osmesa will prevent some apps from being installed
+ libosmesa6 conflicts with libglapi-mesa-lts-utopic
description: updated
Tholl1989 (mariajcore) on 2015-03-07
tags: added: regression-release
tags: added: upgrade-software-version
Tholl1989 (mariajcore) on 2015-03-07
description: updated
description: updated

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mesa (Ubuntu):
status: New → Confirmed
Leon (leonbo) wrote :

Anyone know of a workaround for this?

Doug McMahon (mc3man) wrote :

"Anyone know of a workaround for this?"
Do a fresh install using the 14.04.1 image from Ubuntu old-releases.
If needing for some reason a newer mesa then use a ppa like xorg-edgers fresh X crack or oibaf

I just run into this bug. It also is present with vivid version of LTS enablement stack.

Timo Aaltonen (tjaalton) wrote :

uploaded a new mesa-lts-vivid to

https://launchpad.net/~canonical-x/+archive/ubuntu/x-staging

seems to work for me, please confirm

Changed in mesa-lts-vivid (Ubuntu):
status: New → Incomplete

I can confirm that the mesa-lts-vivid Timo uploaded to his PPA (10.5.9-2ubuntu1~trusty3~ppa1) includes the corresponding vivid's libosmesa(-dev) packages. I can now install the dependencies needed to build f. e. vtk without any problems (see answer #3). Great to see that this annoying bug is solved!

Timo Aaltonen (tjaalton) wrote :

a bit of background: libosmesa in precise didn't depend on libglapi-mesa which meant it wasn't necessary to provide a renamed one for precise lts stacks..

Changed in mesa (Ubuntu):
status: Confirmed → Invalid
Timo Aaltonen (tjaalton) wrote :

uploaded mesa-lts-vivid for trusty-proposed

Hello Doug, or anyone else affected,

Accepted mesa-lts-vivid into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mesa-lts-vivid/10.5.9-2ubuntu1~trusty3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed

I enabled trusty-proposed and gave the uploaded mesa-lts-vivid (10.5.9-2ubuntu1~trusty3) a try. I can confirm that the corresponding vivid's libosmesa(-dev) packages are now included and that I am able to install the dependencies needed to build f. e. vtk without any problems (see answers #3 and #11). Great to see that this annoying bug is solved!

tags: added: verification-done
removed: verification-needed
Timo Aaltonen (tjaalton) wrote :

I'm not sure this is the right way to fix it, since it wouldn't allow packages that depend on libosmesa6 to be installed, because versioned Provides is not supported there... that would need fixing the stock mesa to build libosmesa statically so that it wouldn't depend on libglapi-mesa.

Timo Aaltonen (tjaalton) on 2015-09-17
tags: removed: verification-done
Changed in mesa (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
status: Invalid → In Progress
Timo Aaltonen (tjaalton) on 2015-09-17
Changed in mesa-lts-utopic (Ubuntu):
status: Confirmed → Invalid
Changed in mesa-lts-vivid (Ubuntu):
status: Incomplete → Invalid
no longer affects: mesa-lts-utopic (Ubuntu Trusty)
no longer affects: mesa-lts-vivid (Ubuntu Trusty)
no longer affects: mesa-lts-utopic (Ubuntu)
no longer affects: mesa-lts-vivid (Ubuntu)
Changed in mesa (Ubuntu Trusty):
assignee: nobody → Timo Aaltonen (tjaalton)
importance: Undecided → High
status: New → In Progress
Changed in mesa (Ubuntu):
assignee: Timo Aaltonen (tjaalton) → nobody
status: In Progress → Invalid
summary: - libosmesa6 conflicts with libglapi-mesa-lts-utopic
+ libosmesa6 conflicts with libglapi-mesa-lts-*

Hello Doug, or anyone else affected,

Accepted mesa into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mesa/10.1.3-0ubuntu0.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mesa (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Doug McMahon (mc3man) wrote :

Installed fine in 14.04.3 (using hwe vivid stack), both the lib & -dev packages
Also allowed desmume to install & open

tags: added: verification-done
removed: verification-needed
description: updated
tags: removed: regression-release upgrade-software-version
no longer affects: mesa (Ubuntu)
Leon (leonbo) wrote :

Upgraded to Vivid HWE and enabling the proposed repository fixed the issue for me.

Doug McMahon (mc3man) wrote :

What are you all doing here??, twice released to trusty-proposed under same name? & then after 2nd verification deleted

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 10.1.3-0ubuntu0.5

---------------
mesa (10.1.3-0ubuntu0.5) trusty; urgency=medium

  * Build osmesa separately and without using shared glapi again.
    (LP: #1424059)

 -- Timo Aaltonen <email address hidden> Thu, 17 Sep 2015 11:35:21 +0300

Changed in mesa (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for mesa has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments