[SRU] Please backport menulibre-2.0.4 to trusty

Bug #1323405 reported by Sean Davis on 2014-05-26
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
menulibre (Ubuntu)
Undecided
Unassigned
Trusty
High
Unassigned

Bug Description

[Impact]
The following bugs are fixed with MenuLibre 2.0.4. The first three are critical to reliability since they make alacarte and menulibre no longer usable and may leave the user with a broken menu structure. The remaining fixes improve overall usability of the application.
- Fixed preprocess_layout_info segfault (LP: #1307729) (verification-done)
- Fixed corruption of xfce-applications.menu (LP: #1313276) (verification-done)
- Fixed menu corruption when saving after search (LP: #1306999) (verification-done)
- Allow moving launchers into empty categories (LP: #1318209) (verification-done)
- Install menulibre icon to pixmaps (LP: #1307469) (verification-done)
- Update launcher categories on move (LP: #1313586) (verification-done)
- Fixed deleted launchers being replaced by others (LP: #1315890) (verification-done)
- Uninstall launchers from custom categories (LP: #1318235) (verification-done)
- Escape spaces in Exec after browsing (LP: #1214815) (verification-done)
- Restore previous view after search (LP: #1307000) (verification-done)
- Enable X-Xfce-Toplevel category in Xfce (LP: #1309468) (verification-done)
- Do not add X-Xfce-Toplevel to new directories (LP: #1315874) (verification-done)
- Allow saving when entries are modified (LP: #1315878) (verification-done)
- Add xdg-utils to depends, hard dependency (LP: #1307481) (verification-done)

[Test Case]
This bug appears after multiple launchers have been moved using menulibre. The edits must be made in unique menulibre instances (close and open menulibre). The issue arises as a result of unique directories being written to the menu file twice. Once this happens, menulibre and alacarte are no longer usable.

[Regression Potential]
The risk for regression is exceptionally low. The bugs fixed in this release were tested and verified by multiple affected users.

[Other Info]
Unfortunately, there is no way to reverse the damage done by version 2.0.3 (outside of editing the menu file by hand and removing duplicate entries). Affected users will have to remove their xfce-/gnome-applications.menu and start fresh.

Sean Davis (bluesabre) on 2014-05-26
Changed in menulibre (Ubuntu):
assignee: nobody → Sean Davis (smd-seandavis)
description: updated
Sean Davis (bluesabre) wrote :

Attached backport debdiff from utopic to trusty.

Changed in menulibre (Ubuntu):
assignee: Sean Davis (smd-seandavis) → nobody
Logan Rosen (logan) on 2014-05-27
Changed in menulibre (Ubuntu):
status: New → Fix Released
Sean Davis (bluesabre) wrote :

Has this been uploaded to trusty-proposed?

Pasi Lallinaho (knome) on 2014-07-06
Changed in menulibre (Ubuntu Trusty):
importance: Undecided → High
Micah Gersten (micahg) wrote :

Uploaded to trusty-proposed

Changed in menulibre (Ubuntu Trusty):
status: New → Fix Committed
Sean Davis (bluesabre) on 2014-07-12
tags: added: verification-needed
Logan Rosen (logan) wrote :

Sean, the SRU team adds the verification-needed tag to the bug once the package is in RELEASE-proposed. Then you (or someone else) verify that the change has been made properly and change the tag to verification-done. :)

tags: removed: verification-needed

Hello Sean, or anyone else affected,

Accepted menulibre into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/menulibre/2.0.4-1~ubuntu14.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Jack Fromm (jjfrv8) wrote :

Did a fresh install of Trusty on hardware.
Ran Menulibre testcase from Xubuntu Testsuite A to see if it would reproduce bug 1321061 on 2.03. It did.
Enabled -proposed and updated. Confirmed version 2.04.
Ran testcase again.
It not only created a new launcher instead of just moving existing one, it crashed the app.
Screenshot and crash report attached.

Jack Fromm (jjfrv8) wrote :
Jack Fromm (jjfrv8) wrote :

Bug 1313586 does not appear to be resolved. When you move a launcher into another directory, the Save icon is not activated. You have to change some other setting in the Entry Editor to force it to activate.

Sean Davis (bluesabre) wrote :

@jjfrv8

Nice find, looks like that's a new bug with moving a new, unsaved launcher.

Jack Fromm (jjfrv8) wrote :

At the suggestion of Sean, I tried the bug 1321061 scenario again but gave the New Launcher a name and saved it before moving. That prevents the problem. You can then move the launcher into and out of expanded directories.

Sean Davis (bluesabre) on 2014-07-22
description: updated
Sean Davis (bluesabre) wrote :

@jjfrv8,

For bug 1313586, as indicated in the bug report, the category changes take place immediately, and do not require that the launcher is saved afterwards. This can be verified from the applications menu.

Sean Davis (bluesabre) on 2014-07-22
description: updated
Sean Davis (bluesabre) on 2014-07-23
description: updated
Sean Davis (bluesabre) on 2014-07-23
description: updated
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package menulibre - 2.0.4-1~ubuntu14.04.1

---------------
menulibre (2.0.4-1~ubuntu14.04.1) trusty; urgency=medium

  * No-change backport to trusty (LP: #1323405)

menulibre (2.0.4-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
    - Fixed preprocess_layout_info segfault (LP: #1307729)
    - Fixed corruption of xfce-applications.menu (LP: #1313276)
    - Fixed menu corruption when saving after search (LP: 1306999)
    - Allow moving launchers into empty categories (LP: #1318209)
    - Install menulibre icon to pixmaps (LP: #1307469)
    - Update launcher categories on move (LP: #1313586)
    - Fixed deleted launchers being replaced by others (LP: #1315890)
    - Uninstall launchers from custom categories (LP: #1318235)
    - Escape spaces in Exec after browsing (LP: #1214815)
    - Restore previous view after search (LP: #1307000)
    - Enable X-Xfce-Toplevel category in Xfce (LP: #1309468)
    - Do not add X-Xfce-Toplevel to new directories (LP: #1315874)
    - Allow saving when entries are modified (LP: #1315878)
  * debian/control
    - Add xdg-utils to depends, hard dependency (LP: #1307481)
 -- Sean Davis <email address hidden> Thu, 10 Jul 2014 00:03:52 -0500

Changed in menulibre (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for menulibre has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers