Add the ubuntu-cpc project to trusty

Bug #1693018 reported by Robert C Jennings on 2017-05-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
live-build (Ubuntu)
Trusty
Undecided
Unassigned
livecd-rootfs (Ubuntu)
Trusty
Undecided
Unassigned

Bug Description

[Impact]

 * ubuntu-cpc project is not present in livecd-rootfs for trusty

[Test Case]

 * attempt to build the ubuntu-cpc project without errors
 * build existing projects and check for errors

[Regression Potential]

 * Limited; The majority of the code is limited to the ubuntu-cpc project.
 * Limited; the majority of cloud image usage does invoke cloud-init, which already writes out a source.list that matches the server ISO. This change aligns non-cloud-init usage to the existing norm. (LP: #1513529)

[Other Info]

 * I cherry-picked commits back to trusty and included raspi2 support to keep commonality and make 3-way diff easier based on conversations with slangasek and inifinity. Then I re-wrote the changelog to put all the changelog messages in a single entry.
 * I'm not certain my method for re-writing the changelog (if you're following commit-by-commit) was the best but I think the cumulative result is okay, but if not please tell me.
 * This does not necessarily get us to the point of having images equivalent to the content @ cloud-images.ubuntu.com for Trusty. We will iterate on that separately once we have the ability to run from livecd-rootfs in the archive.

[Original Description]

The ubuntu-cpc project is not available in trusty. We would like to SRU it back for cloud image builds.

Related branches

Robert C Jennings (rcj) on 2017-05-26
description: updated
Robert C Jennings (rcj) on 2017-05-26
description: updated
Robert C Jennings (rcj) wrote :

Attaching the debdiff for live-build

Adam Conrad (adconrad) on 2017-05-26
Changed in live-build (Ubuntu):
status: New → Invalid
Changed in livecd-rootfs (Ubuntu):
status: In Progress → Invalid
Robert C Jennings (rcj) on 2017-05-26
Changed in livecd-rootfs (Ubuntu):
assignee: Robert C Jennings (rcj) → nobody
Robert C Jennings (rcj) on 2017-06-01
Changed in livecd-rootfs (Ubuntu Trusty):
milestone: none → trusty-updates
Changed in live-build (Ubuntu Trusty):
milestone: none → trusty-updates
Robert C Jennings (rcj) wrote :

Attaching updated debdiff for live-build coalescing changes into a single version.

Łukasz Zemczak (sil2100) wrote :

The changelog merge seems okayish to me - was a bit confusing at first but I don't know of any particular standard of how this should look like, I never saw an operation like that being performed. But it looks clear enough for me and having the changelogs actually was helpful.

What I would like to happen here is this package being tested for non cpc builds as well, as I see that along with the ubuntu-cpc cherry-pick some changes from the upstream are included in auto/build (the way the chroot sources.list gets generated, removal of some deb-src etc.). If this gets all the proper testing, I'm all good to get this moving. But for now - approving.

Changed in livecd-rootfs (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed

Hello Robert, or anyone else affected,

Accepted livecd-rootfs into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.208.14 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Robert C Jennings (rcj) wrote :

Łukasz, we'll need live-build_3.0~a57-1ubuntu11.4 approved before we can test livecd-rootfs. Can you approve that package? Thanks

Brian Murray (brian-murray) wrote :

Hello Robert, or anyone else affected,

Accepted live-build into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/live-build/3.0~a57-1ubuntu11.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in live-build (Ubuntu Trusty):
status: New → Fix Committed

As part of a recent change in the Stable Release Update verification policy we would like to inform that for a bug to be considered verified for a given release a verification-done-$RELEASE tag needs to be added to the bug where $RELEASE is the name of the series the package that was tested (e.g. verification-done-xenial). Please note that the global 'verification-done' tag can no longer be used for this purpose.

Thank you!

Robert C Jennings (rcj) wrote :

Builds with the proposed packages were successful. I am marking this a verification-done-trusty.

tags: added: verification-done-trusty
removed: verification-needed
Launchpad Janitor (janitor) wrote :
Download full text (5.9 KiB)

This bug was fixed in the package livecd-rootfs - 2.208.14

---------------
livecd-rootfs (2.208.14) trusty; urgency=medium

  [ Robert C. Jennings ]
  * Add ubuntu-cpc project (LP: #1693018)

    [ Daniel Watkins ]
    * Move building of all architecture-specific CPC artifacts into Launchpad
      - Fixup virtual FLAVOUR kernel name

    [ Oliver Grawert ]
    * added additional CPC build targets:
      - added manifest generation for squashfs and root.tar.gz
      - added VMDK generation
      - added OVA generation from VMDK's
      - added generic Vagrant image generation

    [ Ben Howard ]
    * Fix typo in ubuntu-cpc preventing non-intel builds.
    * add devpts-live to hook builds
    * add logic to settle the disks after UEFI builds
    * extended hooks/functions to support creation of derivative images
    * including mounting images.
    * added the ability to create qcow2 images in hooks/functions
    * simplified loop clean-up in hooks/functions
    * removed assumption that disk1.img would be built
    * switched qcow2 generation to use hooks/functions function

    [ Daniel Watkins ]
    * Produce OVA files for i386 cloud builds.

    [ Ben Howard ]
    * Remove unneeded packages from the root.tar.{gz,xz} cloud image targets

    [ Daniel Watkins ]
    * Install grub in ppc64el cloud images so they are bootable

    [ Daniel Watkins ]
    * Set timeout options so ppc64el cloud images don't display a grub boot
      menu (matching the behaviour of other cloud images).
    * Specify a regex to run-parts so that cloud image extra scripts are found
      and executed.

    [ Steve Langasek ]
    * Refactor/reorder ubuntu-cpc support for consistency with other flavors,
      so that subarch overrides can be applied correctly.

    [ Ben Howard ]
    * fixed loop setup due to change of kpartx output
    * only use grub-install logic for Intel architectures

    [ Steve Langasek ]
    * Refactor some non-idiomatic architecture handling in
      live-build/ubuntu-cpc/hooks/999-cpc-fixes.chroot that also misidentifies
      the architecture name for armhf.

    [ Steve Langasek ]
    * Add hooks to ubuntu-cpc to divert /bin/sync in the chroot and undivert it
      at the end. This is a general-purpose change that should be applied to
      all flavors and archs, but at the moment it's only needed on armhf+raspi2
      to work around the raspberrypi2-firmware postinst calling sync, which is
      actually warranted in the normal case.
    * If a subarch is specified for a cloud image build, don't build rootfs
      artifacts; these should come from the 'generic' build.
    * Fix architecture handling in hooks. We know we're always being invoked
      from a launchpad-buildd-like setup, which passes ARCH and SUBARCH in the
      environment, because auto/config and auto/build both rely on this. So
      don't scatter dpkg --print-architecture calls throughout, especially
      when many of these are not cross-build-aware.
    * Refactor ubuntu-cpc hooks to allow us to handle images where the root
      partition should not be partition 1.

    [ Ben Howard ]
    * ubuntu-cpc: fix hooks/032-disk-image.binary call to
      create_empty_p...

Read more...

Changed in livecd-rootfs (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for livecd-rootfs has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package live-build - 3.0~a57-1ubuntu11.4

---------------
live-build (3.0~a57-1ubuntu11.4) trusty; urgency=medium

  * Add support for the ubuntu-cpc project (LP: #1693018)

    [ Daniel Watkins ]
    * debian/patches/ubuntu-ppc64el-support.patch:
      - Handle different /boot kernel naming on ppc64el, matching powerpc
    * ubuntu-label-disks.patch
     - Apply LB_HDD_LABEL to disk images produced by lb_binary_rootfs
    * ubuntu-chroot-fs-opts.patch
     - Add options for tuning disk images produced by lb_binary_rootfs

 -- Robert C Jennings <email address hidden> Mon, 09 May 2017 02:34:47 +0000

Changed in live-build (Ubuntu Trusty):
status: Fix Committed → Fix Released
no longer affects: live-build (Ubuntu)
no longer affects: livecd-rootfs (Ubuntu)
tags: added: id-59120b5af9aad110645a1f71
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers