Mono reliably crashes on certain multithreaded code in 3.13.0-62-generic

Bug #1493943 reported by Douglas Roffel on 2015-09-09
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Trusty
Medium
Unassigned
Vivid
Medium
Unassigned
linux-lts-utopic (Ubuntu)
Undecided
Unassigned
Trusty
Medium
Unassigned

Bug Description

SRU Justification:

[Impact]
EDIT: The referenced bug was not causing the crashing.

[Fix]
None yet.

[Test Case]
If I can get a test case working without giving the code for my company's internal application, I will post it.

--

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: linux-image-3.13.0-62-generic 3.13.0-62.102
ProcVersionSignature: Ubuntu 3.13.0-62.102-generic 3.13.11-ckt24
Uname: Linux 3.13.0-62-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.12
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: droffel 1829 F.... pulseaudio
CurrentDesktop: Unity
Date: Wed Sep 9 10:28:21 2015
HibernationDevice: RESUME=UUID=c916917a-07a8-42ad-807a-b2f7c4ff9807
InstallationDate: Installed on 2015-04-15 (146 days ago)
InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140722.2)
IwConfig:
 eth0 no wireless extensions.

 lo no wireless extensions.
Lsusb:
 Bus 001 Device 002: ID 80ee:0021 VirtualBox USB Tablet
 Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: innotek GmbH VirtualBox
ProcFB: 0 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-62-generic root=UUID=51deb493-21fe-4016-9855-90d738549bff ro quiet splash crashkernel=384M-:128M crashkernel=384M-:128M vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-62-generic N/A
 linux-backports-modules-3.13.0-62-generic N/A
 linux-firmware 1.127.15
RfKill:

SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
WifiSyslog:

dmi.bios.date: 12/01/2006
dmi.bios.vendor: innotek GmbH
dmi.bios.version: VirtualBox
dmi.board.name: VirtualBox
dmi.board.vendor: Oracle Corporation
dmi.board.version: 1.2
dmi.chassis.type: 1
dmi.chassis.vendor: Oracle Corporation
dmi.modalias: dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:rvnOracleCorporation:rnVirtualBox:rvr1.2:cvnOracleCorporation:ct1:cvr:
dmi.product.name: VirtualBox
dmi.product.version: 1.2
dmi.sys.vendor: innotek GmbH

Douglas Roffel (douglas-roffel) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Medium
Chris J Arges (arges) wrote :

This is commit referred to:
commit 73459e2a1ada09a68c02cc5b73f3116fc8194b3d
Author: Paolo Bonzini <email address hidden>
Date: Thu Apr 23 13:20:18 2015 +0200

    x86: pvclock: Really remove the sched notifier for cross-cpu migrations

    This reverts commits 0a4e6be9ca17c54817cf814b4b5aa60478c6df27
    and 80f7fdb1c7f0f9266421f823964fd1962681f6ce.

$ git describe --contains 73459e2a1ada09a68c02cc5b73f3116fc8194b3d
v4.1-rc2~14^2

Since bug 1450584 backported those commits to v3.13, v3.16, v3.19 we'll have to apply this patch to all series.
This is already fixed in Wily since its v4.2.

no longer affects: linux (Ubuntu Precise)
no longer affects: linux-lts-utopic (Ubuntu Vivid)
Changed in linux-lts-utopic (Ubuntu):
status: New → Invalid
Changed in linux (Ubuntu Trusty):
status: New → In Progress
Changed in linux (Ubuntu Vivid):
status: New → In Progress
Changed in linux-lts-utopic (Ubuntu Trusty):
status: New → In Progress
Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Changed in linux (Ubuntu Vivid):
importance: Undecided → Medium
Changed in linux-lts-utopic (Ubuntu Trusty):
importance: Undecided → Medium
Changed in linux (Ubuntu Trusty):
importance: Undecided → Medium
Changed in linux (Ubuntu):
importance: Medium → Undecided
Changed in linux (Ubuntu Trusty):
assignee: nobody → Chris J Arges (arges)
Changed in linux (Ubuntu Vivid):
assignee: nobody → Chris J Arges (arges)
Changed in linux-lts-utopic (Ubuntu Trusty):
assignee: nobody → Chris J Arges (arges)
Chris J Arges (arges) wrote :

I'll work on getting this SRU'ed to the appropriate releases. Could you please share your test-case for reproducing this issue?

Douglas Roffel (douglas-roffel) wrote :

Chris: My test case unfortunately depends on an internal application that I am not able to share the code of. At the moment, I am building an older kernel version to test whether the test works properly on it. I will respond once I've determined that the bug I referenced is indeed the same one i'm dealing with here.

Chris J Arges (arges) on 2015-09-10
description: updated
Douglas Roffel (douglas-roffel) wrote :

Unfortunately, I was able to reproduce my segfault with a kernel version before the parent's bug was introduced. This implies my issue lies somewhere else. I'm pretty sure its something to do with threading in the kernel, but the referenced issue is not this one.

Changed in linux (Ubuntu):
status: Fix Released → Incomplete
Changed in linux (Ubuntu Trusty):
status: In Progress → Incomplete
Changed in linux (Ubuntu Vivid):
status: In Progress → Incomplete
Changed in linux-lts-utopic (Ubuntu Trusty):
status: In Progress → Incomplete
Douglas Roffel (douglas-roffel) wrote :

I have modified the description and status to Incomplete, as I cannot provide an adequate test (that doesn't contain proprietary code) to reproduce the issue at this time.

description: updated
Chris J Arges (arges) wrote :

Douglas,
A reproducer doesn't have to be public if you are willing to verify the bug.
I can provide a test build with the identified patch if you'd like. Let me know.
--chris

Samuel Greenway (greenwaysw) wrote :

Seems this is a reoccurring issues.

Ref. https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1450584.

Opensimulator.org project is still seeing issues with crashes giving a mono-sgen error.
http://opensimulator.org/mantis/view.php?id=7519

Chris J Arges (arges) on 2016-09-21
Changed in linux (Ubuntu Vivid):
assignee: Chris J Arges (arges) → nobody
Changed in linux-lts-utopic (Ubuntu Trusty):
assignee: Chris J Arges (arges) → nobody
Changed in linux (Ubuntu Trusty):
assignee: Chris J Arges (arges) → nobody

This bug was nominated against a series that is no longer supported, ie vivid. The bug task representing the vivid nomination is being closed as Won't Fix.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu Vivid):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.