uio_pci_generic is not available in trusty kernel package for ppc64el

Bug #1473109 reported by David Marchand on 2015-07-09
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Trusty
High
Unassigned

Bug Description

[Impact]
uio_pci_generic is not enabled in linux kernel package for ppc64el while other architectures have it enabled.
This is useful for things like DPDK.

[Test Case]
modprobe uio_pci_generic

[Fix]
CONFIG_UIO_PCI_GENERIC=m for common ubuntu config

--

Looking into git tree :

~/sources/pub/ubuntu.com/ubuntu-14.04-trusty$ git grep UIO_PCI_GENERIC debian.master/
debian.master/config/amd64/config.common.amd64:CONFIG_UIO_PCI_GENERIC=m
debian.master/config/arm64/config.common.arm64:CONFIG_UIO_PCI_GENERIC=m
debian.master/config/armhf/config.common.armhf:CONFIG_UIO_PCI_GENERIC=m
debian.master/config/i386/config.common.i386:CONFIG_UIO_PCI_GENERIC=m
debian.master/config/powerpc/config.common.powerpc:CONFIG_UIO_PCI_GENERIC=m
debian.master/config/ppc64el/config.common.ppc64el:# CONFIG_UIO_PCI_GENERIC is not set

I can't find a reason why it would be disabled only for ppc64el and I can see that utopic enables it for all architectures (common configuration).

Can we have it enabled ?
This module is used by dpdk (for example).

Thanks.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1473109

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: trusty
Chris J Arges (arges) on 2015-07-09
Changed in linux (Ubuntu):
assignee: nobody → Chris J Arges (arges)
Changed in linux (Ubuntu):
status: Incomplete → Triaged
Chris J Arges (arges) wrote :

Looks like everything 3.13+ has CONFIG_UIO_PCI_GENERIC=m except ppc64el.

Changed in linux (Ubuntu Trusty):
assignee: nobody → Chris J Arges (arges)
Changed in linux (Ubuntu):
assignee: Chris J Arges (arges) → nobody
Changed in linux (Ubuntu Trusty):
importance: Undecided → High
Changed in linux (Ubuntu):
status: Triaged → Fix Released
Changed in linux (Ubuntu Trusty):
status: New → In Progress
Chris J Arges (arges) wrote :

Sent patch to kteam ML.

description: updated
Brad Figg (brad-figg) on 2015-07-14
Changed in linux (Ubuntu Trusty):
status: In Progress → Fix Committed
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-trusty' to 'verification-done-trusty'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-trusty
Thiago Martins (martinx) wrote :

Problem fixed on both "Linux 3.13.0-63-generic" and "Linux 3.16.0-48-generic" on Trusty.

Thanks!

tags: added: verification-done-trusty
removed: trusty verification-needed-trusty
Xiang Hui (xianghui) wrote :

modprobe failed on my Ubuntu trusty environment, can anyone help take a look?

[OS]
# uname -a
Linux juju-xianghui-machine-11 3.13.0-63-generic #103-Ubuntu SMP Fri Aug 14 21:42:59 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
[TEST]
# modprobe uio_pci_generic
modprobe: FATAL: Module uio_pci_generic not found.

Chris J Arges (arges) on 2016-09-21
Changed in linux (Ubuntu Trusty):
assignee: Chris J Arges (arges) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers