Ubuntu14.04.1 kernel panics with enic driver throwing a NULL Pointer exception

Bug #1438039 reported by Srinivas on 2015-03-30
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned
Trusty
High
Unassigned
Utopic
High
Unassigned
Vivid
High
Unassigned

Bug Description

Steps to reproduce the bug:
1. Install Ubuntu 14.04.1 on the Cisco M-series server.
2. Run reboot test, OS will come up and go for graceful reboot continuously.
3. I am seeing kernel panic in 3 out of 4 Ubuntu machines . Don't know after how many iterations of reboot it happened. I checked the server 6 hours after starting the reboot test.
4. Don't know whether this panic is happening while the OS was booting or while going for reboot.

The bug has been root caused to the enic driver and a fix has been posted upstream.
Please find below the details of the patch submitted upstream.

4cfe878537cec0e9c0f84b93cc6aa9526f6942b5 enic: do tx cleanup in napi poll.

This bug is submitted for the patch to be pulled in from upstream to Ubuntu's releases.

===
break-fix: - 4cfe878537cec0e9c0f84b93cc6aa9526f6942b5

Srinivas (srinira) wrote :

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1438039

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Srinivas (srinira) wrote :

I am unable to get the logs from the machine.

BTW, the bug is already fixed and the patch is committed upstream. The details of which has been mentioned in the description.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: cherry-pick kernel-fixed-upstream trusty
Changed in linux (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
tags: added: kernel-da-key
Srinivas (srinira) wrote :

Any update on the patch being pulled?

Andy Whitcroft (apw) on 2015-06-04
description: updated
tags: added: kernel-bug-break-fix
Andy Whitcroft (apw) on 2015-06-04
Changed in linux (Ubuntu Trusty):
status: New → Confirmed
Changed in linux (Ubuntu Utopic):
status: New → Confirmed
Changed in linux (Ubuntu Vivid):
status: New → Fix Released
Changed in linux (Ubuntu):
status: Triaged → Fix Released
Joseph Salisbury (jsalisbury) wrote :

I tried to perform a cherry-pick of 4cfe87853. However, it looks like it will also need the following commits backported or cherry-picked:

7c2ce6e
b6e97c1
a145df2
8e09134
14747cd
4cfe8785

I'll try to build a test kernel with these commits, but it may be too many changes for an SRU.

In the mean time, can you test the LTS-backport-vivid kernel for Trusty? This is the kernel that comes with 14.04.3. It can be install with:

sudo apt-get install linux-generic-lts-vivid

Changed in linux (Ubuntu Vivid):
importance: Undecided → High
Changed in linux (Ubuntu Utopic):
importance: Undecided → High
Changed in linux (Ubuntu Trusty):
importance: Undecided → High
Rolf Leggewie (r0lf) wrote :

utopic has seen the end of its life and is no longer receiving any updates. Marking the utopic task for this ticket as "Won't Fix".

Changed in linux (Ubuntu Utopic):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers