Touchpad not working and cursor sliding

Bug #1430298 reported by Martin Hájek on 2015-03-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Trusty
Medium
Unassigned
Utopic
Medium
Unassigned
Vivid
Medium
Unassigned

Bug Description

I have notebook Asus K551LN and after Ubuntu installation the touchpad is not working correctly and cursor moves in intevals regularly to the left side ofdisplay. I used the recommended trick with proto.bare command added to boot line but after several months of waiting for a solution I post it here.

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: linux-image-3.16.0-31-generic 3.16.0-31.41
ProcVersionSignature: Ubuntu 3.16.0-31.41-generic 3.16.7-ckt5
Uname: Linux 3.16.0-31-generic x86_64
ApportVersion: 2.14.7-0ubuntu8.2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: martin 2058 F.... pulseaudio
 /dev/snd/controlC1: martin 2058 F.... pulseaudio
CurrentDesktop: Unity
Date: Tue Mar 10 13:16:19 2015
HibernationDevice: RESUME=UUID=e26bfdc2-9ea0-479e-b0c5-c6579c86f700
InstallationDate: Installed on 2015-01-24 (44 days ago)
InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Release amd64 (20141022.1)
MachineType: ASUSTeK COMPUTER INC. S551LN
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-31-generic root=UUID=fabefd36-c04a-493a-b350-03a1bfefa41a ro
RelatedPackageVersions:
 linux-restricted-modules-3.16.0-31-generic N/A
 linux-backports-modules-3.16.0-31-generic N/A
 linux-firmware 1.138.1
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/08/2014
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: S551LN.209
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: S551LN
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrS551LN.209:bd07/08/2014:svnASUSTeKCOMPUTERINC.:pnS551LN:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnS551LN:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.name: S551LN
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.

Martin Hájek (martin-all-mail) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Pilot6 (hanipouspilot) wrote :

You have a Focaltech touchpad.
Please try this build from 'next' directory.

https://www.dropbox.com/sh/07642x3lziqgmz9/AACGWNO5_lNnX7x7tYMoH9gka?dl=0

Pilot6 (hanipouspilot) wrote :

This touchpad is supported in upstream kernels starting with 4.0.
At the moment not all laptop models are supported by 4.9rc3. But fix has been commited for next rc.

Changed in linux (Ubuntu):
status: Confirmed → Fix Committed
Martin Hájek (martin-all-mail) wrote :

Thanks, Pilot6. It works now. I tried your builds a month ago and it did no worked.

Pilot6 (hanipouspilot) wrote :

I backported fix for your model about a week ago.

Joseph Salisbury (jsalisbury) wrote :

Commit 4ec212f003d2430b0b2748b8a3008255f39cfe13 didn't have a cc to stable. Once it lands in mainline, we should request that it be included in the upstream stable kernels, that way it makes it's way in to the Ubuntu kernels through the stable update process.

Changed in linux (Ubuntu Trusty):
status: New → Triaged
Changed in linux (Ubuntu Utopic):
status: New → Triaged
Changed in linux (Ubuntu Trusty):
importance: Undecided → Medium
Changed in linux (Ubuntu Utopic):
importance: Undecided → Medium
Changed in linux (Ubuntu Vivid):
importance: Undecided → Medium
status: Fix Committed → Triaged
tags: added: kernel-da-key trusty vivid
Pilot6 (hanipouspilot) wrote :

Joseph,

This commit will never be included in upstream stable versions. That's the problem.
They will just release 4.0 and that's it. But Ubuntu users will not have the driver till 15.10 is released.

I think this is the case, when more creative approch is needed.

tags: added: latest-bios-209
Rolf Leggewie (r0lf) wrote :

utopic has seen the end of its life and is no longer receiving any updates. Marking the utopic task for this ticket as "Won't Fix".

Changed in linux (Ubuntu Utopic):
status: Triaged → Won't Fix

This bug was nominated against a series that is no longer supported, ie vivid. The bug task representing the vivid nomination is being closed as Won't Fix.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu Vivid):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers