bcache causes task hang with 3.13 kernel

Bug #1425128 reported by James Page on 2015-02-24
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Trusty
Medium
Stefan Bader

Bug Description

We're doing some testing of bcache to see how it improves block performance in trusty; right now we're hitting a problem where processes performing filesystem operations get hung on the default 3.13 kernel:

 [ 7083.029073] INFO: task qemu-img:96548 blocked for more than 120 seconds.
 [ 7083.035797] Not tainted 3.13.0-45-generic #74-Ubuntu
 [ 7083.041325] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.

we don't see the same issue if we switch to the 3.16 hwe kernel.

Fairly easy to reproduce so can try test kernels - will also try to get a bit more debug for you on this one.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1425128

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: trusty
Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: kernel-da-key
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu Trusty):
status: New → Confirmed
importance: Undecided → Medium
Stefan Bader (smb) wrote :

I had been starting to look for bug fix type changes from 3.14 a while ago. But since we had no details about the problems that were seen on 3.13, and I think I could not reproduce things either, there was no way of verifying whether those are good to go with. Please have a look at the kernel at: http://people.canonical.com/~smb/lp1408972/ and let me know how this works for you.

Changed in linux (Ubuntu Trusty):
assignee: nobody → Stefan Bader (smb)
Stefan Bader (smb) wrote :

As 3.16 is claimed to be ok this is fixed in the development tree.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Stefan Bader (smb) wrote :

Test patches refreshed yet another time.

Changed in linux (Ubuntu Trusty):
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers