devel: hv_vss_daemon now sports a -n flag to prevent daemonisation

Bug #1408355 reported by Andy Whitcroft on 2015-01-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Andy Whitcroft
Trusty
Medium
Andy Whitcroft

Bug Description

We now have an official way to prevent hv_vss_daemon from deamonising by default, the new -n flag mirrors the hack we have been carrying for some time. We need to work out how to migrate to this new form whilst maintaining backwards compatibility.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1408355

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Andy Whitcroft (apw) on 2015-01-07
Changed in linux (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → Medium
assignee: nobody → Andy Whitcroft (apw)
milestone: none → ubuntu-15.01
Andy Whitcroft (apw) wrote :

Turns out that we do not check the passed parameters in older versions, so we can simply use -n in all cases and expect correct behaviour.

Andy Whitcroft (apw) on 2015-01-21
Changed in linux (Ubuntu Trusty):
status: New → Triaged
assignee: nobody → Andy Whitcroft (apw)
importance: Undecided → Medium
milestone: none → ubuntu-14.04.2
Changed in linux (Ubuntu):
status: Triaged → Fix Committed
Andy Whitcroft (apw) on 2015-01-21
Changed in linux (Ubuntu Trusty):
milestone: ubuntu-14.04.2 → ubuntu-14.04.3
milestone: ubuntu-14.04.3 → ubuntu-14.04.2
Andy Whitcroft (apw) on 2015-01-29
Changed in linux (Ubuntu):
milestone: ubuntu-15.01 → ubuntu-15.02
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.19.0-7.7

---------------
linux (3.19.0-7.7) vivid; urgency=low

  [ Andy Whitcroft ]

  * Release Tracking Bug
    - LP: #1426013

  [ Upstream Kernel Changes ]

  * x86/irq: Fix regression caused by commit b568b8601f05
  * cxl: Fix leaking interrupts if attach process fails
    - LP: #1415102
  * cxl: Early return from cxl_handle_fault for a shut down context
    - LP: #1415102
  * cxl: Disable AFU debug flag
    - LP: #1415102
  * cxl: Disable SPAP register when freeing SPA
    - LP: #1415102
  * cxl: remove redundant increment of hwirq
    - LP: #1415102
  * cxl: Add tracepoints
    - LP: #1415102
  * cxl: Update CXL ABI documentation
    - LP: #1415102
  * cxl: Use image state defaults for reloading FPGA
    - LP: #1415102
  * cxl: Add image control to sysfs
    - LP: #1415102
  * cxl: Enable CAPP recovery
    - LP: #1415102
  * cxl: Add ability to reset the card
    - LP: #1415102
  * cxl: Fix device_node reference counting
    - LP: #1415102
  * cxl: Export optional AFU configuration record in sysfs
    - LP: #1415102
  * cxl: Fail AFU initialisation if an invalid configuration record is
    found
    - LP: #1415102
  * cxl: Add missing return statement after handling AFU errror
    - LP: #1415102
  * powerpc/eeh: Introduce flag EEH_PE_REMOVED
    - LP: #1415102
  * powerpc/eeh: Allow to set maximal frozen times
    - LP: #1415102
  * HID: i2c-hid: Limit reads to wMaxInputLength bytes for input events
 -- Andy Whitcroft <email address hidden> Thu, 26 Feb 2015 16:00:18 +0000

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Andy Whitcroft (apw) on 2015-03-02
Changed in linux (Ubuntu Trusty):
milestone: ubuntu-14.04.2 → ubuntu-14.04.3
Andy Whitcroft (apw) on 2015-08-10
Changed in linux (Ubuntu Trusty):
milestone: ubuntu-14.04.3 → ubuntu-14.04.4
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers