ppc64le oopses and userspace process hangs in System V semaphore code

Bug #1358569 reported by Anton Blanchard on 2014-08-19
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Andy Whitcroft
Trusty
High
Andy Whitcroft
Utopic
High
Andy Whitcroft
linux-lts-utopic (Ubuntu)
Trusty
High
Andy Whitcroft

Bug Description

Canonical have been hitting issues with the System V semaphore code. Sometimes userspace processes would hang, sometimes an oops would pop.

We have been able to reproduce this. Michael Ellerman has taken a close look and two fixes have just been merged in the 3.17 merge window:

51d7d5205d33 (powerpc: Add smp_mb() to arch_spin_is_locked())
78e05b1421fa (powerpc: Add smp_mb()s to arch_spin_unlock_wait())

Could these please be merged into the Utopic and (eventually) the Trusty kernel trees?

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1358569

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu Trusty):
status: New → Incomplete
Adam Conrad (adconrad) wrote :

For the record, this hits the buildds and kills them occasionally, so we should definitely get this into both utopic and trusty.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu Trusty):
status: Incomplete → Confirmed
Andy Whitcroft (apw) wrote :

These two commits are very self contained, arch specific, and obviously safe as they only add memory barriers. Will apply for Utopic and submit for Trusty.

Changed in linux (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
Changed in linux (Ubuntu Trusty):
assignee: nobody → Andy Whitcroft (apw)
Changed in linux (Ubuntu):
importance: Undecided → High
Changed in linux (Ubuntu Trusty):
importance: Undecided → High
Adam Conrad (adconrad) wrote :

Looks like we also want these commits to fully support backporting this to trusty and pick up all the spinlock fixes in one go:

919fc6e34831d1c2b58bfb5ae261dc3facc9b269
3405d230b374b6923878b21b8d708d7db1f734ef
7179ba52889bef7e5e23f72908270e1ab2b7fc6f

Andy Whitcroft (apw) wrote :

Ok I have backported those 5 commits to trusty and built a test kernel for testing. The kernel is at the URL below. Pleas report any testing back here:

    http://people.canonical.com/~apw/lp1358569-trusty/

The individual patches are also split out at the above URL and I am attaching the overall diff.

Andy Whitcroft (apw) on 2014-08-19
Changed in linux (Ubuntu):
status: Confirmed → Fix Committed
Andy Whitcroft (apw) on 2014-08-19
Changed in linux (Ubuntu Trusty):
status: Confirmed → In Progress
tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.16.0-10.15

---------------
linux (3.16.0-10.15) utopic; urgency=low

  [ dann frazier ]

  * [debian] Fix regression with ABI subversions and backport

  [ Feng Kan ]

  * SAUCE: (no-up) irqchip:gic: change access of gicc_ctrl register to read
    modify write.
    - LP: #1357527
  * SAUCE: (no-up) arm64: optimized copy_to_user and copy_from_user
    assembly code
    - LP: #1358949

  [ Stefan Bader ]

  * SAUCE: bcache: prevent crash on changing writeback_running
    - LP: #1357295

  [ Tim Gardner ]

  * [Config] CONFIG_XFRM_STATISTICS=y
  * [Config] CONFIG_SECURITY_NETWORK_XFRM=y
  * [Config] CONFIG_SENSORS_IBMPOWERNV=m
    - LP: #1353005
  * Release Tracking Bug
    - LP: #1359783

  [ Upstream Kernel Changes ]

  * intel_idle: Broadwell support
    - LP: #1256170
  * powerpc/book3s: Add basic infrastructure to handle HMI in Linux.
    - LP: #1357108
  * powerpc/powernv: Invoke opal call to handle hmi.
    - LP: #1357108
  * powerpc/book3s: handle HMIs for cpus in nap mode.
    - LP: #1357108
  * powerpc/book3s: Fix endianess issue for HMI handling on napping cpus.
    - LP: #1357108
  * powerpc: Add smp_mb() to arch_spin_is_locked()
    - LP: #1358569
  * powerpc: Add smp_mb()s to arch_spin_unlock_wait()
    - LP: #1358569
  * hwmon: (powerpc/powernv) hwmon driver for power, fan rpm, voltage and
    temperature
    - LP: #1353005
  * tools/testing/selftests/ptrace/peeksiginfo.c: add PAGE_SIZE definition
    - LP: #1358855
  * printk: Add function to return log buffer address and size
    - LP: #1359423
  * powerpc/powernv: Interface to register/unregister opal dump region
    - LP: #1359423
  * bcache: fix crash on shutdown in passthrough mode
    - LP: #1357295
  * bcache: fix uninterruptible sleep in writeback thread
    - LP: #1357295

  [ Vinayak Kale ]

  * SAUCE: (no-up) dt-bindings: Add Potenza PMU binding
    - LP: #1357527
  * SAUCE: (no-up) arm64: dts: Add PMU node for APM X-Gene Storm SOC
    - LP: #1357527
 -- Tim Gardner <email address hidden> Fri, 15 Aug 2014 12:34:33 -0600

Changed in linux (Ubuntu Utopic):
status: Fix Committed → Fix Released
Andy Whitcroft (apw) on 2015-01-21
Changed in linux (Ubuntu Trusty):
milestone: none → ubuntu-14.04.2
Andy Whitcroft (apw) on 2015-01-29
Changed in linux (Ubuntu Trusty):
milestone: ubuntu-14.04.2 → ubuntu-14.04.3
Changed in linux-lts-utopic (Ubuntu Trusty):
milestone: none → ubuntu-14.04.2
Changed in linux-lts-utopic (Ubuntu Utopic):
status: New → Invalid
Changed in linux-lts-utopic (Ubuntu Trusty):
importance: Undecided → High
Changed in linux-lts-utopic (Ubuntu):
status: New → Invalid
Changed in linux-lts-utopic (Ubuntu Trusty):
status: New → Fix Released
assignee: nobody → Andy Whitcroft (apw)
tags: added: trusty
no longer affects: linux-lts-utopic (Ubuntu)
no longer affects: linux-lts-utopic (Ubuntu Utopic)
Changed in linux (Ubuntu Trusty):
milestone: ubuntu-14.04.3 → ubuntu-14.04.4
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers