[Lenovo ThinkPad X230] LCD Backlight dims completely when disconnecting external monitor

Bug #1313830 reported by Dustin Lundquist on 2014-04-28
44
This bug affects 9 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Trusty
High
Unassigned

Bug Description

After undocking with external DVI monitor connected to dock the laptop's internal LCD dims all the way (backlight still on, but as dim as it goes). Keyboard backlight controls cause OSD indicator to show backlight changing but no affect on LCD brightness.

Issue also reported for RedHat here: https://bugzilla.redhat.com/show_bug.cgi?id=1067071

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: linux-image-3.13.0-24-generic 3.13.0-24.46
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: dustin 2683 F.... pulseaudio
CurrentDesktop: Unity
Date: Mon Apr 28 10:13:42 2014
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=79c0f3ac-bda7-4a28-9ae1-6bb19ab0fd0d
InstallationDate: Installed on 2013-10-08 (201 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Beta amd64 (20130925.1)
MachineType: LENOVO 2306CTO
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-24-generic.efi.signed root=UUID=2f1bbe89-ca2f-4884-8fc6-8a476dd1a475 ro
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-24-generic N/A
 linux-backports-modules-3.13.0-24-generic N/A
 linux-firmware 1.127
SourcePackage: linux
UpgradeStatus: Upgraded to trusty on 2014-01-08 (109 days ago)
dmi.bios.date: 03/05/2013
dmi.bios.vendor: LENOVO
dmi.bios.version: G2ETA0WW (2.60 )
dmi.board.asset.tag: Not Available
dmi.board.name: 2306CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Defined
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvrG2ETA0WW(2.60):bd03/05/2013:svnLENOVO:pn2306CTO:pvrThinkPadX230:rvnLENOVO:rn2306CTO:rvrNotDefined:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2306CTO
dmi.product.version: ThinkPad X230
dmi.sys.vendor: LENOVO

Dustin Lundquist (dlundquist) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

Dustin Lundquist, could you please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-3.15-rc3

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: latest-bios-2.60
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
summary: - LCD Backlight dims completely when disconnecting external monitor
+ [Lenovo ThinkPad X230] LCD Backlight dims completely when disconnecting
+ external monitor
tags: added: kernel-fixed-upstream-3.14.0-031400
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: kernel-fixed-upstream-3.14
removed: kernel-fixed-upstream-3.14.0-031400
tags: added: needs-reverse-bisect
Chris J Arges (arges) wrote :

I've also had this happen on my Thinkpad T420.

Chris J Arges (arges) on 2014-06-17
Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Changed in linux (Ubuntu Trusty):
status: New → Confirmed
importance: Undecided → Medium
Changed in linux (Ubuntu):
importance: Medium → Undecided
Yaiza Bailen (ybailen) wrote :

This is happening on my T420s running 3.13.0-29

I am happy to test bisected kernels

Yaiza Bailen, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into the default Ubuntu kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Yaiza Bailen (ybailen) wrote :

Hi Cristopher,

That was already done here:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1276037

But marked as duplicated under this one.

Thanks,
Yaiza

Yaiza Bailen, no it was not, as you are not the original reporter of 1276037.

Yaiza Bailen (ybailen) wrote :

Hi Cristopher, I wasn't the reporter of 1276037 but the laptop was the same. In any case I just filled in a new bug.

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1342053

Changed in linux (Ubuntu Trusty):
assignee: nobody → Liming Wang (wangliming)
importance: Medium → High
Liming Wang (wangliming) wrote :

It's too hard to reproduce this bug because I have not the same hardware.
I have tested it on three types of laptop, but can't reproduce this bug. They are:

1. T540P with Displayport monitor
2. T440s with Displayport monitor
3. x230S with Displayport monitor. We have no external dock to touch DVI monitor.

All the laptop are installed with ubuntu 14.04 and the kernel is 3.13.0-24-generic.
I note that Yaiza Bailen has the bug on T420 and T420s with Displayport monitor, which may be
similar with my #2 laptop, but it can't be reproduced.
It seems that I need to get the same hardware to reproduce the bug.

Liming Wang (wangliming) wrote :

hi, @dlundquist , Dustin Lundquist,
Did you test it on x230 with DisplayPort monitor?
Or it only existed when x230 is plugged with DVI on the dock?
Whether can following command change the brightness of LCD?

$ echo 100 | sudo tee /sys/class/bachlight/acpi_video0/brightness

or

$ echo 600 | sudo tee /sys/class/backlight/intel_backlight/brightness

Yaiza Bailen (ybailen) wrote :

Hi,

If I log out and log in again, the brightness is recovered.

Danny Yates (mail4danny) wrote :

This also affects 2nd generation (Haswell) X1 Carbons when unplugging a DisplayPort monitor. Kernel version 3.13.0-32-generic.

Yaiza Bailen / Danny Yates, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into the default Ubuntu kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Yang Kun (YK) (dayangkuncn) wrote :

Po-Hsu Lin helped to test on a x230s, could not re-produce the issue:
========================

On 2014年07月24日 10:56, Po-Hsu Lin wrote:
> Hello,
> I've verified this on our x230s here, it cannot be reproduced.
>
> Steps:
> 1. Install 14.04, boot to desktop
> 2. Connect a external DP monitor
> 3. Disconnect it, check the brightness
> 4. Connect a external D-Sub monitor
> 5. Disconnect it, check the brightness
>
> Cheers

Danny Yates (mail4danny) wrote :

Hi Christopher. Sorry for the delay, but it turned out I wasn't subscribed to this bug. I have created a new bug https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1353429 to track my hardware and subscribed you to it as requested.

Thanks.

Xaq Rothman (xaq-rox) wrote :

I am also experiencing this problem with a Lenovo T440s.

Linux quickstone 3.13.0-34-generic #60-Ubuntu SMP Wed Aug 13 15:45:27 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

dronus (paul-geisler) wrote :

This seems to be a regression, that had happened not long ago.

Currently I am experiencing this bug with 3.13.0-44-generic (backported to Ubuntu 12.04) on a T420s. It applies to the VGA port too.

However, I used external displays from time to time, and do not experience this bug about two month ago. So for me, it appears to be added by the last two moths. However, the backported kernels may be a little delayed, so others may experience this bug earlier this year.

Xaq Rothman / dronus, thank you for your comment. So your problem and hardware may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into the default Ubuntu kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
https://wiki.ubuntu.com/Kernel/Policies/DuplicateBugs
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

As well, please do not announce in this report you created a new bug report.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

dronus (paul-geisler) wrote :

Still happens on T420s with 3.13.0-51-generic . All symptoms exactly the same.

Liming Wang (wangliming) on 2017-04-12
Changed in linux (Ubuntu Trusty):
assignee: Liming Wang (wangliming) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers