Please set CONFIG_EXT3_FS=n and CONFIG_EXT2_FS=n and CONFIG_EXT4_USE_FOR_EXT23=y

Bug #1248270 reported by Phillip Susi on 2013-11-05
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Wishlist
Tim Gardner
Trusty
Wishlist
Tim Gardner

Bug Description

When the old code is disabled the ext4 driver takes over and does a better job and gives a smaller kernel. Specifically the ext4 driver does a better job of resisting fragmentation since it uses delayed allocation, and supports online resize, whereas the ext2 driver does not.

Config changes requested:

CONFIG_EXT3_FS=y -> n
CONFIG_EXT2_FS=y -> n
CONFIG_EXT4_USE_FOR_EXT23 (NEW) -> y

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1248270

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
importance: Undecided → Medium
importance: Medium → Wishlist
status: Incomplete → Triaged
tags: added: trusty
summary: - Please set CONFIG_EXT[23]=n
+ Please set CONFIG_EXT3_FS=n and CONFIG_EXT2_FS=n and
+ EXT4_USE_FOR_EXT23=y
description: updated
summary: Please set CONFIG_EXT3_FS=n and CONFIG_EXT2_FS=n and
- EXT4_USE_FOR_EXT23=y
+ CONFIG_EXT4_USE_FOR_EXT23=y
Tim Gardner (timg-tpi) on 2013-11-26
Changed in linux (Ubuntu Trusty):
assignee: nobody → Tim Gardner (timg-tpi)
status: Triaged → In Progress
Dimitri John Ledkov (xnox) wrote :

Well, my local rebuild failed, due to checks advising one to start begging for mercy since "ext2" module got dropped.... =) i didn't do ignores before but the wikipages explain it. I wonder if chacks can verify that either ext2/3 modules are present or EXT4_USE_FOR_EXT23 is enabled.

ps. ♩♯ ♪ ♫ ♬ ♭ why won't you release me, I'm begging you for ♩♯ ♪ ♫ ♬ ♭

Phillip Susi (psusi) wrote :

What do you mean checks?

Luis Henriques (henrix) wrote :

I just came across this bug report which seems to be relevant for this bug: https://lkml.org/lkml/2013/11/27/321

Andy Whitcroft (apw) wrote :

@henrix -- that seems to be resolved by the below commit which will be in the first 3.13 upload:

  commit 30fac0f75da24dd5bb43c9e911d2039a984ac815
  Author: Jan Kara <email address hidden>
  Date: Sun Dec 8 21:11:59 2013 -0500

    ext4: Do not reserve clusters when fs doesn't support extents

Changed in linux (Ubuntu Trusty):
status: In Progress → Fix Released
Andy Whitcroft (apw) wrote :

Marking Fix Released as there is no bug marker for this.

Dimitri John Ledkov (xnox) wrote :

Andy, despite the #5 & #6 comments, this bug report is about the config change requrest to flip CONFIG_EXT2|3_FS to "n" and set CONFIG_EXT4_USE_FOR_EXT23 to "y", which I don't see applied on neither master & master-next branches.

Is this config change be applied in 3.13 kernels?

Changed in linux (Ubuntu Trusty):
status: Fix Released → In Progress
Tim Gardner (timg-tpi) wrote :

Dimitri - CONFIG_EXT4_USE_FOR_EXT23=y in the Trusty unstable branch. It will soon transition to being the production kernel, e.g., master and master-next.

Tim Gardner (timg-tpi) wrote :

linux-3.13.0-1.16

Changed in linux (Ubuntu Trusty):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints