saucy/trusty CD images are unbootable, stuck in BusyBox shell

Bug #1212977 reported by Daniel van Vugt on 2013-08-16
46
This bug affects 10 people
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
Saucy
Undecided
Unassigned
linux (Ubuntu)
High
Unassigned
Saucy
High
Unassigned
Trusty
High
Unassigned
udev (Ubuntu)
Undecided
Unassigned
Saucy
Undecided
Unassigned
Trusty
Undecided
Unassigned

Bug Description

saucy daily-live images are unbootable on Dell Optiplex 990 and other hardware combinations. I just get a BusyBox shell.

All images up to and including raring however work fine.

---
ApportVersion: 2.9.2-0ubuntu8.3
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: dan 2083 F.... pulseaudio
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
DistroRelease: Ubuntu 13.04
HibernationDevice: RESUME=UUID=9e3dac8a-8fa4-4da5-b4d2-52b2ee5fd022
InstallationDate: Installed on 2013-06-03 (76 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
IwConfig:
 eth0 no wireless extensions.

 lo no wireless extensions.
MachineType: Dell Inc. OptiPlex 990
MarkForUpload: True
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-25-generic root=UUID=416f5f80-6d98-4208-a3f5-ef272b12e5c6 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.8.0-25.37-generic 3.8.13
RelatedPackageVersions:
 linux-restricted-modules-3.8.0-25-generic N/A
 linux-backports-modules-3.8.0-25-generic N/A
 linux-firmware 1.106
RfKill:

Tags: raring
Uname: Linux 3.8.0-25-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 09/10/2011
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A07
dmi.board.name: 0D6H9T
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 15
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA07:bd09/10/2011:svnDellInc.:pnOptiPlex990:pvr01:rvnDellInc.:rn0D6H9T:rvrA00:cvnDellInc.:ct15:cvr:
dmi.product.name: OptiPlex 990
dmi.product.version: 01
dmi.sys.vendor: Dell Inc.

The bug also persists regardless of whether I boot in UEFI or legacy BIOS modes.

summary: - saucy daily-live images are unbootable on Dell Optiplex 990 stuck in
+ saucy daily-live images are unbootable on Dell Optiplex 990; stuck in
BusyBox shell
Daniel van Vugt (vanvugt) wrote :

And yes, I have checked the sha1sum's of my images after downloading them.

Daniel van Vugt (vanvugt) wrote :

The bug also persists regardless of whether I boot the image from USB or a DVD.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1212977/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1212977

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: saucy

There are no logs. The system won't boot.

Changed in linux (Ubuntu):
status: Incomplete → New

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1212977

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Would it be possible for you to test some prior releases as well, such as Raring, Quantal, or Precise?

Changed in linux (Ubuntu):
importance: Undecided → High
tags: added: kernel-key
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Daniel van Vugt (vanvugt) wrote :

Sure. I have been doing all my Ubuntu work for a couple of years on this machine without any issue, and these saucy images are the first to fail. But I can retest some old isos to verify it's not a regression of the machine itself.

Daniel van Vugt (vanvugt) wrote :

Verified the 13.04 amd64 iso boots perfectly. But I still can't boot saucy live images, even the latest ones this week.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Incomplete

apport information

tags: added: apport-collected raring
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: regression-release
removed: raring
tags: added: bios-outdated-a17
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-da-key
removed: kernel-key
Joseph Salisbury (jsalisbury) wrote :

Was there an earlier Saucy image that did work? It would be good to know if there was an early image that worked and then identify the first image that didn't work. We could then compare kernel versions and perform a bisect if needed.

tags: added: kernel-key
removed: kernel-da-key
Daniel van Vugt (vanvugt) wrote :

I can't tell. I don't boot isos on this machine very often, and can't seem to find any earlier saucy images other than the current ones:
http://cdimage.ubuntu.com/daily-live/

If anyone knows how to find the earlier saucy images then I can do some (slow) bisection.

Joseph Salisbury (jsalisbury) wrote :

One thing we could do would be to install Raring, but then boot some Saucy kernels on it, to identify the earliest kernel that did boot and the first that didn't boot. Do you think this is something you could try?

tags: added: kernel-da-key
removed: kernel-key
Daniel van Vugt (vanvugt) wrote :

I have been booting mainline kernels recently without any issue (up to 3.11.0-rc5). But can test more...

Daniel van Vugt, as per http://www.dell.com/support/troubleshooting/us/en/19/Product/optiplex-990 an update is available for your BIOS (A17). If you update to this, does it change anything?

If not, could you please both specify what happened, and provide the output of the following terminal command:
sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date

Please note your current BIOS is already in the Bug Description, so posting this on the old BIOS would not be helpful.

Thank you for your understanding.

Daniel van Vugt (vanvugt) wrote :

I cannot update the BIOS on my primary server right now. I will try later. Though it is unreasonable for us to ask users to do so, on systems which have worked flawlessly with Ubuntu for years.

Joseph Salisbury (jsalisbury) wrote :

Can you test the latest Saucy kernel with a Raring installation? The latest Saucy kernel can be downloaded from:
https://launchpad.net/ubuntu/+source/linux/3.11.0-4.9/+build/4907705

Also, does installing Saucy fail as well, or just booting live images?

tags: added: kernel-key
removed: kernel-da-key
Daniel van Vugt (vanvugt) wrote :

Tested. That saucy kernel works fine (in raring).

Booting from the latest live images fails, as does selecting Install Ubuntu from the same images. Both get stuck in the BusyBox shell.

Double-checked that the saucy image does indeed work in a different machine. Just not on the Optiplex 990.

Changed in linux (Ubuntu):
status: Incomplete → New
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

This could be a udev bug, since the Saucy kernel boots fine on a Raring install. Adding that bug task. We would like to see if there is a kernel oops or error when the failure happens. From the BusyBox prompt, can you run the dmesg command and post the output?

Joseph Salisbury (jsalisbury) wrote :

If you have an issue running dmesg, you could also run:
sudo cat /dev/kmsg

Daniel van Vugt (vanvugt) wrote :

Here's the dmesg. I'm presently using a radeon card, but usually have no graphics card installed, and get the same behaviour.

Tim Gardner (timg-tpi) wrote :

Daniel - Generally when the boot drops into BusyBox it is because the kernel cannot find a root file system, or there are bad drives in an mdadm RAID set, or other disk failures. Are there _any_ messages indicating why the boot process has been interrupted ?

Daniel van Vugt (vanvugt) wrote :

There are no error messages I can see.

See also, the log in comment #36.

Joseph Salisbury (jsalisbury) wrote :

Hi Daniel,

Can you try a few other things?

1. After the system drops to the BusyBox prompt, wait about 30s then enter CTRL-D to see if it boots.
2. Are there any messages on the console before the system drops to the BusyBox prompt? If so, can you capture a digial image if the messages/text?
3. Can you see if this issue also happens in the case of an upgrade? So install Raring, then upgrade to Saucy and see if the bug still exists. If it does, we can then try to narrow down the specific package that is causing this by re-installing Raring again, then upgrading individual packages like the kernel, udev, etc.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in casper (Ubuntu Saucy):
status: New → Confirmed
Changed in casper (Ubuntu):
status: New → Confirmed
affects: caspar (Ubuntu Saucy) → casper (Ubuntu Saucy)
Andy Whitcroft (apw) wrote :

Could we boot this with quiet/splash removed from the kernel command line (if present) and debug added (F6 gets you a menu to fiddle with the command line).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in casper (Ubuntu):
status: New → Confirmed
Changed in udev (Ubuntu):
status: New → Confirmed
Phil Wyett (u-k-i-t) wrote :

I have this issue too. I have had no issues with live iso images up until saucy.

Booting and after leaving and doing CTRL+D. I get a lovely kernel panic with the message:

    /init: line 352: can't open /root/dev/console: no such file

    Kernel panic - not syncing: Attempted to kill init! exitcode 0x00000200

Phil Wyett (u-k-i-t) wrote :

From #39 also Q3.

Doing a dist-upgrade from 13.04 is fine. There are no issuesas I have seen on the > 20 times I have done it.

David Kiefer (david-kiefer) wrote :

If it helps any, I had this problem when I tried to boot the saucy image from Aug 18. It dropped me to a busybox shell or when I selected "check this CD for errors" the machine would reboot after a few seconds.
However, I now tested it again using the image from Aug 30 and it boots fine. An older image from Aug 04 also works.
Unfortunately, I can't retest the one from Aug 18 as I've already deleted the .iso file and overwrote it both on the USB drive and on the DVD I tested it on.

The only other thing that changed (that I can think of) is that on the hard disk I wanted to install Saucy on, a partition which was a LVM2 volume containing a Fedora 13 install is now replaced with a Raring install.

Daniel van Vugt (vanvugt) wrote :

I can't test upgrades, but Ctrl+D gave me the same kernel panic as comment #45.

Removing splash/quiet and adding debug to the kernel command line only produces an uninteresting log like comment #36.

Daniel van Vugt (vanvugt) wrote :

There seem to be three of us experiencing this issue... Has anyone had any success upgrading the BIOS? I haven't had time to figure out how to make a large enough DOS image that actually fits the BIOS upgrade on it :)

Joseph Salisbury (jsalisbury) wrote :

Per comment #46, it sounds like this bug does not happen if the system is upgraded versus a fresh install. Daniel, is there any way you can test a Raring to Saucy upgrade on your system as well?

Phil Wyett (u-k-i-t) wrote :

Reply to #49

For complete cover and knowing there was a 'beta' BIOS update 'F7a' for my board and I have just done that update. Gigagytes inbuilt QFlash is great - No boot disks or Windows required. ;-)

Tested and get the same issue. The board I have which is a Gigabyte GA-97a-DS3 Rev: 1.0.

http://uk.gigabyte.com/products/product-page.aspx?pid=4122&dl=1#bios

This is not UEFI but is hybrid EFI. The tests I have just run were with EFI in all it's setting states i.e. in 'Auto', 'NON-EFI' and 'EFI'. The result is the same failure with todays live 13.10 ISO.

Joseph Salisbury (jsalisbury) wrote :

This may be related to bug 1223195 . There is a fix coming for that bug shortly, which we can have you test.

@Phil, just to confirm, you don't hit this issue if you upgrade from Raring to Saucy? It only happens for a fresh Saucy install, or when you boot a Saucy LiveCD?

Phil Wyett (u-k-i-t) wrote :

@Joseph, Never had an issue with any dist-upgrade from raring to saucy. The issue is all centred around booting with the saucy licecd image.

I have subscribed to the bug you mentioned in the comment. I will be only too happy to test any fix upon release.

Changed in casper (Ubuntu Saucy):
status: Confirmed → Invalid
Daniel van Vugt (vanvugt) wrote :

As I said, I cannot upgrade this machine. It's my production server and needs to be stable.

I only need to boot saucy for live image testing with exotic video cards. I'll do an upgrade later when saucy is stable and actually released.

Phil Wyett (u-k-i-t) wrote :

@Joseph, Tested todays ISO that includes the bug 1223195 fix and the error remains. No change agaianst this bug report at all.

Given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We are approaching release and would like to confirm if this bug is still present. Please test again with the latest development kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.11.0-7.14

The ISO of 2013-09-20 that contained the 3.11.0-7 #14 kernel does not boot and the same issue remains.

Removed tags as my hardware has the latest BIOS.

A new 3.11.0-8 #15 has landed and I will test as soon as it's runs into the latest daily ISO.

summary: - saucy daily-live images are unbootable on Dell Optiplex 990; stuck in
- BusyBox shell
+ saucy daily-live images are unbootable on Dell Optiplex 990 and other
+ hardware combinations; drops to and stuck in BusyBox shell
description: updated
tags: removed: bios-outdated-a17 bot-comment kernel-key kernel-request-3.11.0-7.14
Phil Wyett (u-k-i-t) on 2013-09-21
summary: saucy daily-live images are unbootable on Dell Optiplex 990 and other
- hardware combinations; drops to and stuck in BusyBox shell
+ hardware combinations (Gigabyte GA-970a-DS3 Rev: 1.0 motherboard); drops
+ to and stuck in BusyBox shell
Changed in linux (Ubuntu Saucy):
status: Incomplete → Confirmed

Phil Wyett, please do not adjust this report. If you have a bug in Ubuntu, please file a new report via a terminal:
ubuntu-bug linux

Pending results of https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1212977/comments/56 from Daniel van Vugt.

tags: added: bios-outdated-a17 bot-comment kernel-key kernel-request-3.11.0-7.14
summary: - saucy daily-live images are unbootable on Dell Optiplex 990 and other
- hardware combinations (Gigabyte GA-970a-DS3 Rev: 1.0 motherboard); drops
- to and stuck in BusyBox shell
+ [Dell Optiplex 990] Saucy daily-live images are unbootable, stuck in
+ BusyBox shell
Changed in linux (Ubuntu Saucy):
status: Confirmed → Incomplete
Phil Wyett (u-k-i-t) wrote :

New bug filed. I will never work a duplicate bug again. Unsubscribed.

Daniel van Vugt (vanvugt) wrote :

Confirmed no improvements, using daily-live 20130925.

Changed in linux (Ubuntu Saucy):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Hi Daniel,

I'm trying to get a hold of a Dell Optiplex 990 to debug this issue further. There is on in HW cert, and I've asked if we can borrow it to help with this bug.

no longer affects: casper (Ubuntu)
Joseph Salisbury (jsalisbury) wrote :

Hi Daniel,

I now have a Dell Optiplex 990 to test with. I downloaded and was able to boot the Saucy LiveCD from:
http://cdimage.ubuntu.com/daily-live/current/

Can you see if this bug still exists on your system, with this latest daily image?

Daniel van Vugt (vanvugt) wrote :

Tried today's images and still no luck.

What BIOS were you using on the Optiplex? I still have A07.

Joseph Salisbury (jsalisbury) wrote :

The BIOS is reported as version X31. Do you have the option of upgrading your BIOS? I'll see if there is a way to downgrade on my system.

Also, are you using Legacy or UEFI booting?

Daniel van Vugt (vanvugt) wrote :

The bug happens in both legacy and UEFI modes (comment #1).

If and when I have enough time to figure out how to make a bootable DOS image that also fits the BIOS on it, I will be able to try upgrading :P Although putting a new harddisk in and installing Windows just to get the BIOS installed might actually be faster.

Joseph Salisbury (jsalisbury) wrote :

Hi Daniel,

Just curious if you had a chance to try and upgrade the BIOS?

Daniel van Vugt (vanvugt) wrote :

Finally spent an afternoon and got the latest BIOS installed: A18.

No improvement :(

Joseph Salisbury (jsalisbury) wrote :

Thanks for testing. I'm not sure where the X31 version of BIOS my machine came from. What form factor is your machine? The one I have is the "Small form factor" model.

tags: added: bios-outdated-a18 bot-stop-nagging
removed: bios-outdated-a17 kernel-request-3.11.0-7.14
tags: added: latest-bios-a18
removed: bios-outdated-a18
Joseph Salisbury (jsalisbury) wrote :

Thanks, Daniel. I'm going to try and get my machine back to the A18 BIOS.

Just curious, what steps did you use to flash the BIOS? I was planning on using FreeDOS to boot from a USB stick, then running the BIOS executable.

Daniel van Vugt (vanvugt) wrote :

Joseph,

I installed FreeDOS to a USB stick. So I now have a FAT32 USB stick I can copy BIOS exe's onto from Ubuntu, and simply boot into. The hard part was convincing FreeDOS to install to the USB stick... I had to unplug the real harddrives to convince FreeDOS that USB was the primary drive.

But once it's installed, it's just a handy bootable USB stick.

Joseph Salisbury (jsalisbury) wrote :

Hi Daniel,

I was able to get my system to A18 of the BIOS. The X31 version was an experimental version, but surprisingly it prevented this bug. I ran some tests by installing and booting a Saucy LiveCD on the machine.

Here are some results:
BIOS set to Legacy mode and pressing F12 during boot to access Boot menu:

1. Booting LiveCD and selecting "USB Storage Device" under "LEGACY BOOT":
"Selected boot device failed."
"Press any key to reboot the system."

2. Booting LiveCD and selecting "UEFI: INT13(usb,0x81)" under "UEFI BOOT:"
I get the GRUB menu and can install or boot from LiveCD.

3. If I set BIOS to boot USB first, then I get this message:
"Attempted to Boot UEFI Volume from Legacy Mode."
"To Boot the UEFI Vollume Automatically, rather than via F12:
...
...

BIOS set to UEFI mode and pressing F12 during boot to access Boot menu:

1. Booting LiveCD and selecting "USB Storage Device" under "LEGACY BOOT":
"Selected boot device failed."
"Press any key to reboot the system."

2. Booting LiveCD and selecting "UEFI: INT13(usb,0x81)" under "UEFI BOOT:"
I get the GRUB menu and can install or boot from LiveCD.

So it appears this issue may be related to UEFI and the BIOS. Can you try the same steps I performed above and see if you get similar results? I assume booting without selecting F12 is how you reproduce this bug, but trying some of the other options might provide some additional information.

Also, it looks like you originally installed Raring on here. Do you recall if you saw any issues during that install? Do you recall if you had UEFI or Legacy boot enabled during that installation?

Daniel van Vugt (vanvugt) wrote :

Joseph,

I don't have as much luck as you do even following the same steps. It's worth noting that getting to the GRUB menu is easy using Legacy or UEFI. But the Ubuntu boot fails after that. Stuck in the BusyBox shell.

Yes, the machine still has raring installed (booted as Legacy because UEFI never really worked at least in the old BIOS). And the raring install images boot perfectly well. The only issue is with saucy images. I wonder if I can test trusty soon?

Holger Knust (hknust) wrote :

I am getting the same issues you are describing on a Dell XPS 17 L702. UEFI booting is not an available option, nor is a BIOS update (checked the Dell site for newer BIOS). I grabbed the casper.log and the dmesg output in case that provides any insights.

Holger Knust (hknust) wrote :
Joseph Salisbury (jsalisbury) wrote :

Daniel,

Testing trusty is a good idea. There is an image available at:
http://cdimage.ubuntu.com/daily-live/current/

Holger Knust (hknust) wrote :

Tried the Trusty Live CD and got the same result: Boots into Busybox

summary: - [Dell Optiplex 990] Saucy daily-live images are unbootable, stuck in
- BusyBox shell
+ saucy/trusty CD images are unbootable, stuck in BusyBox shell
description: updated
Daniel van Vugt (vanvugt) wrote :

I've got a workaround now at lease (other than upgrading). I installed saucy on a new disk in a separate machine and then transplanted the disk into the OptiPlex 990. It runs well. So whatever the problem is, it is isolated to the installation media. The problem doesn't exist after installation.

Daniel van Vugt (vanvugt) wrote :

"at least" :)

Joseph Salisbury (jsalisbury) wrote :

Thanks for the update, Daniel. I'm going to bring my system BIOS back to A07 and install Raring, to get as close to your original config as possible. Maybe that will allow me to reproduce the issue.

It still would be a good test to try the latest Trusty image.

Joseph Salisbury (jsalisbury) wrote :

For some reason, I cannot install or LiveCD boot Raring in "Legacy" mode. I can only get to the GRUB menu by setting the BIOS to use EFI. Daniel, can you see if you can boot the latest Raring image with the BIOS set to Legacy mode and selecting the legacy USB option from the F12 boot menu?

Changed in linux (Ubuntu Saucy):
status: Confirmed → Incomplete
Changed in udev (Ubuntu Saucy):
status: Confirmed → Incomplete
Changed in udev (Ubuntu Trusty):
status: Confirmed → Incomplete
Changed in linux (Ubuntu Trusty):
status: Confirmed → Incomplete
Daniel van Vugt (vanvugt) wrote :

Sorry, I can't reboot my server to test things very often. Here are some results from today:

raring LiveCD legacy: OK
raring LiveCD EFI: SOMETIMES boots, sometimes reboots post-plymouth.
raring installed legacy: OK

saucy LiveCD legacy: FAIL - stuck in BusyBox shell
saucy LiveCD EFI: FAIL - stuck in BusyBox shell
saucy installed EFI: OK (installed to the drive using a different machine)

trusty LiveCD legacy: FAIL - stuck in BusyBox shell almost all the time, but worked once today(!)
trusty LiveCD EFI: FAIL - stuck in BusyBox shell

I've also tried removing all my PCIe cards and USB devices, in case probing was a factor. But it didn't help.

Changed in linux (Ubuntu Saucy):
status: Incomplete → Confirmed
Changed in linux (Ubuntu Trusty):
status: Incomplete → Confirmed
Changed in udev (Ubuntu Saucy):
status: Incomplete → Confirmed
Changed in udev (Ubuntu Trusty):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

I think I may have been able to reproduce this today with Trusty. The system dropped to the busybox shell. It looked like there was a timeout waiting to find the root filesystem by uuid. I took a digital picture and will attach to the bug.

Daniel, can you also take a digital picture of your system when it drops to the busybox shell?

Joseph Salisbury (jsalisbury) wrote :
Joseph Salisbury (jsalisbury) wrote :

If you are seeing the same message as me, can you try using the rootdelay boot option?

From the GRUB prompt select e. Once there you can add the line "rootdelay=90" to the end of the line.

Daniel van Vugt (vanvugt) wrote :

rootdelay=90 makes no difference to me.

Image attached

Daniel van Vugt (vanvugt) wrote :

Does anyone know where to find the old saucy daily images? If I had access to them, I could (slowly) bisect the problem.

Joseph Salisbury (jsalisbury) wrote :

All the prior releases are available from:
http://releases.ubuntu.com/

However, I don't think the early daily releases are still available. It's strange that we have the same machine, but I'm unable to reproduce the bug. I'm going to compare your dmesg/lspci output to mine to see what hw diffs there are.

Daniel van Vugt (vanvugt) wrote :

It might be handy to compare details with the 5 other people who claim to be experiencing this bug too.

Joseph Salisbury (jsalisbury) wrote :

So it looks like we have a difference in hard drivers. You have an SSD drive:
INTEL SSDSC2CW12 400i PQ: 0 ANSI: 5

I have a mechanical drive:
SAMSUNG HM251HI, 2AJ10001, max UDMA/133

Do you happen to have a mechanical drive to see if you can reproduce the issue with it?

Also, can other folks affected by this bug post the output from:
dmesg | grep scsi

tags: removed: kernel-key
Changed in linux (Ubuntu Saucy):
status: Confirmed → Incomplete
Changed in linux (Ubuntu Trusty):
status: Confirmed → Incomplete
Daniel van Vugt (vanvugt) wrote :

Last I checked the bug still occurred with all drives and cards unplugged. But I will retest when I can...

This bug was nominated against a series that is no longer supported, ie saucy. The bug task representing the saucy nomination is being closed as Won't Fix.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu Saucy):
status: Incomplete → Won't Fix
Rolf Leggewie (r0lf) wrote :

saucy has seen the end of its life and is no longer receiving any updates. Marking the saucy task for this ticket as "Won't Fix".

Changed in udev (Ubuntu Saucy):
status: Confirmed → Won't Fix
robert (007wickline) on 2015-06-23
Changed in udev (Ubuntu Trusty):
status: Confirmed → Fix Released
Changed in udev (Ubuntu Trusty):
status: Fix Released → Confirmed
Changed in linux (Ubuntu):
status: Incomplete → Invalid
Changed in linux (Ubuntu Trusty):
status: Incomplete → Invalid
Changed in udev (Ubuntu):
status: Confirmed → Invalid
Changed in udev (Ubuntu Trusty):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers