[FFe] juju-core 1.18

Bug #1287147 reported by James Page on 2014-03-03
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
juju-core (Ubuntu)
High
Unassigned
Trusty
High
Unassigned

Bug Description

Ubuntu Trusty has been tracking the 1.17.x interim development release series of Juju; this series does not guarantee backwards compatibility but has allowed us to track new features and enable new architectures such as ppc64el and arm64.

The 1.18.0 release of juju-core has been released; its predominantly a rollup of the 1.17.x series of releases with a single new feature.

In addition, the 1.18.0 release will also introduce the following essential release features for 14.04:

1) Joyent Provider

All other features have been delivered in interim releases.

The HA state server and VLAN support for MAAS have not made it into this release.

James Page (james-page) on 2014-03-03
Changed in juju-core (Ubuntu):
importance: Undecided → High
James Page (james-page) wrote :

I'd like to push in juju-core 1.17.6 as an interim point release as it resolves a number of high/critical bugs (some of which are impacting on OpenStack CI testing).

This includes all fixes from:

https://launchpad.net/juju-core/+milestone/1.17.5
https://launchpad.net/juju-core/+milestone/1.17.6

Note: I declined 1.17.5 for trusty upload as it removed support for juju-mongodb - this is now restored in 1.17.6.

Changelog:

juju-core (1.17.6-0ubuntu1) UNRELEASED; urgency=medium

  * New upstream point release, including fixes for:
    - br0 not bought up by cloud-init with MAAS provider (LP: #1271144).
    - ppc64el enablement for juju/lxc (LP: #1273769).
    - juju userdata should not restart networking (LP: #1248283).
    - error detecting hardware characteristics (LP: #1276909).
    - juju instances not including the default security group (LP: #1129720).
    - juju bootstrap does not honor https_proxy (LP: #1240260).
  * d/control,rules: Drop BD on bash-completion, install bash-completion
    direct from upstream source code.
  * d/rules: Set HOME prior to generating man pages.
  * d/control: Drop alternative dependency on mongodb-server; juju now only
    works on trusty with juju-mongodb.

Testing:
Verified local provider usage on 14.04
Verified MAAS provider on 14.04 deploying 14.04
Verified OpenStack provider on 14.04 deploying 14.04

I specifically confirmed that the juju-mongodb package is being used in all of these test cases.

Note that upstream also do CI against all providers prior to release.

Build log: see attached.

James Page (james-page) wrote :
James Page (james-page) wrote :

Also an update on the upstream juju-core release schedule between now and 14.04:

1.18.0 is planned for w/c 24th March

A further 1.20.0 (might be renamed 2.0) release is planned for the first week in April (just before final freeze).

At the point where we jump to 1.18.0, I'm proposing not uploading interim dev released (1.19.x) so we have a stable series in 14.04 at all times.

Dave Walker (davewalker) wrote :

It's not really clear to me what features are being introduced by this proposed change, is there a upstream feature changelog avaliable?

Detail on the HA support and the new arch testing would be useful.

Thanks

James Page (james-page) wrote :

The HA support has not landed in 1.17 as yet (I believe that will come for 1.18 but more likely 2.0); the juju-core team have been working on supporting other archs such as ppc64el and arm64. The ppc64el stuff has been tested with the local provider and LXC.

James Page (james-page) wrote :

Dave

The majority of change is bug fixes aside from the switch to juju-mongodb for trusty and the alternative architecture enablement work.

Dave Walker (davewalker) wrote :

Ack'ing Bug fix and ppc64el/arm64 upload, as 1.17.6.

James Page (james-page) wrote :

I have a revised schedule with proposed features from the juju-core team.

juju-core 1.18 (stable release):

April 1 -- 1.17.8 ReleaseJoyent Provider lands
April 2 -- 1.18.0 Release (without HA and VLAN)
    Dependent on lp #1298663 and any other critical bugs uncovered
April 4 -- 1.18.1 Release (without HA and VLAN)
    Bug fixes only

James Page (james-page) wrote :

(please ignore #8 - fingers not working this morning :-))

I have a revised schedule with proposed features from the juju-core team.

juju-core 1.18 (stable release):

April 1 -- 1.17.8 Release
    Joyent Provider lands << NEW FEATURE

April 2 -- 1.18.0 Release (without HA and VLAN)
    Bug fixes only
April 4 -- 1.18.1 Release (without HA and VLAN)
    Bug fixes only

The 1.17.8 release will introduce a new provider to support use of juju with the Joyent cloud; I discussed this with the developer working on this feature and the code changes to the rest of juju are minimal - the new provider is relatively isolated in the source code.

juju-core 2.0 (stable release):

April 7 -- 1.19.0 Release
    VLAN landed
April 11 -- 1.19.1 Release
    Azure availability sets land
    HA landed (first phase more work needed to bring up additional state servers)
April 25 -- 2.0 Release Candidate
    HA landed in full.

As you can see, juju-core 2.0 is due for release after final freeze and 14.04 release; so I'd like to release with juju-core 1.18 as this will be the most recent stable for 14.04 release. We may wish to introduce juju 2.0 as a backport (or namespaced package) but I'll deal with that in the MRE I need to request from the technical board.

James Page (james-page) on 2014-03-31
summary: - [FFe] juju-core 1.18/2.0
+ [FFe] juju-core 1.18
James Page (james-page) wrote :
James Page (james-page) wrote :

juju-core released 1.18.0 over the weekend; this is the stable release of the 1.17.x series we have been tracking in 14.04 development.

  https://launchpad.net/juju-core/+milestone/1.18.0

Alongside some more bug fixes, this release also includes a new provider for the Joyent cloud; this is not documented in the release notes as the associated documentation is not yet complete.

Build log attached; I've tested on the local provider and the openstack provider OK; just running tests with 14.04 MAAS.

James Page (james-page) wrote :

I've now finished testing with the MAAS provider against an up-to-date MAAS install on 14.04 - all looks OK

Dave Walker (davewalker) wrote :

There seems to be some confusion or change in plans. The original description states

1.18 consists of:
1) HA of Juju state nodes
2) Full support for ppc64el and arm64

But the revised timeline says Without HA. Is HA no longer a release target? Other than supporting ppc64el and arm64, are there any other featureful changes?

Thanks.

Curtis Hovey (sinzui) wrote :

1.18.0 supports
New and Notable with 1.18.0
    https://launchpad.net/juju-core/+milestone/1.18.0

* Support for proxies
* Managing authorised ssh keys
* Backup and restore the state-server (bootstrap node)
* Run arbitrary commands on some or all instances
* Use metadata generate-tools instead of sync-tools to generated
  simple streams metadata
* The bootstrap --source option was replaced with --metadata-source
* Timeouts for bootstrap are configurable for environments
* Bootstrapping the local provider for lxc no longer requires sudo
* Juju local provider can use clone for faster LXC
* Juju now supports juju-mongodb, a mongodb tuned for juju’s needs
* The "null" provider is now called "manual" in the juju config.
* The destroy-environment command requires the environment name
* Juju unset-env
* Juju retry-provisioning
* Bash completions include flags, machines, services, and units

Also...It supports:
* Joyent Cloud.
    It is not a secret, but it is not announced until we write some beautiful documentation.
    Note that juju 1.17.7 has no support for Joyent.
* Charms define default series
    Charms can define the series they support and which is default. This permits a single charm
    to support 12.04, 14.04, and 16.04.

James Page (james-page) wrote :

Daviey - I've updated the original bug report to make things clearer; the only new feature that 1.18.0 introduces is the joyent provider.

ppc64el and arm64 have been delivered in 1.17.x releases; HA did not make the cut as its not stable enough yet.

description: updated
Dave Walker (davewalker) wrote :

Thanks fir updating. Providers tend to be isolated, and typical hardware enablement.

FFe Ack

We decided that we should land everything but HA and VLAN work this week in
a stable release to minimize the risk that either of those changes could
have on overall stability in the release. However, HA and VLAN work is
underway, and much of it has already landed, and the first HA support is
expected to land in a development release in the next several days.

On Mon, Apr 7, 2014 at 12:44 PM, Dave Walker <email address hidden> wrote:

> There seems to be some confusion or change in plans. The original
> description states
>
> 1.18 consists of:
> 1) HA of Juju state nodes
> 2) Full support for ppc64el and arm64
>
> But the revised timeline says Without HA. Is HA no longer a release
> target? Other than supporting ppc64el and arm64, are there any other
> featureful changes?
>
> Thanks.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1287147
>
> Title:
> [FFe] juju-core 1.18
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/juju-core/+bug/1287147/+subscriptions
>

Dave Walker (davewalker) wrote :

@Mark, to be clear - HA and VLAN support is not something intended for 14.04 distro release?

Changed in juju-core (Ubuntu Trusty):
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package juju-core - 1.18.0-0ubuntu1

---------------
juju-core (1.18.0-0ubuntu1) trusty; urgency=medium

  * New upstream release (LP: #1287147), including fixes for:
    - maas/lxc: LXC permission denied issue (LP: #1299588).
    - core: mega-watcher for machines does not include container
      addresses (LP: #1301464).
 -- James Page <email address hidden> Mon, 07 Apr 2014 18:24:59 +0100

Changed in juju-core (Ubuntu Trusty):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints