gnuradio-dev doesn't install liblog4cpp5-dev dependency

Bug #1358173 reported by Luis Colunga on 2014-08-18
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gnuradio (Debian)
Fix Released
Unknown
gnuradio (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
FanJun Kong - ( BH1SCW )

Bug Description

Missing liblog4cpp5-dev package makes compilation of sources requiring gnuradio-dev to fail. Example: gr-osmosdr

luis@ubuntu:~/SDR/gr-iqbal/build$ make
Scanning dependencies of target gnuradio-iqbalance
[ 7%] Building CXX object lib/CMakeFiles/gnuradio-iqbalance.dir/fix_cc.cc.o
In file included from /usr/include/gnuradio/block.h:29:0,
                 from /usr/include/gnuradio/sync_block.h:27,
                 from /home/luis/SDR/gr-iqbal/include/gnuradio/iqbalance/fix_cc.h:26,
                 from /home/luis/SDR/gr-iqbal/lib/fix_cc.cc:26:
/usr/include/gnuradio/logger.h:116:31: fatal error: log4cpp/Category.hh: No such file or directory
 #include <log4cpp/Category.hh>
                               ^
compilation terminated.
make[2]: *** [lib/CMakeFiles/gnuradio-iqbalance.dir/fix_cc.cc.o] Error 1
make[1]: *** [lib/CMakeFiles/gnuradio-iqbalance.dir/all] Error 2
make: *** [all] Error 2

Doing sudo apt-get install liblog4cpp5-dev fixes the issue.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnuradio (Ubuntu):
status: New → Confirmed
Logan Rosen (logan) wrote :

This was fixed in gnuradio 3.7.8-1, which means it's fixed in every currently supported Ubuntu release except for Trusty.

Changed in gnuradio (Ubuntu):
status: Confirmed → Fix Released
Changed in gnuradio (Debian):
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnuradio (Ubuntu Trusty):
status: New → Confirmed
Changed in gnuradio (Ubuntu Trusty):
assignee: nobody → FanJun Kong - ( BH1SCW ) (fjkong)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.