Evolution-EWS 3.12 causes Evolution to hang Utopic

Bug #1363798 reported by tim nelson on 2014-09-01
36
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
Undecided
Unassigned
evolution-ews (Ubuntu)
Undecided
Iain Lane
Trusty
High
Iain Lane

Bug Description

Fresh install, add a mail account and nothing happens after. Calendars will show up in Gnome but evolution just sits there with no UI ever popping up. Can wait hours, will not crash or do anything. If you try to open another instance you get a pop up saying it's already running.

Fresh install of UbuntuGnome both with updates turned on and off. Both times, same results. Evolution-EWS is what causes it, if you remove it it opens just fine.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in evolution (Ubuntu):
status: New → Confirmed
Gérard Bigot (gerard-bigot) wrote :

I had the same problem. The GUI simply doesn't show. Everything seems to work.

I upgraded from trusty, where my EWS configuration was OK.

I Just removed Evolution-EWS. Restarted, setup IMAP+ accounts, and the GUI is back. Less the EWS features...

Gérard Bigot (gerard-bigot) wrote :

Console start with EWS :

** (evolution:8686): WARNING **: Couldn't connect to accessibility bus: Empty address ''

(evolution:8686): GLib-GObject-WARNING **: The property GtkSettings:gtk-button-images is deprecated and shouldn't be used anymore. It will be removed in a future version.

** (evolution-alarm-notify:8707): WARNING **: Couldn't connect to accessibility bus: Empty address ''

(evolution:8686): camel-WARNING **: Failed to initialize NSS SQL database in sql:/etc/pki/nssdb: NSS error -8126

(evolution:8686): GLib-GObject-WARNING **: The property GtkSettings:gtk-cursor-blink is deprecated and shouldn't be used anymore. It will be removed in a future version.

(evolution:8686): GLib-GObject-WARNING **: The property GtkSettings:gtk-cursor-blink-time is deprecated and shouldn't be used anymore. It will be removed in a future version.

(evolution:8686): GLib-GObject-WARNING **: The property GtkSettings:gtk-cursor-blink-timeout is deprecated and shouldn't be used anymore. It will be removed in a future version.

(evolution:8686): GLib-GObject-WARNING **: The property SoupSession:use-ntlm is deprecated and shouldn't be used anymore. It will be removed in a future version.
Working around libsoup bug with redirect

(evolution:8686): GLib-GObject-WARNING **: The property GtkSettings:gtk-menu-images is deprecated and shouldn't be used anymore. It will be removed in a future version.

(evolution:8686): GLib-GObject-WARNING **: cannot register existing type 'CamelEwsStore'

(evolution:8686): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion 'G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(evolution:8686): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion 'G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(evolution:8686): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion 'G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(evolution:8686): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

Gérard Bigot (gerard-bigot) wrote :

Console start without :

** (evolution:9402): WARNING **: Couldn't connect to accessibility bus: Empty address ''

(evolution:9402): GLib-GObject-WARNING **: The property GtkSettings:gtk-button-images is deprecated and shouldn't be used anymore. It will be removed in a future version.

** (evolution-alarm-notify:9417): WARNING **: Couldn't connect to accessibility bus: Empty address ''

(evolution:9402): camel-WARNING **: Failed to initialize NSS SQL database in sql:/etc/pki/nssdb: NSS error -8126

(evolution:9402): GLib-GObject-WARNING **: The property GtkSettings:gtk-cursor-blink is deprecated and shouldn't be used anymore. It will be removed in a future version.

(evolution:9402): GLib-GObject-WARNING **: The property GtkSettings:gtk-cursor-blink-time is deprecated and shouldn't be used anymore. It will be removed in a future version.

(evolution:9402): GLib-GObject-WARNING **: The property GtkSettings:gtk-cursor-blink-timeout is deprecated and shouldn't be used anymore. It will be removed in a future version.

(evolution:9402): GLib-GObject-WARNING **: The property GtkSettings:gtk-menu-images is deprecated and shouldn't be used anymore. It will be removed in a future version.

(evolution:9402): GLib-GObject-WARNING **: The property GtkSettings:gtk-toolbar-style is deprecated and shouldn't be used anymore. It will be removed in a future version.

(evolution:9402): GLib-GObject-WARNING **: The property GtkCellRendererPixbuf:stock-id is deprecated and shouldn't be used anymore. It will be removed in a future version.

Gérard Bigot (gerard-bigot) wrote :

some extra failed asserts that I can't understand.

tim nelson (tim-l-nelson) wrote :

The same issue also occurs in the 3.12 evolution-ews in Gnome3 Team Staging PPA on Trusty as well.

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Iain Lane (laney) wrote :

Would you try 3.12.6 which should be in Utopic soon please?

Hi,

I see. I'll try.

G.

2014-09-18 10:40 GMT+02:00 Iain Lane <email address hidden>:

> Would you try 3.12.6 which should be in Utopic soon please?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1363798
>
> Title:
> Evolution-EWS 3.12 causes Evolution to hang Utopic
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/evolution/+bug/1363798/+subscriptions
>

Gérard Bigot (gerard-bigot) wrote :

Ok, the evolution-ews just appeared in the proposed pocket.

I updated it, removed all evolution process still running in my ubuntu, and started.

The same behaviour : the main evolution window doesn't appear. I see the process in a ps. I get meeting notification.

Exchange account is not even configurated. I changed for imap.

Just removing evolution-ews makes the main window (with the mail list, and the calendar tab) appear, once evolution restarted.

Gérard Bigot (gerard-bigot) wrote :

Do I need to copy/paste again the console messages ?

Iain Lane (laney) wrote :

On Thu, Sep 18, 2014 at 09:24:36AM -0000, mangouste06 wrote:
> Ok, the evolution-ews just appeared in the proposed pocket.
>
> I updated it, removed all evolution process still running in my ubuntu,
> and started.
>
> The same behaviour : the main evolution window doesn't appear. I see the
> process in a ps. I get meeting notification.
>
> Exchange account is not even configurated. I changed for imap.
>
> Just removing evolution-ews makes the main window (with the mail list,
> and the calendar tab) appear, once evolution restarted.

No need to paste anything more. Could you please file a bug with the
evolution-developers at

  https://bugzilla.gnome.org/

I think you'll want to include a backtrace. Follow the instructions to
add the debugging repository

  https://wiki.ubuntu.com/DebuggingProgramCrash#Debug_Symbol_Packages

and install evolution-dbgsym evolution-ews-dbgsym, then run

  $ gdb evolution

and follow the instructions here

  https://wiki.ubuntu.com/Backtrace#Generation

and attach the file you get to the bugzilla report. You can then link
that to this Launchpad bug by using the links near the top.

Thanks,

--
Iain Lane [ <email address hidden> ]
Debian Developer [ <email address hidden> ]
Ubuntu Developer [ <email address hidden> ]

Downloaded the Debian package evolution-ews version 3.12.6-1 and installed it. Evolution works. Must be a compile error.

Gérard Bigot (gerard-bigot) wrote :

I just did the same, and I can see the main window!! I'm back to evolution.

Could you try compare the too packets?

José Dapena Paz (jdapena) wrote :

I've just run the issue using gdb, and I found the problem is that libcamelews.so and libmodule-ews-configuration.so both define the Camel EWS types. See the attached debugging session for an example of double declaration of camel_ews_store_get_type.

Justa User (justausr) wrote :

I'd posted this issue to another thread which then pointed me back here. I applied the debian ews and things worked. Just did an update and a new evolution got installed. The hang returned. Removed the debian version of ews and reinstalled the ubuntu version. Still hangs. If I run from the command line I get the message about registering the CamelEWSStore. here is the output:

** (evolution:4243): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-Ib3KI5k2aG: Connection refused

(evolution:4243): GLib-GObject-WARNING **: The property GtkSettings:gtk-button-images is deprecated and shouldn't be used anymore. It will be removed in a future version.

(evolution:4243): Gtk-WARNING **: Failed to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

** (evolution-alarm-notify:4265): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-Ib3KI5k2aG: Connection refused

(evolution:4243): camel-WARNING **: Failed to initialize NSS SQL database in sql:/etc/pki/nssdb: NSS error -8126

(evolution:4243): GLib-GObject-WARNING **: The property GtkSettings:gtk-menu-images is deprecated and shouldn't be used anymore. It will be removed in a future version.

(evolution:4243): GLib-GObject-WARNING **: cannot register existing type 'CamelEwsStore'

(evolution:4243): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion 'G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(evolution:4243): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion 'G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(evolution:4243): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion 'G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(evolution:4243): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

Justa User (justausr) wrote :

small update. reinstall debian version and it works again.

Iain Lane (laney) wrote :

I think I've fixed this - please could somebody please test evolution-ews 3.12.6-1ubuntu1 when it becomes available for Utopic.

We should then update 14.04 with the same fix, if confirmed.

affects: evolution (Ubuntu) → evolution-ews (Ubuntu)
Changed in evolution-ews (Ubuntu):
assignee: nobody → Iain Lane (laney)
status: Confirmed → Fix Committed
Changed in evolution-ews (Ubuntu Trusty):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Iain Lane (laney)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evolution-ews - 3.12.6-1ubuntu1

---------------
evolution-ews (3.12.6-1ubuntu1) utopic; urgency=medium

  * Don't build with -Bsymbolic-functions in LDFLAGS - this causes
    evolution to hang. (See bgo#594473 for details) (LP: #1363798)
 -- Iain Lane <email address hidden> Fri, 03 Oct 2014 11:00:59 +0100

Changed in evolution-ews (Ubuntu):
status: Fix Committed → Fix Released
Gérard Bigot (gerard-bigot) wrote :

Hi,

just updated the -proposed evolution-ews.

The main window appeared. For me it's corrected.

Thanks.

2014-10-03 11:55 GMT+02:00 Iain Lane <email address hidden>:

> I think I've fixed this - please could somebody please test evolution-
> ews 3.12.6-1ubuntu1 when it becomes available for Utopic.
>
> We should then update 14.04 with the same fix, if confirmed.
>
> ** Package changed: evolution (Ubuntu) => evolution-ews (Ubuntu)
>
> ** Changed in: evolution-ews (Ubuntu)
> Status: Confirmed => Fix Committed
>
> ** Changed in: evolution-ews (Ubuntu)
> Assignee: (unassigned) => Iain Lane (laney)
>
> ** Also affects: evolution-ews (Ubuntu Trusty)
> Importance: Undecided
> Status: New
>
> ** Changed in: evolution-ews (Ubuntu Trusty)
> Status: New => Triaged
>
> ** Changed in: evolution-ews (Ubuntu Trusty)
> Importance: Undecided => High
>
> ** Changed in: evolution-ews (Ubuntu Trusty)
> Assignee: (unassigned) => Iain Lane (laney)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1363798
>
> Title:
> Evolution-EWS 3.12 causes Evolution to hang Utopic
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/evolution-ews/+bug/1363798/+subscriptions
>

Iain Lane (laney) wrote :

Hmm, actually, I can't make this happen on 14.04.

Can anyone else?

Changed in evolution-ews (Ubuntu Trusty):
status: Triaged → Incomplete

Just updated. The update in the "proposed" channel worked. The only thing that does not work is the ubuntu theme integration.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers